Fibaro dimmer 2 not dimming with scenes

New to the community. I have got a SmartThings hub controlling 3 Fibaro dimmer 2 (FGD-212) modules in one of my rooms. This works well from the switches and when I go into the device on the app to set the dimming level. The problems I’m having is when I set a scene or a routine the lights won’t go to the pre set dimming level, although the correct lights go on/off when requested through the correct scenes. Other things I’ve notice with this is that when I go in to set the dimming level manually from the device options when I slide the bar for dimming level there is no change until I use the up and down arrows for the 1st time, then it will dim using the bar. Another thing I’ve noticed is that ST app always show the modules as being on. Even when they’re switched off. Has anyone experiences anything similar are they able to help?