Fibaro dimmer 2 new issues


I’ve had a fibaro dimmer 2 installed with a retractive switch for about a year. Never touched the settings since it was first installed. Using the stoxk handler.

The initial operation could be describes as:

  • pressing and releasing the “up” section of the switch switched the lights on at the same level they were before. Double pressing “up” went to full brightness.

  • pressing and holding “up” slowly raised the lighting level. Release to leave it there.

  • pressing and releasing “down” turned the lights off.

  • pressing and holding “down” slowly lowered the lighting level.

Now there have been a few firmware updates to the hub and it’s knacked various bits along the way, later to be fixed. I had noticed a while ago that pressing the “up” button occasionally failed to switch the lights on, but for whatever reason, thought nothing of it. The majority of the time the lights are controlled via software, unless they’re getting switched off in which case its generally the physical switch.

I have finally realised that for whatever reason, I’m now unable to turn the lights on at the switch. Software switches on fine. Physical switch switches off fine.

No wiring has been altered from day one.

I’ve now messed with the settings so much over the past day that I can’t recall how it should be set in terms of parameters.

I’m not sure why or when it’s failed to work as it should (and as it did), but I was hoping someone could tell me which way the parameters should be set? It’s a little frustrating. Thanks!

I had a similar problem few weeks back with my retractive switch in the end couldn’t get it working so went back to using a toggle switch which isn’t ideal but at least it let’s me turn the lights off and on.
Sorry this doesn’t help but thought I would let you know your not alone with these issues, constantly having issues with z wave devices it’s getting tiresome. :pensive:

1 Like

Agreed on the tiresome front.

It’s enough hassle to get things purchased, installed and configured the first time around without one day noticing that for some reason, they just don’t work anymore.

I’ve tried every combination of parameter and I cannot get this thing to work. It’s as if the DTH is incomplete. But this has definitely worked without issue in the past.

Update - my retractive switch is now a waste of time. The functionality has definitely been lost. Since nothing has changed, I can only assume that it’s down to either the hub firmware changing something, or an update to the stock DTH ?

For reference, I now have to have it set as a ‘momentary’ instead of ‘roller blind’.

I press a physical down button once - light comes on. Press again, light off. Press and hold - light brightens. Press and hold again, light dims. Press and hold again, light brightens…and so on.

The “up” button seems to do nothing but allow a single press to flick the lights back off.

It’s really odd. And it’s not how it’s supposed to work, nor is it intuitive.

1 Like

Christ the performance of this is horrendous now. It used to be instantaneous, now sometimes there are considerable delays to the dimmer level physically changing after the software slider is altered. Sometimes the slider shows a completely different value, the bulb never ‘catches up’, needing to be changed again to initiate a real change.

Anyone have any suggestions please?

Are you using the new app as it can be very slow at times. Otherwise it sounds like a server lag more than lag from the actual fibaro itself.

Nah, still the old app. Zero changes to hardware.