SmartThings Community

Fibaro Dimmer 2 (FGD-212) Pairs but Doesn't Work


(D Bagus Handhoko) #34

Main system of my home is comfort from cytech.biz . A small part of the devices that i have are 15 lamps of fibaro dimmer 212 . Recently i add amazon dot to my system, so i need smartthings to communicate with my comfort. My comfort has interface to zwave but not as good as smartthings


(David Jacobs) #35

THanks for advice anyway. I have a Wealthy friend who can help :grinning:


(D Bagus Handhoko) #36

Robin/Adam.

I success to make it ST as secondary controller ( i think ) of HC lite controller, by add device menu not add secondary controller. Also can control from amazon alexa. ST acknowledge as fibaro dimmer ( maybe as FGD 211 ).,… the strange one if i change to fibaro dimmer 2 handler become not function ( can not control from ST )

Am I make a mistake ?


(Robin) #37

I have no idea how ST will behave as a secondary???

What Device handler are your trying for the dimmer 2 though?


(D Bagus Handhoko) #38

as secondary seem work okay, i can turn on/off and also dim the light. I try the @hajar one


(codersaur) #39

FYI, I’ve just published version 2 of my Fibaro Dimmer 2 advanced device handler. It was originally based on hajar’s device handler but I’ve added lots of extra functionality into it including full parameter synchronisation, multi-channel device associations, protection modes, fault reporting, and advanced logging options. :grinning:

See here: [RELEASE] Fibaro Dimmer 2 (FGD-212) - Advanced DTH (V2)

All feedback welcome!


(Steve) #40

Hi. Following this thread with great interest. I thought I had the savvy for such things but this is blieing my mind. I have ST and trying to connect dimmer 2 to lighting circuit. All wired ok but not working on switch. From what I can tell the dimmer comes set to momentary switch mode rather than toggle for standard uk switches. I understand I need to add the programming to ST. But I can’t work out how I do this so I can edit the default settings of the dimmer 2

TIA Steve


(Robin) #41

Use the advanced device handler provided by @zcapr17

You can then click the cog symbol (when viewing the device in the ST app) and you will see the parameter settings… in there you can change between switch types.


(Robin) #42

(Robin) #43

(Steve) #44

any ideas why I cant copy the code? I can select all but no copy , even Ctrl C not working

steve


(Robin) #45

Copy from where? GitHub?


(Tefo Giliana) #46

Is the above advice still applicable? I am new on ST and need help setting up ST Hub with Fibaro dimmer 2 as well.


(Robin) #47

I suggest you use the latest device handler code, but otherwise the install process etc is unchanged:


(Tefo Giliana) #48

Thanks Robin. The experienced people like yourself make it a little bit easier for some like me. I will give feedback on how this goes. On the other hand is there any handler you can recommend for fibaro switch 2 gen5??


(Tefo Giliana) #49

I have connected the Fibaro double switch using both the S1 and S2 but cannot find the S2 on ST, even after downloading the Multi-Channel Control SmartApp. Can someone help please. I do not know what to do next


(Robin) #50

I replied to you on a different thread… are you get confused between the double switch module and the dimmer 2 module?


(Tefo Giliana) #51

The dimmer is fine but on the switch 2 I only see the main switch (S1).


(Daffydave) #52

HI hoping someone could help me, i’m new to smartthings, i have installed at fibaro dimmer 2, iv created the device handler from codesaur V.2.2, added my device and can see the device iv been through the settings in smartthings and changed it to toggle switch, (as this is what im using) and set all the other parameters that highlight in red and tried to force sync but it doesn’t seem to sync i, then turned force sync off and went back to the app, i seem to be seeing the live values from the dimmer module, as i can turn the light on and off from the wall switch and it shows on app that it shows on and off but it still says SYNC Pending and the switch and dimmer functions don’t work.? what have i missed?


(Byron Guernsey) #53

I’m having the same issue as you. The ‘builtin’ device handler for the Fibaro Dimmer 2 works fine with the smartthings app, but not Alexa. Alexa can turn the fibaro Dimmer off and on just fine. I can adjust the dimming with the smartthings app fine. But if I ask alexa to adjust the light dimming, it says “ok” and nothing happens. Smartthings shows that Alexa call setlevel, but nothing happens.

So I tried the device handler mentioned in the thread above- the newer version. When I assigned it in the dimmer configuration I saw the same results that you did. No longer could I control the dimmer, but I saw the state of it. Sync would not work. Basically, the device handler @zcapr17 doesn’t appear to be working at all. My hope was that it would fix the issues I’m seeing with Alexa integration- but it made them worse. I switched back to the device handler that it defaulted to and now at least I can turn the dimmer on/off with alexa.

If someone can point me in the right direction, I’d appreciate it. I presume that the device handler it throwing an error somewhere. I don’t know where detailed logs would be- but I’ve looked around and found nothing.

I just want to get dimming working with Alexa. That’s why I bought the Fibaro Dimmer 2…and so its disappointing that it works otherwise just fine, but not with Alexa dimming requests. Its hard to believe the app works, but the alexa smart-things integration doesn’t, even though smartthings “recently” tab shows the Alexa setlevel request.