FAQ: Zwave repair not working (how to fix error messages)

Those are the routes. Nothing is going through the aeotex extender for some reason. Although it’s in between :frowning:

For what it’s worth, I have three Aeotec Range Extender 6. They are in in my box of unused devices.

My Z-wave mesh is 100% mains powered Z-wave Plus devices.

There was a point when I was first installing devices that I thought the Range Extenders were being useful. Then I read their manual and saw they should flash the LED each time they relayed a message. Never, ever saw that.

I was also getting Z-wave repair errors. I unplugged all the Range Extenders.

If your devices are working, and are finding a route to the hub, I suggest removing the Range Extender.

1 Like

I would. But they the devices that having the issue are very slow and I guess if they went through the extender the issue would be solved. If only I could do it so myself

You can’t control the routing in a Z-wave mesh. And there’s not one static route between devices so what you’re seeing in the IDE is a little misleading.

I used to stress over routing because the IDE was showing devices crisscrossing the house. I’ve learned to just let it be.

In place of the Aeotec, try adding some other mains powered device. The obvious choice would be a plug-in Z-wave socket.

Does anyone know how to remove ghost z-wave devices on a V1 Hub? My hub has been going offline since it started happening, so I think its related.

I had two light switches that have been long dead… the relay inside was toast, so I had removed them from automation, but I had not replaced them. When I went to replace them, I could not exclude, since the two switches were not working properly. I deleted them in the IDE added my new switches, and now when I do a zwave repair, it fails for devices that are not in my device list.

I tried doing a general device exclusion but the switches do not add or remove unfortunately. Not sure what to try next.

What I’ve done to remove ghost devices is:

  1. Using the IDE, create a new device with a name you can easily identify. I usually create a virtual switch. Assign it to the appropriate Location and Hub.
  2. Give things a few minutes to propagate
  3. Using your app, delete the device. You’ll probably have to force delete.

I did this a few days ago and happened to have the hub events log open in a window. I saw some Z-wave deletion messages.

1 Like

Unfortunately force deleting fails. It gets stuck ‘Deleting device’ for a very long time, and then presents me again with the option to force delete. The second attempt does the same thing.

I can see in the logs it restarting the zwave, but thats it.

[ 2020-11-18 11:48:16.000 AM PST
*8 minutes ago* ](https://graph.api.smartthings.com/hub/?all=&source=true&max=25) HUB zwStatus ready Z-Wave is ready
[ 2020-11-18 11:48:12.000 AM PST
*8 minutes ago* ](https://graph.api.smartthings.com/hub/?all=&source=true&max=25) HUB zwStatus starting up Z-Wave starting up
[ 2020-11-18 11:48:10.000 AM PST
*8 minutes ago* ](https://graph.api.smartthings.com/hub/?all=&source=true&max=25) HUB zwStatus power cycle Z-Wave power cycle started

In that case, go ahead and delete the created devices using the IDE.

I went thru a period where force-deleting didn’t work and had to resort to the IDE. No idea why.

and use same network ID as the ghost device

Just exterminated a ghost yesterday following these directions FAQ: How to remove ghost devices from your z-wave and zigbee networks

1 Like

Ah! Yes, key point! Duh!

Deleted in IDE, but only one was removed, the other still show failed in z-wave repair.

Tired to repeat with that one again, tried force delete. Didn’t work again. Delete it in the IDE.

That one still shows as failed in the repair.

We did successfully get one out though

------- Scratch that -----

Just rebooted, did another repair, both devices are showing in the zwave repair failure

I think you’re at the limit of what us mere mortals can do. Time to queue up at SmartThings support and get them to dig about in the guts of the system

I actually started with them, they told me that I had to exclude the device. But with a broken device they said I was out of options. Maybe I will try adding an actual device instead of a virtual device and matching the ID

I’ve had a case in with Support for the same thing for a few days now. They said they needed time to look into it but haven’t gotten back with a solution yet.

Phone support or Email? Email has been a round robin for me lately

Email. I’m planning on replying back to their message with a request for update today.

Since I can’t see anything detrimental by having these ghost devices, I’m almost tempted to just let it be. I’m concerned that attempts to eliminate them might botch my configuration in some way.

If they are in the system as z-wave devices it’s at least theoretically possible some other devices would try to route thru the ghost

And from what I’ve experienced, the ZWave stack in the 3x.x firmware is much, much less tolerant of issues. Id not stop trying to eliminate them

1 Like

Support hooked me up and got both of them taken care of. Thanks.

2 Likes