FAQ: Did we lose the ability to add custom smartapps after the app update of June 2021?

In case anyone wondered, there doesn’t appear to be any way to do this with voice navigation. :disappointed_relieved:



I’m sorry, there must be some phone specific bug at play with this. I’ve held it for 30 second and never see the effect described. I’m using an Iphone XS with the next-to-latest version of iOS. Not working for me.

Keep trying… it took about 5 attempts before I got it. It was not a fun experience.

I was able to add custom apps by using an iPad with the previous SmartThings app version, luckily it was dead and didn’t automatically update. Once I added the apps, it showed up on my phone in the new app.

I haven’t been able to activate developer mode in either apps though, but doesn’t look like I need to with the approach I took. Going to keep my iPad with the previous app version for now.

Then I must be looking for a single pixel. It either ends up opening the “About” screen or never turns away from gray, no matter how long I hold it.

1 Like

To add Developer mode to the ST app…

login into the developer site first at This link

Then in the ST app go to

Menu > settings

Press down on the “About SmartThngs” field
The background color changes to a darker shade as you are pressing and about 5 seconds later the background changes to white so you stop pressing at that point.

Then scroll down to see developer mode at the bottom of that screen.


Thanks - appreciate your help. It’s got to be something with the device. I know different iPhones have different haptic and 3D functionality. I just rebooted the phone and tried again, same result. I will continue to try, but I’m thinking something isn’t working on my phone. I have been reluctant to upgrade my wife’s phone, but maybe that’s another approach. Thanks again.

Just got it, apparently you need to have logged in to the devceloper portal at SmartThings . developer .​samsung.com


Yes - this did it for me too (login developer portal).

Nice! This worked for me too. Great find.

Worked! Thank you.

Outstanding… this worked thank you. But I can’t find the Homebridge v2 in the Smartapps.

Did you click Publish → For Me?

Thank you for dealing with this idiot… that worked. Just bought a Pi and trying to set this all up. It is a little more of a challenge than I expected with SmartThings. Especially since ST just changed the app and all the instructions online deal with the old app. Thank you again.

1 Like

You guys saved me. Thanks for this!

1 Like

I was able to activate Developer Mode and see my legacy (Groovy) SmartApps, but my new SmartApp developed under the new process isn’t showing, even though it was previously installed and configured before this new ST app rolled out. If I select Add SmartApp from the menu, I can see my new SmartApp, but when I select it the window closes (takes me back to the Automations tab), and the app isn’t added. My new SmartApp is still working, but I can’t add it to the ST app so I can change the configuration options.

Anyone else having this issue or figured out a fix?

Which smartapp?

In the automations section, did you scroll tO the bottom of the screen? See your other smartapps there?

I do see all of my Groovy SmartApps, but not the new one I created. It’s a webhook SmartApp developed under the new process.

Tagging @nayelyz

Thanks, @jkp!
Make sure you deployed your SmartApp at the Developer Workspace, @JFry. It doesn’t appear in the list otherwise.

1 Like