FAQ: CONFIRMED: Local Processing - Working Device Handlers

Regarding smart sense motion

Are you sure?

Mine is local and shows temperature in the SmartThings app.

See screenshots

Not 100% sure what you mean but ‘SmartSense Motion/Temperature Sensor’ used to be local but it isn’t anymore.

You’re right, I jumped the gun and checked the wrong DH. I show that SmartSense Motion Sensor is still running locally (not sure what issues others are experiencing). Re-added device to the list on the first post.

I’m wondering if this is due to them wanting to push the larger ZigBee delays out. They can change it in the cloud faster than firmware updates.

Anyone noticing some devices with the dimmer switch handler being local and others with the same handler not showing on the list?
For some reason I have some GE Z-wave dimmers not showing as local devices.

Not sure about that, but there has definitely been something going on with the device type handlers for the GE switches. Several people reporting that the LEDs begin operating differently on different switches in their home even though they themselves have not made any changes. Which sounds to me like some back end DTH change, although I don’t know that for sure.

Well, I can tell you now that after I went to the IDE and manually updated every device that is supposed to run local, they appeared back in the local device list. This is probably another glitch introduced by the ST end. I’m opening a ticket so they know about this, even though I’ll probably get a dumb reply from someone in support saying they are not seeing anything in my account.

Edit: If someone is seeing something similar, please reference my ticket number #304771

1 Like

Why is there only one SmartApp that can run locally? For that matter, why can’t everything run locally?

I fail to see the logic behind the requirement for everything to be processed in the cloud. If it’s a hardware limitation, then why not offer some controller software that can be installed on a local PC?

Because SmartThings was architected as a cloud-centric system (for many reasons, including, quite likely, the desire to keep costs low for initial launch). Remember – this was a very small Kickstarter crowed-funded product and company.

As per various announcements over the past 1.25 years, the attempt to squeeze a hybrid-architecture onto the existing platform ran into more problems than expected; that’s why we’ve ended up with Hub V2 with “limited” abilities.

SmartThings is most certainly reworking their platform (both cloud and hub) to better facilitate local processing. But you can find a few dozen threads where it’s pretty clear that the cloud will always play a major role regardless and the reasons for and against are discussed at length.

The current recommendation: Patience. The product will improve.

1 Like

I would buy a v3 if it comes with full local processing support but i think i might just fall into another marketing scam… My v2 hub is basically gathering dust now.

1 Like

Hi Xtropy,
Do you happen to know if there is any working handler for Netvox ZigBee devices?
I have just purchased a UK Hub v2 and tried to pair some zigbee devices that I have from netvox and it does not work… any help would be welcome…

Created a new topic for you, in order to avoid hijacking this one, which is about devices that run locally.

3 Likes

All… thanks for all info on here related to local devices. As someone who has programmed their home with many smart automations and now has no Internet acces due to a recent windstorm, I was initially shocked to find out that all of my motion activated automations no longer worked even thought the V2 Hub had power. To clarify for all of us who just don’t have time to dig into this… I recently migrated my motion centers from smartthings to Aeon due to the “reset” problem where the zigbee motion sensors appear to stop working until you reset the motion sensor, So it looks like I fixed the reset problem but now apparently have the “won’t work locally” problem because the driver is not one that is listed in the first entry to this thread. So, to clarify:

   1. If I go into the IDE and edit my sensor type from "Aeon Multisensor 6" to "Smartsense Motion Sensor" or "Smartsense Motion" than my motion triggered routines in the smartlighting app should work fine ? I know I'll be missing some of the more sophisticated sensor capabilities in the Aeon Multisensor, but I really don't use those anyway.
    2. Is there a mechanism to select certain drivers and download them to the hub manually so your devices can operate locally ? Maybe even replace one of the current local drivers with code from the Aeon Multisensor 6 code ?

Thanks.

You have to make sure that the DTH is for a device using the same protocol (zigbee, Z wave, Wi-Fi, etc.) as the device that you are assigning to it. Otherwise it won’t work at all.

All of the SmartThings branded sensors are zigbee, and the aeotec are zwave, so unfortunately that won’t work. You need to find a local Z wave sensor DTH instead.

That said, as the first post in this thread says, most of the Aeotec Devices do have local DTHs. (Aeon Labs is the company, Aeotec is the model line)

Aeon Home Energy Meter
Aeon Home Energy Meter + C3
Aeon Illuminator Module
Aeon Key Fob
Aeon Minimote
Aeon Multisensor
Aeon Multisensor Gen5
Aeon Outlet
Aeon Siren

1 Like

As far as what runs locally, only DTHs that the company has decided to distribute with the firmware that is given to all customers. At the present time there is no way to load your own code in to run locally or to use any custom code or for that matter any DTHs that the company did not select for universal distribution. They’ve said they’d like to change that at some point, but no timeline.

Since this thread is just an FAQ to list the various device types that do run locally, please take any further follow on discussion about how local processing works or what future features we might like to see to the following thread instead.

Due to railroad construction work my fibre connection has been working intermittently at best over the last couple of months.

All usual signs of non responding hub, but one interesting find: IKEAs Trådfri LED lights are working locally using the standard dimmeable zigbee DH.

1 Like

EDIT: Correct. (pre-edit information I gave is incorrect)

None of my custom DTH run local.

I would guess it’s probably the SmartApp not the the DTH. I recommend that you exclusively use Lighting Automation smartapp for those motion automation. Lighting Automation SmartApp runs locally.

1 Like

That just ain’t true; unless there has been a major change in the SmartThings Platform architecture that wasn’t announced!

That’s because there is no mechanism in the Platform at this time to post a custom DTH to the Hub.

Every DTH has to be manually reviewed by SmartThings and incorporated into their firmware in order to execute on the Hub.

4 Likes