FAQ: Common issues encountered migrating from a SmartThings to Samsung account (or: "Help! My hub/devices have disappeared!")

Does the just updated STSC app allow for merging devices across locations so that I can get down to one? I don’t see a device “tab”, and when I go into devices, it doesn’t seem to have a “Location” to select. Seems like those steps relate to the app as it was before the last update, or I’m lost.

1 Like

I don’t think so.

Why do you have stuff in more than one Location?

Ask Samsung. Everything worked until last night.

:cry: :confounded: :frowning_face: :poop:

I suspect I’ll just be redoing all my automations and setups this weekend, and manually redoing the devices. I ended up with two homes, the one the devices except the Harmony and Ecobee and mobile device presenses along with all the automations, etc, and the other with the all the lights, sensors, and hub. So all the devices are in a “home” with no automations.

Also broke Google Home and Echo.

I must have been “migrated”.

I have a very similar situation.
After opening the new app, everything got messed up. My current status is as follows:
-About half of my devices AND my HUB have moved to a new location
-The other half of devices and all automations/apps stayed in original location.

So my questions are:
-With Classic app or IDE is there a way to move my HUB to the original location?
-With Classic app or IDE is there a way to move devices from one location to another?

In the Classic app, is everything showing there?

Yes, but split between two locations.

You will need to contact ST support at https://support.smartthings.com

1 Like

Problem is I emailed them two days ago now, and no response. By the time I’m home at night, they’re closed. Guess Saturday I’ll have to call, because after breaking my house setup, they seem to be unable to respond. I suspect it’s because they did this to a number of us.

I have added the following to my first post of this thread…

Important Notice - since February 17, 2019 there have been some users reporting the creation of multiple locations after opening the STSC app with the result of their hub, devices and Automations being separated in those locations. In this case, please open a ticket with ST support. None of the methods noted above will help you resolve this issue. Please note: Do not delete anything at this point but wait for Support to assist. Also, report this issue in the following thread and tag @Brad_ST

(New app and multiple locations... is it possible?)

1 Like

I just tried to call support, and was given a call back queue time of 2 hours, 41 minutes.

EDIT: After waiting 3 hours, the summary of my call was that I had to fix it all myself. They cannot move devices, automations, or the hubs into one consolidated location. I asked if there was any kind of master ticket or any tracking of this situation where some of our installs were broken this week, and he said there was not. I kept mentioning this thread, and even read him jkp’s last post about reporting to support.

Since I sent an email Thursday night and have still not had a response, and phone support was a waste of time, I assume I just have to bite the bullet and start deleting and re-adding devices into the new location, then redoing the automations that are not working.

I’m pretty put out that he didn’t even open a ticket to a higher level of support. He was nice, but those of us affected just seem screwed by Samsung’s software update.

1 Like

tagging @Brad_ST to see if he can offer you any advice

1 Like

Got an email late last night after I’d started moving things from Samsung Support in response to my Thursday email:

Thanks for reaching out.

I believe I see the issue you are running into but will need to get a couple additional eyes on it from some other members of the team. Please hold tight for us and don’t start setting anything back up yet, I want to see if we can get everything up and running as easily as possible for you.

Thanks for your patience and if you have any questions in the meantime don’t hesitate to let me know.

I’ll update if they find a solution. Unfortunately, to get stuff working, I’d already spent a couple of hours updating the new location.

1 Like

Forgot to update, but after a couple of days, the email support team was able to restore a lot of my setup. Still had to put stuff in rooms again, and lost some devices. But it was much more manageable.

Amazon Echo was a pain to get set back up because it wouldn’t discover the devices that moved back to the location with all th automations. Had to disconnect SmartThings and reconnect/discover several times to finally get it to work.

On the other hand, Google Home was simple to get the devices back into a controllable state.


So I think I screwed up by migrating 2 hubs to the same Samsung account. I called support but was offered very little help.

My first hub is at my parents house and I refrained from migrating that account to my Samsung account because I was afraid it would screw everything up and I think I may have done just that. Recently I had to go into their hub using my old Smartthings account to make a few changes and do some general maintenance and was eventually “forced” to migrate their hub to the new app so I could get rid of that giant message that covers half the screen, preventing me from being able to easily find devices and such. I already migrated my hub months ago to my Samsung account so I figured I’d use the same account for their hub and if it caused issues I assumed I would be able to later open a new Samsung account and link their hub to that. Now I feel stupid for thinking that because I don’t think there is a way to actually do that.

Since I’ve done this I keep running into issues I didn’t have before. Now if I want to install an app onto my parents’ hub I have to actually log into Smartthings classic app using my old Smartthings account otherwise I just do not see the apps at all. This is fine for now but what happens when Samsung decides to no longer allow us to use our old accounts to log in to the app? I assume at that point I’m screwed?

Another odd issue I have only effects my phone presence sensor and nobody else’s. Multiple times a day I will have to rename my presence sensor because it automatically keeps changing to “Jeremy (lastname’s) Jeremy’s Galaxy Note 9” on both hubs. It’s truly annoying having to keep changing it and I would just deal with it except that very occasionally (once or twice a week) my presence will also duplicate in both hubs rendering the previous one useless and forcing me to go into each hub to update the automatons and pistons to the new presence sensor. I do not know for sure if these issues are related in any way but it does seem they are.

There are a few other minor issues which aren’t that important yet but if they ever decide to make the classic app unusable then these issues will be unavoidable for me. I will not talk about that now because I don’t want to make this post longer than it already is.

I have spent many many hours setting everything up for the past 3 years on my parents’ hub (even more time spent on my own hub) to have it exactly the way they want it so I really want to avoid having to reset either hub. I am just too busy now to spend that much time doing it all over again so if anybody using multiple hubs has any idea what I can do to fix this I would really appreciate it.

Have you contacted customer support and if so, do you have a support ticket # you can share?

I do have a support ticket but that is for some smartapps that can not be deleted from IDE (19060800467).

When I brought up the other issues I mentioned above I was just told to basically wait for Smartthings to eventually sort out the issues over time.

Ok , thanks,.right now on both apps i have a hub attached to each location. I thought about leaving the v2 hu disconnected until I migrate the devices to the new v3 hub.then deleting the.other location. Is that possible? Just double checking

yes. you can have two locations with a hub each. Technically you can have one location with two hub, too.

1 Like