Failing Console Window

After some time developing any given SmartApp - published or not - the Console window starts to fail.

This is similar to Console not working

The problem I have is that it is not browser specific, and if I copy the code, delete the app and create a new app with the original code - it starts working again.

It’s almost like there is a memory leak or something like that preventing the console from displaying.

I can see the data in “Logs” - but it’s a pain switching between screens.

I noticed the same behavior, but I assumed it’s a problem with my code.

Debugging is a serious problem in the but when log is not working.

Yeah… I find it a little wonky as well. My experience has been that just refreshing the page returns normal operation (make sure your saved first)

I’ve tried that - it seems to be tied to the application - even changing browsers (or dumping cookies etc) doesn’t resurrect the Console.

I’m having a problem with console logging. It was running like a rock for weeks and today it started disappearing. I tried logging out, refreshing screen, dropped the app, started a new app from templates and its still not logging.

Any ideas are appreciated if you have a workaround!