Fade between 2 levels (GE dimmers)

Hey Everyone.

One thing that I have not yet been able to figure out is to get all my lights to fade between brightness levels when I go between different moods.

I have philips hue bulbs and GE dimmer switches throughout my house and when I go from one mood to another (these are setup in Webcore when a certain routine executes) only my Philips lights fade. My GE dimmer switches just jumps to that new level and it just don’t feel right. Going between moods should be smooth (at least for me) else it just feels glitchy.

I might be wrong but I feel like doing this as a Scene in SmartThings it does fade GE dimmers smoothly BUT Scenes in SmartThings are not the best since it’s very slow and it does not change everything at one time.

So my question would be, anyone know of any custom device handler for GE switches that allows them to fade smoothly between 2 values? I found some where you can change the time of on/off ramp, but not anything where you can configure how fast it should fade between 2 values.

Looking forward to hearing back from the community on this issue.

Best,
Mikael

GE switches have two different parameters that can be configured to control dimming:

http://www.ezzwave.com/advanced-operation/

Both the number of steps (or levels) that the dimmer will change and the timing of the steps can be modified to suit personal preferences. The timing of the steps can be adjusted in 10 millisecond intervals. As an example, the default setting for parameter 8 is “3”. This means that the lighting level will change every 30 milliseconds when the Dim Command is received. A value of 255 would mean that the level would change every 2.55 seconds. Combined, the two parameters allow dim rate adjustments from 10 milliseconds to 4.2 minutes to go from maximum-to-minimum or minimum-to-maximum brightness levels.

Most device type handlers will allow you to do this, I believe including the stock handler. Go to the device in your things list, go to its details screen, and there should be a tiny gears icon that you can click on to get to the parameters that are exposed.

If the DTH doesn’t expose them, you can temporarily change to the Z wave tweaker and do it that way.

2 Likes

Just tried this and it did not work.

I set Parameter 8 to 10 just to check and then in the app changed levels from 80 to 20 but it just jumped. Also tried in WebCoRE and same there, just made the jump.’

Maybe I am doing something wrong here.

What was parameter 7 set to? If you only have one step, it’s going to jump. You need multiple steps to make a fade.

I tried setting both 7 & 8 to value 10 but still just getting the jump.

I get the On/Off timing to work (changing values for parameter 11 & 12).

So you set it for 100 milliseconds Between steps (that’s a 10th of a second) with 10 total steps. That means it’s doing the whole fade in a total of one second. To the human eye that’s going to look like a single jump.

If you just want to see if the parameters are working, set parameter 8 to 255. That would give you 2 1/2 seconds between levels, you definitely should be able to notice that.

Just tried that and I still get just a jump going between 2 levels.

Strange cause the All ON/OFF works when I tweak it. Maybe the dim feature does not work when setting the level in webCoRE or manually using the level bar in the SmartThings app?

Could be, I’m not sure. Did it change the fade rate when you physically press the switch on the wall?

If so, then, yeah, maybe it’s not working that way for network commands.

Have you tried asking in the webcore forum to see if anyone has another way to do it?

This discussion is well underway on the webCoRE forum… not sure if it has reached a conclusion though:

1 Like

Yea, seems like many people are having the same issue but does not seem like anyone cracked that nut yet.

1 Like