Evolve Glass Series T100R Thermostat works with SmartThings

For those who may be interested in Evolve’s line of residential thermos, I recently got 2 Glass Series T100R’s to replace both my Honeywell YTH8320ZW1007 thermos that kept loosing connection to my hub: Honeywell ZW1007/U Thermos failing with "communication lost"

These have almost the same physical dimensions as the Honeywell thermo, are more contemporary in design, have a smaller screen, and don’t have touchscreens. Setting them up is a breeze. Menu system is straight forward instead of the number codes used by Honeywell. I have the Evolve’s on both a standard HVAC and a heat pump HVAC, and they work perfectly. There’s also a “fan cycler” fan mode (aka circulation on the Honeywell) that you can adjust how long it runs and for how long the off time is set to create a custom fan cycle.

ST’s standard Z-Wave Thermostat device type works perfectly, but I prefer to use my own that replaces the sliders and adds text to the temperature tile.

Here’s more info from Evolve (H-hospitality series is in the link, but it’s the same for the R - residential). The thermo is nicer in real life than what the pictures show. It also comes in black.


@johnconstantelo Thanks for the link back here. Do you have the link to your app? I really like it!

Do you know how to remove these from the network? I’m having some issues where when this comes on, it’s turning on a light, so i want to try to remove and add back in to see if that helps (post here)

Also just a general question - if you go to your scheduler and try to set a heating schedule, are you able to do it? I have two units, two different firmware versions, and one of them can’t be programmed to heat. We returned it and got a replacement. Just curious if you’ve had this issue and what firmware you’re on.


Hi @ironadam. I remember your post a while back. You definitely have something odd going on. Support wasn’t any help?

To remove these from ST, first make sure no SmartApps are linked to the thermo by checking the device in the app. Tap the gear and then tap on the SmartApps tile. If nothing is listed, you’re good to go. Next tap on the Preferences tile. In there you’ll see where to remove the device. Start that process, and it should ask you to exclude the device. Now go to the thermo’s setting for installing to a zwave network and select NO. You may have to do this a few times. Just keep selecting NO until the app says the device has been excluded. Try to avoid forcing an exclude/delete.

I haven’t tried setting any schedules yet directly on the thermos, but I can give that a shot. Both of my thermos are at firmware version 02.02.36, zwave version 4.54, with date codes of 1347 and 1348.

Here’s a link to the device type I’m using:


Regardless if you use this device type, or ST default one, make sure to tap the Config tile to get the right supported mode and fan mode set up.

Thanks so much for the detailed instructions. I’m still going back with support. THere is nothing in the logs indicating what is going on with my stuff, but we finally (today) found out that turning on this thermostat turns on the light/siren. Very strange right? now that we’ve diagnosed what is turning it on (and i’ve removed the thermostat now per your instructions and tried turning it on, and the light doesn’t come on, so something weird is happening in the zwave network), I’m hoping we can make some progress on solving it.

So I went into the thermostat and when I click the configure tile, nothing happens. I added it back to the network using the RC45 (i think) thermostat, and adds in easy, but I’m not able to configure anything. Is that normal? I’m going to try the device type above and see if that works! I’m curious too because I’ve noticed that the thermostats sometimes randomly change operational modes (e.g. Heat to OFF). It mostly goes that direction, Heat to Off. Do yours ever do this?


@johnconstantelo By the way, I added that device type and changed my thermostat to that device type. I’m on android, and when i click on the mode, it changes a few times then goes to … and won’t change from that. Also hitting the + / - tiles do not change the temperature. Is there something that I’m doing wrong on setup?


You will not see anything in the app at all after tapping on Config. It just sets proper parameters and tells ST what modes the thermo is capable of using in the device type.

After changing the device type, make sure to log off the app on the phone, and I also recommend for Android users to clear cache via Application Manager, and using task manager to close down the app. Log back in to the ST app and things should look normal assuming the thermo has sent data, or you’ve tapped Refresh or a polling period was met. Somethings that may take a bit.

I’ve never had that problem. That is certainly not normal by any means. Where do you see that change in the display? On the left side, or did the mode actually change along the bottom of the screen?

When you see “…” that means it’s going from one mode to another, and depending on how fast the device is changing and talking back to the hub, the quicker it should move from one mode to the next, including Off. The same applies to +/- tiles. I’ve noticed just a couple/few seconds delay, but nothing out of the ordinary. How far from the hub are your thermos?

@johnconstantelo btw, the firmware version of 2.02.36 is the one that is working correctly. So looks like you are good. 02.02.39 is the one we have that is not.

I did get the app working so looks like all good. Clearing cache and reboot is the key! Thanks again


@ironadam, excellent! Glad to know the firmware is good too.

I’m not sure when you captured the code for the device type, but I updated it last night to include 2 new tiles. One is for the Unit’s operating state and the other is for the Fan’s operating state. Now you can just bring up the thermo in the app and see everything instead of looking at the Activity tile for those two states.

Wow, so I’m super late in replying. Work caught up to me and have not had time to play around with my devices. So I want to use your latest code…do I still just use the link you shared above to get the latest?

Thanks again for the help

@ironadam, yup use the link I have above.

I know it’s been a while since this thread was active, but I have the Trane version of this thermostat and was wondering if the device type still works. If so do you have a working link for it?

Absolutely, but it’s changed a lot since then (for the better):


Thanks! I’m very new to smartthings, but ill give it a try.

Welcome to ST and the community! We’re all here to help. Since you’re new, be sure to check out how to add your own code: