Error when saving or creating smartapps?

I’ve been having difficulty making changes to my smartapps. Whenever I click save, or try to import updated code via github, I get the following error in the IDE:

groovy.lang.MissingPropertyException: No such property: id for class: java.lang.String

Any idea what I could be doing wrong?

It’s not giving you a line number for the error?
Post a link to the code…

I get that error even if I try to create the sample app…

I tried copy/pasting the IFTTT app in, and I get the same error.

Ah, I did some binary-search code copy/paste, weirdly enough, I had a description block like:

definition( name: "Soy dev SmartThings", namespace: "hfwang", author: "Hsiu-Fan Wang", description: "Exposes a smartthings hub to the vagries of soy chat.", category: "", iconUrl: "https://s3.amazonaws.com/smartapp-icons/Convenience/Cat-Convenience.png", iconX2Url: "https://s3.amazonaws.com/smartapp-icons/Convenience/Cat-Convenience@2x.png", iconX3Url: "https://s3.amazonaws.com/smartapp-icons/Convenience/Cat-Convenience@2x.png")

Note the empty string in category. I put in one of the other categories (I used “SmartThings Internal”), and then everything worked fine.

1 Like

For me, the issue was that when I created the sample app and selected “Safety & Security”, it auto-generated “Safety & Security” in the code. Apparently what this error really means is that the Category isn’t an exact match for one of their pre-defined categories. I changed it to “Safety & Security” in the code and it saves now.

BTW, this happened with a new app, no changes to the core auto-generated code.

There’s an error currently when the category has an “&” in it. As a workaround, if you look at the generated SmartApp code, you can remove the amp; then it should work.

So for example, change category: "Safety & Security" to category: "Safety & Security".

1 Like