Error trying to view "My Device Handlers" in Web IDE

ide

#1

I was working on a Device Handler for my new device but keep getting…
Oh No! Something Went Wrong!
Error
500: Internal Server Error
URI
/ide/devices
Reference Id
74813c29-c2a6-40a0-8344-b42b5f883ba4
Date
Fri Oct 21 02:16:27 UTC 2016

When I click on “My Device handlers”. Looks like the other Tabs at the top of the IDE page all continue to work. I submitted a ticket two days ago. The 2nd tier tech said that it would be done by COB, that was Tuesday. Has this happened to anyone else? Is there a solution? Will Samsung Support fix this?

Thanks!


(Eric) #2

Do you have the Core dashboard open?


#3

Other people have reported the same problem this month, but SmartThings staff said it’s related to a different problem that has to do with timeouts.

See the bug reports page in the community – created wiki for links to the discussion threads

http://thingsthataresmart.wiki/index.php?title=Bug:_First_Reports


#4

@whoismoses , thanks for the quick reply. What is the Core Dashboard? I googled it but got a bunch of links to Milestone 1? – I’m new to SmartThings development, though I’ve been a developer for a few decades and have SmartThings in my own house.


(Eric) #5

It must not be your issue if you don’t know what it is.

It is an app that allows you to setup complex rules for automation.


#6

Support finally got back to me. I had added, then committed and pushed a directory with a space in it from my local repository to my devices directory in github. I didn’t know that was bad. It would be nice if the error message contained some sort of clue as to why it failed I could have fixed it right away without having to email, call, email, email, and email support over three days.