SmartThings Community

Error installing SmartApp


(T) #1

I am just getting started and trying to install a device handler for a monoprice z-wave plus multi sensor. I copied the code and then get this message when I click Create:

No signature of method: script_app_metadata_b266a064_b427_4a29_8e55_932fd26dc287.metadata() is applicable for argument types: (script_app_metadata_b266a064_b427_4a29_8e55_932fd26dc287$_run_closure1) values: [script_app_metadata_b266a064_b427_4a29_8e55_932fd26dc287$_run_closure1@7ba51280] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)re)


(Jason "The Enabler" as deemed so by @Smart) #2

Make sure you are installing the device handler code in the device handler section, not the smartapp section.


(T) #3

Thanks, that was the problem. I was able to install it as a device handler but still not sure how to link it to the device in my SmartThings app. I see the device with only a option for SmartApps.


(Tyler Durden) #4

You can change which device handler a device uses from the IDE. This topic is a good overview. The step I’m referring to is in Section II of this post after it talks about SmartApps.

FAQ: An Overview of Using Custom Code in SmartThings


(T) #5

Got it, works now, Thanks.