Error: Failed to save page credentials - Harmony Hub


(john) #1

Hi all,
I have read the many threads dealing with the Error above most threads are 2015, with the trail ending at a cloud to cloud fix arriving. I can say I have the same issue when adding my Logitech Harmony Hubs (2 hubs) with 9 activities.

I get the Error: Failed to save page credentials.

I have the latest version of the Harmony Hub Firmware


(Greg) #2

My harmony was going along smoothly until I added a bunch of activities over the weekend. Now I can’t sync them because of the Failed to save page credentials. Error.

Would love to know how this is solved. I can’t even remove the harmony smartapp and start over.


#3

I am having the same problem. I have a new setup. Last night I was able to add one activity without a problem. Tonight I tried add a second one and get failed to save … Creditials error


(Jay Bloomfield) #4

Yep, same here. This just started to happen for me today.


(OL) #5

Same problem here - got Harmony hub yesterday, spent whole night with this credential saving error… Would be great to have a solution.


#6

I was pleasantly surprised to see an email with a few things to try. When I got home, I tried them with no luck, and replied to their email. They promptly responded with this:
It’s not just you: I was able to recreate the exact same problem on the office iPhone and on my personal iPhone. If you have an Android device (or even a Windows phone), you should be able to configure the Harmony right this instant.

If not, don’t worry. Our Engineers are already aware of the errors (again, multiple people have reported this issue) and should have a fix issued really soon. I’ve tagged your account, so as soon as we have more info, an email will automatically be sent out to you.


#7

Last night I tried one more time before I went to bed. It finally worked!


(Paul Montag) #8

I’m having this problem as well. Something is broken here.


(OL) #9

ST issued app update on May 7th - it works now, can save credentials. Though the integration with Harmony hub works fine, the link with Amazon Eco / Alexa is cumbersome - Alexa sends commands to Harmony through ST, but then reports that the device is not responding “Sorry, the device NAME is not responding”…