Err 101 - ZW module not responding

Well my day is starting off great.
None of my z-wave device are responding.
My Zigbee devices are working fine.
I ran a z-wave repair and it just never finishes.
It seems that the z-wave radio might have taken a dump.
Not sure what happened but it keeps failing a z-wave repair for devices that I do not have.
I have several plug in modules that I excluded from the network, and then BOOM! this happened.

Not sure how to repair this. I’ve rebooted the hub several times and ran multiple z-wave repairs.

Look for a thread that is covering this issue. @Kristopher had major ‘fun’ with this not too long ago.

Yeah I did… I didn’t find any resolution

There is currently a Really weird Sonos problem where what appears to be runaway polling of the Sonos makes zwave devices unavailable. I know that makes absolutely no sense from an engineering side, but it is what’s happening. Probably something in account management.

Anyway, for the Sonos people, Support is telling them to remove the Sonos devices, and then suddenly magically the Zwave devices start working again.

I know you’ve been playing around with echo notifications and landroid. Why don’t you try removing that and see if by any chance you have something like the Sonos issue going on. Again, from an engineering standpoint none of this makes any sense, but is what’s happening on the Sonos side, so it might be worth a try.

1 Like

Odd, my hub has been unplugged with no batteries for 45 minutes and I’ve received nothing about it being offline.

Logs state that it has been disconnected, nothing else.

And the hub status shows active.

So what? The servers have no idea where my hub is? That could mean a back-end problem?

1 Like

@jdroberts that makes way more sense than you know.

I do not have Sonos, but I do have a hue hub… And that thing has been doing an almost constant polling for the past few days.

I thought it was odd. It’s polling the system every couple of minutes.

But all of the Phillips lights and zigbee ge bulbs are still working, plus there local control items, unless they have Zwave item involved.

I’ll try it when I get home.

Fantastic! I recently added my Sonos back and just noticed that my z-wave t-stats are not working. I was just troubleshooting now to see why. From logs everything looks clean like it’s working, but in reality the set points are not being changed. I wonder if this may be the issue. I think Santa is coming back and is bringing Nests because I am tired of troubleshooting ST’s nonsensical issues!

You know, one the logs my devices are showing like they are changing, but aren’t.

Also, the ST app still shows my hub as active… It’s not even plugged in!

Sorry man, that does sound like something is messed up with your hub, possibly. I ran the z-wave repair and one of the t-stats failed. I cut off the power and turned it back on and I am back in business. Phew…

Ok, I seriously doubt this is a problem on my end…

1 - hub is showing currently active in the ide and the app
2 - hub was physically unplugged with no batteries two hours ago.
3 - the use shows one of my lights turned on 35 minutes ago at the switch, which is odd because it’s a ge bulb ran on a dumb switch.

This is just getting more strange by the minute.

Sorry man - that one looks really bad. When I was getting that issue, it was 5 minutes and 5 seconds after a repair, exactly, and consistently. Yours looks like its happening irregularly and sometimes right after a cold boot.

Do you have any Enerwave PIR sensors by the way?


Might want to start a separate thread for this one… But my theory on that is as follows:

The Sonos (and some of the other UPNP integrations like Hue) lazily listen in on all traffic moving around on the Hub. If something is getting parsed wrong, I suspect it just stops the event loops and then that’s that.

And trust me @SBDOBRESCU - I have my share of unbelievably stupid Nest issues still too. If I had to do it again I probably would have gone in a different direction – maybe Ecobee.


1 Like


Just saw your further post.

1 - hub is showing currently active in the ide and the app

This was a symtom I had with the 101 error as well :frowning: I kept disconnecting via the IDE as well and then pinging via the IDE to get the Hub back when I restarted. You’re still screwed though…

Yes, I have one ceiling mounted one.
No problems with it.

This all started when I removed 6 plug ibn modules and tried to add an ecolink motion sensor.

Thanks buddy! !!!

1 Like

I have zillions of the Ecolink sensors – they’re pretty good. I’m super convinced the Enerwave is the root of your issue and I would not readd it when you rebuild everything. You’re the 4th person I’ve seen have the 101 error with one of those in the network. I think it does something goofy with the routing that ends up poisoning the network, even though the device itself works “ok”. You can see my past struggles with that stupid device in the forum too :frowning:

Another point of advice too - when you start adding devices into the network, repair often. It makes the future repairs go faster, and also you can narrow down issues with devices as they come.


@bravenel @mikemaxwel
So I saw you guys talking about a way to back up apps… I’m so being that right about now

1 Like

Yeah, no one company is perfect. As long as the issues are temporary or easy to fix, have no reason to replace my t-stats. The problem is that ST failed in ways that required lots of troubleshooting to identify the problems so now every little hiccup brings angst of a new wave of countless hours spent chasing ghosts. Luckily, my system has been fairly stabil for the past few weeks, and I hope stays that way. Hope yours is fine after you re did it.


@Kristopher @SBDOBRESCU @JDRoberts

I’m about to take the entire system down. I’ve taken screen shots of all rules to aid in the rebuild.

I have a Minimote v1 updated to the newest firmware. That should help in the exclusions, though I haven’t gotten it to work yet, but I believe that’s because of this problem.

Now, any advice you can give to ease this process is greatly appreciated.

I plan to do it like this:
Step 1 - remove echo smart app and hue smart app. ***Should I go ahead and remove ask smartapp or will the be deleted with the hub reset? ***
Step 2 - factory reset hub, reboot, then unplug it
Step 3 - use Minimote to devices, or just factory reset them, whichever works the fastest.
Step 4 - reboot hub
Step 5 - rebuild network devices
Step 6 - rebuild smart app library
Step 7 - document the hell out of this asking the way for next time.