Enerwave ZWN-BPC Z-wave Ceiling Mounted, Battery Powered PIR Sensor

I bought one of these a while back and finally got around to mounting it and adding it to the network. I mounted mine in the garage.

Initial inclusion:
Pain in the butt. It is an officially supported device, but it connects as a z-wave door sensor. Even when excluded and then included under the actual device. I went into the app and changed it to a z-wave motion sensor and it works great.

Device type:
I am using @bridaus device type. Just because I can. It works great.

Summary:
The sensor is super sensitive and works perfect for the garage. I have my lights set to go on when the house door opens or when the garage door opens or when there is motion. With a 15 minute delay for off after the open events or when there is no longer motion. This one picks up the slightest movement meaning my lights do not go off until I leave the garage.

I’m going to buy more of them.

Edit:
@bridaus, will you do me a favor and add the ability to change the timeout on this thing back into your code? If not, that’s cool. Thanks.

I will, just give me a week or so if you don’t mind. Busy time. It will be a separate button in order to keep device inclusion reliable.

1 Like

I paired two of these last night, couldn’t get them to work properly until I installed the custom device type. They seem to work great once connected properly.

1 Like

Maybe I got lucky. I set mine to 25% sensitivity and connected it. At first it came up as an open/close sensor but when I went to remove it it then listed as a z-wave motion sensor. Works great. Even turned up the sensitivity to 50% without any issues so now it works well in my living room with vaulted ceiling.

I had all kinds of trouble, but it was all my fault… I managed to freeze muy hub and everything I was doing was useless until I rebooted it.

I have it set to 100% and picks up everything. It’s perfect for my garage.

Look great so far thank you bridaus!!!

i tried everything, i reboot the hub, exclude and pair again and my sensor always shows motion ON :frowning:
any solution T_T

I’m having the exact same issue.

I’m pretty sure you have already done this, but is worth asking…

  1. Exclude the device from the app.
  2. Run a general device exclusion even if the first time was successful. I did this twice more… Just to be on the safe side. But this studio probably won’t be successful if the device was successfully excluded by step one.
  3. In the API deserve the custom device type. Refresh the page or log out and back in, just to make sure it’s gone. I’ve been fooled by glitches in the system before.
  4. Reboot the hub
  5. While the hub is rebooting do a system reset on the device (it can’t hurt plus you have a couple of minutes to kill)
  6. go back into the API and create the custom device type. Make sure it’s saved and published.
  7. Add the device back to the system. Make sure you have the battery out of the device, start the search procedure in the app, put the battery in, count to 2 and press the button on the back. Count to 2 again and press it again if it isn’t found.
    *note during this step it may need a quick press, or a long press. I’ve noticed it sends to be different with different devices.

After all of this you should be good. This is what I went through to get mine working. After I figured out that I had frozen my hub.

Good luck.

1 Like

I always seem to have better exclusion reliability with the minimote. The hub exclusion mode seems to be hit or miss.

1 Like

I’ve actually not attempted that. Do you know where I can find the directions for this?

hi , exactly what device type???

The minimote has an ‘exclude’ button. Press it, then press the appropriate button on the device to enter exclusion mode. Be within a a footish. You’ll get a blue light on the minimote confirming that it’s actually been excluded. I’ve had such an easier time with the minimote for device resets vs the hub.
Edit: I typically exclude via smartthings first to avoid zombie devices, and then exclude with the remote. Seems that sometimes smartthings fails to fully exclude from the zwave network but still deletes it from its internal ‘graph’ database.

This one…

1 Like

Hi @bridaus

Thank you very much for this device type, it works great for me!

Do you think it will be possible to add a “reset time” shorter between movements.
I would like the motion to turn inactive after 2 seconds for example. If we could make it modifiable in “Edit Device” it will be fantastic!

Please let me know, Happy new year!

FYI — sending out constant movement notifications with 2second spacing will possibly cause congestion on your zwave network and will certainly chew thru your batteries in short order.

Just curious, does anyone have any of these they are wanting to get rid of?

Thank you for your answer @codytruscott, I am aware of the battery life if i report more frequent movements.

However, I still need to be able to change the “reset value” on inactive movement faster as this procedure is crucial to mode changing in my configuration…

Does anybody has a suggestion?

I believe the device only supports motion down to 15 seconds.

My device type is a simpler version of another to “rescue” borked devices. You could try the other device type but it only sets in minutes.

I’ve been working on my device type to add back configuration, but my borked devices won’t take any commands. Still working on that.

Thank you for the answer @bridaus.

Could i force the motion to reset to inactive X seconds after motion was detected as active?

Please let me know what i should change in the code to make it editable in configuration on my phone.

Thank a lot!