Electric Baseboard thermostat control via ST

Hi @PhantomZ, @Luvien and @MichaelS,

The entries you see in the activity feed is the true behavior of the thermostat.
This thermostat controls a baseboard heater with 15 seconds cycle to achieve better control and comfort.
So if the power bar is halfway, you could expect the baseboard to be On 7.5 seconds and Off 7.5 seconds.
So it’s not polling, but the thermostat reports its current heating state every time the load state changes.

The thermostat does not report the energy consumption as such, but the On/Off pattern could be extracted and analyzed to reach that goal.

I hope that answers your question.

@Luvien, the zipcode can be entered in the IDE or in the “Edit Device” menu from the device handler.


Thanks for the answer, that makes sense! Is there a way to disable those notifications or maybe an update of some sort you could consider? Imagine my house with 12 thermostat, it would generate a lot of traffic on the zwave network and within the Smartthings app…

Another question regarding switching from comfort to eco via zwave. In the manual, it says to use a basic command 0x00 and 0xFF… I can’t see how to do it with Rule Machine. If you look at a post I made earlier, I was able to do the switching between modes by sending the “setThermostatMode” command with a string value of “eco” or “comfort”. Is it the right way to do it?

Thanks and great support so far:)

1 Like


Right now, there is no way to disable the notifications, but I will take a note of it.

I do have a question about the notifications issue you have.
I do have 12 thermostats myself and I do not see such notifications on my phone. I can see them in the activity feed, but I’m wondering what is annoying with this?

Do you have setup your SmartThings app to push notifications on your phone for every activity feed entry?

Regarding your other question, there is two ways to change between modes in the STZW402+ thermostat.
You may either use the Z-Wave Basic Set command or use the Z-Wave Thermostat Mode Set command.
By using the “SetThermostatMode” command from the device handler, it sends a Z-Wave Thermostat Mode Set command, so this is a legit way to do it.

Hi @PhantomZ,

This seems great!
However, do you have to do this for all of your thermostats?
Is there any way you could set a rule for multiple thermostats at once?

Hello J-F,

Thank you for the answer. With the zipcode, the outside temperature is reporting on the thermostat!

I would really like to see the consumption. I understand this is not possible even with a firmware update. Maybe in the next model! :slightly_smiling:



I only see the notifications in the “Activity Feed” of the Smartthings app. It’s just that I’ve got other rules/devices putting notifications in the activity feed and I can’t see those because the thermostat is flooding the window!

As for the programmation of the rules to switch the thermostat mode, yes I’m able to select more than 1 thermostat in the rule…
So, if my home mode goes from “Home” to “Away”, it switches all thermostat to “eco”. When I comeback, it does the opposite.

As I said earlier, so far it’s a really nice product!

Hi again,

I made a change in the Device Handler that should be included in the next update (March 3rd if everything goes well).

This update would change two things:

  1. Change in the labels: “Heat Setpoint” becomes “Setpoint” and “Apply” becomes “Go”.
    This is a workaround for the ST font issue.
  2. A new setting in the Preferences located in the “Edit Device” menu: Detailed Heating Notification.
    If set to “No”, you won’t see the Heating/Idle pattern in the activity feed.
1 Like

Hey J-F,

Excellent, that’s great news! It’s nice to see that your company is involve on the scene! It’s rare that we can talk to one of the developer who actually works on the product.

Thanks again!


Hi everyone,

I am happy to announce that Sinopé is currently working on a driver to integrate their Web thermostats to SmartThings and it should be available soon. I will post another comment here as soon as it’s ready or you can consult our API page on our Website.

Thank you and have a great day!


Hi J-F,

Any news on the update? Do we have something to do on the client side or it will updates automatically?


Hi Rick,

Due to some “coordination and technical issues” on ST side, there will be no deployment this week.
I’ve been told to expect the deployment next week.

Once the update is pushed, all you need to do is:

  1. Go in your Stelpro Ki Thermostat device from the ST app
  2. Go into the “Edit Device” menu
  3. Have the “Do you want a detailed operating state notification?” setting set to “No”
  4. Repeat steps 1 to 3 for all your Stelpro Ki Thermostat devices

Then you’re all set!

I don’t know how to program…
Do you know of a feature / smartapp / device type that I can use?

The smartthing iOS update fixed the stelpro font size issue I was having. Still having issues with programming an Eco/comfort toggle via rulemachine but it may be user error.

Hi Dan,

Good to know the font issue has been fixed.

Let me walk you through the Eco/Comfort custom commands creation via Rule Machine.
I have an Android tablet, so I hope your iOS device will behave the same…

  1. Make sure you have created a SmartApp with the “Rule Machine” source code
  2. Make sure you have created a SmartApp with the “Rule” source code
  3. Have both SmartApp “Published for me”
  4. Add the SmartApp to your account.
  5. From the “My Apps” menu click on Rule Machine
  6. Under “Expert Features” click on “Custom Commands”
  7. In “Select capability for test device” select “Thermostat”
  8. In “Select thermostat to test for commands” select your Stelpro Ki Thermostat
  9. Click on “New custom command”
  10. Click on “Select custom command”
  11. Select “setThermostatMode”
  12. Click on “Parameters”
  13. Click on “parameter type”
  14. Select “string”
  15. In “string value”, enter "eco"without the quotation marks (make sure it’s lower case)
  16. Click “Done”
  17. Click on “Save command now”
  18. Click “Done”
  19. Click on “Parameters”
  20. Click on “string value”
  21. In “string value”, enter "comfort"without the quotation marks (make sure it’s lower case)
  22. Click “Done”
  23. Click on “Save command now”
  24. Click “Done”
  25. Click “Done”
  26. You should now be back in the “Custom Commands” page and you should see 2 commands under “Saved commands”: setThermostatMode(‘comfort’) and setThermostatMode(‘eco’)
  27. Click “Done”
  28. Back on the “Installed Rules, Triggers and Actions” page, click on Create New Rule
  29. Define whatever name and trigger you want for you rule
  30. Click on “Define Actions”
  31. Name your action to something meaningful for you
  32. Click on “Select Actions”
  33. Go to the very end and select “Run custom commands”
  34. Click on “Run this command”
  35. Select either setThermostatMode(‘comfort’) or setThermostatMode(‘eco’)
  36. Click on “On these devices”
  37. Select your Stelpro Ki Thermostat
  38. Click done until you are back to “Installed Rules, Triggers and Actions”
  39. Redo the steps 28 to 38 for the other custom command.
  40. Click on “Done” and you are all set.
1 Like

Thanks so much for the detailed post. I wonder if I had an older version of Rulemachine (I just updated to the latest before trying again).

I had thought I was doing exactly what you describe, but in step 26 I was only seeing customer commands titled “S” no matter what I did leading up to this point. I am no longer having this issue, and am able to change the mode using customer commands. (I had created a rule that just changed the set point prior to this, but I think I prefer the mode toggle vs. changing the set point).

My home office is on the side of my house, and isn’t on my forced air heating system. When I’m working from home, I let the rest of my house cool down considerably and instead use the radiator heat in my home office to keep me comfortable.

I now have a rule that will toggle the heat to eco mode if motion stops for 20 minutes, and back on again when motion resumes.

I’m considering a routine or mode “Work From Home” that would also link into this, but for now I’ve been focused on stand alone rules.

Thanks for the help. I highly recommend the Stelpro thermostat if you need a zwave controlled radiator thermostat… Easy install, good price, an engaged developer (plus great help from the community).


Hi J-F,

Any words on the deployment? I’m impatient to be able to turn off the notifications!


Hi Rick,

My contact at ST said that there should be no problem for a deployment this Thursday (March 10th).
I don’t know when they do their deployment during the day (morning or evening).
I will keep an eye out and let you know when I have some news.

1 Like


The new Device Handler has been deployed.
You should be able to turn off the Operating State notifications.

Hi J-F,

Indeed, I see the new option.

I put it to “NO” but I still see the state in the notifications/Activity Feed…

I tried to change the value to “YES”, wait a couple of minutes and put it back to “NO”, still the same…

I keep receiving the “Thermistat Operating State is Idle” and “Is Heating”. The frequency tho seems to be lower, strange…

Hi again,

Strange, now it’s ok, I don’t receive the status anymore… When I turned it off, I kept receiving status but a lot less… I looked this morning and nothing.

I tried turning it ON and I instantly received status… turned it OFF again and nothing. I don’t know what happened but it seems OK.

I noted something tho… With the option set to “OFF”, if I hit the refresh button, it doesnt display anything in the notification/status… I would have thought that the manual query would still work.

If I turn the option to ON and try a manual refresh, it works. Not a big deal but it would be nice that the refresh button displays the status even if the option is set to OFF.