Electric Baseboard thermostat control via ST

Hello again J-F,

I didn’t call on you directly on my last message, so might not have been notified. Are you aware of a problem with the z-wave handler?
I’m having an issue as listed on my prior post.

Hi Paul,

I just tested it, and I saw what you mean.
It appears that another platform update broke something in the device handler (because the device handler was not modified in nearly a year).

Hey J-F,

any chance you can fix it? That is a rather important feature, as there is no other easy way to modify the setpoint while out of the house.
By the way, thank you for always getting back to us to respond. Not everyone does. It’s a credit to you Sir.

Hi Paul,

Since I didn’t make any change on the device handler in a year, I assume something is broken in the SmartThings platform.
Could you tell me since when you experiment the issue?
Give me as much info as you can, I will do my best to bring a fix asap

That is difficult since these thermostats are in my second home in Montreal.
I came back in the last days of April. I restarted the whole system in the same evening and noticed right away that I didn’t have your last version installed. I re-installed the latest version and I thought everything was working perfectly. I seem to remember being able to set the setpoint from the app.
The next day, I could no longer adjust the setpoint. That was 3-4 days ago.

I think we received an update to the Smarttings app about that same time.

See my answer in the Stelpro Release thread

BTW, I’ve been working with Sinope on their new line of zigbee thermostats…

The DTH is being tested now, and it will support all ST standard thermostat capabilities. This is great for smart rules engines (CoRE/webCoRE and SmartRules), but especially when used with my zoned heating/cooling smartapps which can control your home temperature on a room by room basis using the concept of virtual zones…

The virtual zones can be scheduled during the day for targeted heating/cooling & more comfort & energy savings. You can now easily control your zoned rooms’ temp delta to make some rooms hotter/cooler from ST with the virtual zone DTH.

More to come very soon…

Hi, Just to let you know that Sinope’s new zigbee smart thermostats for electric heating are now available for purchase.
Don’t hesitate if you have any questions!

1 Like

Can you fully control them all at once via ST or you still have to go through a web interface?

Hi frederixx,
Yes, you can control them directly through SmartThings. No web interface needed.

Re: SmartThings Stelpro not working.
I just got a Stelpro Ki, and the SmartThings app does not work. Looking at the IDE Device Detail Page, it appears that the ST app is changing heatingSetpoint, but not thermostatSetpoint. And that the thermostat only cares about thermostatSetpoint, since that is what changes if I manually change temp at the therm. Anyone else find the same thing, or a fix? This is a deal breaker for me, since I can’t even set up a basic schedule.

Hi @dancemyth,

What variant do you have? Z-Wave or ZigBee?
Please, make sure to get the latest device handler on Stelpro’s github page.

Thanks for the quick response and suggestion. I’m have the Z-Wave.
Updated the device handler. I know it worked because the UI is quite different.
However, problem is still the same: app updates heatingSetpoint, but not thermostatSetpoint. Ki appears to ignore the change. If I change temp at thermostat, both variables are changed.

Hi @dancemyth,

Could you please shed some light on the difference between thermostatSetpoint and heatingSetpoint ?

Which one is correct and what do you expect exactly?
Since this thermostat is a heat-only device, the difference between these two setpoints are not clear

Attached screenshot.
This is new to me and I am not a programmer. The screenshot is from my SmartThings account Show Device Page. Notice in the Current States section, that heatingSetpoint=72. This is the result of my setting the temperature on via the SmartThings app. The Ki ignores this, and keeps its setpoint at 67, which is the value indicated by thermostatSetpoint on the Devices page. When I change the temp on the Ki manually, both the heatingSetpoint and the thermostatSetpoint values are changed, and the Ki will go to the new temperature.

I haven’t tried using the StelPro app, but use webcore to manage bedroom ki Z-Wave thermostat schedule. I had issues getting the setpoint to take, and ultimately came-up with the below sequence:
Hope that helps debug the issue…

AllJet, Thank You!
Worked like a charm. So glad I had this problem, because now I know about WebCoRe.

No Problem, glad I could help.

AllJet, would you mind helping me? I’m have the same problem as dancemyth but I can’t seem to get my webCoRE piston to look like yours. Also when I get it corrected will I be able to control it with Alexa without her reading the wrong number?

@AllJetNoPilot @dancemyth

I believe you just add another task, and select applyNow() from the dropdown