I’m really sorry for the problems… this must be quite frustrating!

Can you try one last thing? Delete any/all LAN Motion devices, remove the driver, and then reinstall the driver and create a new device. Don’t do anything with edgebridge. Just configure your new device with your addresses, and confirm that edgebridge got the registration. Then check the .registrations file contents without disturbing edgebridge (just display the file contents). If the registration looks ok, then try triggering from Blueiris again.

Ok. I completed all that.
Registration file is now populated with:

That SHOULD work!

And it does seem to be on the one device!
Now to add all the others back and see if it survives a reboot.
Any idea whats going on?
I had to delete and re-add all devices once before. Kinda rough.
Thanks for your help!

There’s a hub firmware update rolling out today. Any chance you were in the middle of that while you were trying to do the other diagnostics?

Finally! It definitely appeared to be a registration problem. I appreciate you hanging in there on this. My take-away is that I’ve got to come up with a better way to reset registrations from the SmartThings device. If things are done out of order (configuring SmartThings device before edgebridge is up and running) or some other reason for edgebridge to not be able to successfully send messages back to the hub, then it could cause issues and there needs to be a better and easier way to get things reset.

1 Like

I have a question regarding your screenshot, which could help me figure out how things were going wrong. The edgebridge output showed that the SmartThings device registered, then requested to delete the registration… but then never requested to add the registration back again as I would have expected if you were temporarily changing the LAN Device Address setting.

Did you by chance happen to have any other LAN Motion devices created and configured with the same address?

I had 8 LAN motion devices (cameras)
I was only editing IP of one.
Maybe having other 7 still present was presenting an issue.

I’ve added all 8 back now and rebooted and all seems well

I’m sorry I hadn’t realized that. I probably would have recommended just deleting all but one instead of uninstalling the whole driver!

Nevertheless I’m looking at making some changes to avoid the hassle you went through.

I recant my previous statement about it all working… :smirk:
I had ran a successful test from Blue Iris activating the 1 motion device “Garage” and then cancelling the motion on it and it worked so I assumed all was well.
I then readded all the other 7 devices. Rebooted the server PC. Now when I try to send alerts from Blue Iris I’m seeing no activity at all in the edgebridge log despite the .reg file still appearing populated and “good”
Sometime after testing the 1st device and added back all the others something broke.

When you say you rebooted the server PC, that means you restarted both Blueiris and edgebridge?

If you inspected the registrations file and it looked good… and you haven’t deleted or made any changes to your SmartThings devices, then that part should all be good.

But you say when Blueiris is supposed to send a message to edgebridge, nothing is showing on the edgebridge console to indicate it’s receiving those messages? That sounds like a very different problem. You should at least see something being received… even if there are no registrations for the address (you would see an warning message).

So for this one, I’d say that after restarting Blueiris, something broke between it and edgebridge, not between edgebridge and the hub Edge driver. Are you certain no Blueiris config got changed and edgebridge is up and listening?

Yes. Everything got rebooted.
The config of blueiris is hard coded so I can’t see it changing. It’s sending the same IP\camera_name\active etc all the time.

New “error saving registrations”
Could this be a permissions issue with where .exe is at?

Well two things:

The messages from Blue Iris are indeed getting to edgebridge, so that’s not the problem. The error you are seeing “Unregistered address or Invalid endpoint” indicates that edgebridge has no registrations for the received message. Meaning once again that something is botched on that side of things.

Looks like you forced a registration to be sent from SmartThings, and then maybe tried to change it because I see a delete request. But for both of those things it couldn’t save the registrations file. So yes, something is going wrong there. Maybe a permissions issue, although I haven’t ever come across that problem. What are the contents of your registrations file now?

And why does it keep getting clobbered?!

EDIT: Crazy thought maybe, but you don’t somehow have two instances of edgebridge running at once do you? I don’t think you could since the port number would be taken.

I do believe I did have a case where 2 instances got started because of a scheduled task earlier today when troubleshooting
But right now I’ve verified in task manager there is only 1
So confused here. Months ago when I first set it up everything was very easy to get going.

I deleted all LAN motion devices and went back to a single device for Garage. It’s working for now…
Gonna leave it at 1 device and see if it will keep working.

1 Like

I think 2 instances at once is what got me one time. Is there a way to limit it to one? I have no idea how that works so feel free to dismiss if it’s a wild request.

@Joshua_Green , one of the issues I had was from a blue iris upgrade and it not correctly ending the program and stopping the service. It was 7ish months ago but I’m still feeling the headache.

Could it be possible something isn’t liking my names for LAN motion devices?
Should I not do underscores in names?
So far all is well with 1 device. Guess I can try to add others back 1 by 1.

Underscores in the name should be ok, but I’ll confirm that just in case.

Yes, I would do it one by one for sure.

But tell me exactly what you are trying to configure so I can try to reproduce what you’re seeing here. Do you have multiple Blue Iris cameras configured to send motion status? And they are all coming from the same computer - your Blue Iris server, correct? And edegebridge is also running on that same computer?

And you have configured unique names for each camera and you had SmartThings devices created - one each matching the unique name.

If you have one working, then we know the registration is working fine. There will be only one registration in edgebridge, so don’t expect to see multiple. The driver itself parses out the destination device based on the device name in the HTTP request. All messages are coming from the same LAN Address so that’s why there should be only one registration.

I’ll try to give more details.
Server PC running Blue Iris and edgebridge.
8 different cameras
Anytime Blue Iris detects motion on any of the 8 cameras it’s passed to an AI processor. If AI confirms the alert Blue Iris fires off a web request to the edgebridge server with the camera_name\motion\active
Once the motion trigger is reset Blue Iris send a reset command to edgebridge with camera_name\motion\inactive
This is typically 30seconds or so after alert.
If motion gets retriggered before the timeout period it could send another motion\active to edgebridge.
Each camera has a name and a matching LAN motion device within Smart things configured to match that name.

Thanks - and you said this was all working before, did I understand that correctly?

Yes. I’ve used your bridge and edge LAN drivers for 6mos or more
I previously did fight the blank reg file a couple times. That was it.