Edgebridge

A different community developer has been working on a post Groovy Hubitat integration here:

Hubitat->SmartThings Edge "Interface" BETA testers wanted

Also as we’ve mentioned before you could use Todd’s MQTT interface to get to Hubitat, although it’s probably more work to set that up.

Integration Solutions using MQTT

Thanks @JDRoberts for pointing this out. I will monitor and check it out when it becomes available.

1 Like

got some noob questions about setting this up with docker compose using Portainer on a Pi. until now, most things i’ve installed with portainer have been stacks, and they pull the image from dockerhub.

the method used in the readme involves building our own image with the .py, .txt and .cfg files. i’m not sure exactly where i need to save those files. readme says “./docker” directory. i’m not sure exactly where that is in the context of using portainer. is it my home directory? something specific to docker, or to portainer? is it the portainer volume?

additionally, instead of using a separate cfg file, could environmental variables be used instead? it could allow for an image to be built and stored in a repo and simplify the deploy process

edit: some more research and looks like portainer can’t build an image using the add or copy commands with files on the localhost, and should pull files using wget instead. which makes sense given that portainer is a web gui.

so the suggested commands using ./file are really only meant for using docker CLI, where a current working directory is actually established (i could save these files into ~/edgebridge/ and run the build command from that. and i now also understand that the “./docker” directory is referring to the same one in the github repo, and assumes that i’ve copied all of the files and that folder to my pi just as they are shown in github.)

Hi - Unfortunately I really don’t know much about Docker or Portainer. Someone else had contributed the Docker info on my edgebridge repository with a github id of OttawaCloudConsulting. You might try to contact him through his github pages.

If you figure this all out and have some recommendations on adding to or modifying the Docker readme, I’m happy to make the changes.

1 Like

Todd,

I hope this is the right place to ask about the Optional SmartThings Edge device to monitor edgebridge online/offline status.

I installed the edgebridge monitor and also Web Requestor on Rpi and phone app.

I created a rule to notifiy me every 15 minutes if the monitor is offline.

The rule triggers once, and once only after creation.

I can’t figure out a way to have it notifiy me every day or every 15 minutes.

Is it because it’s an “if” test and not a “while” test.

Can you tell me how to get this working, because I have another routine like this called Elder Care.

It should notify my neighbor if I haven’t moved in 10 hours, meaning I’m dead, disabled or dying, and need attention.

If there is no way to make these routines work with the SmartThings app, mayby there is a way for your edgebridge driver to post something to the Raspberry Pi to run scripts and notify via SMS or eMail.

The Elder Care routine works properly on SmartThings IDE (link below), but they’re going to pull the plug on IDE. I’ll be left without Elder Care.

Here is a link similar to the Smartapp Script I have running on IDE. It works, but the iPhone/android SmartThings routine doesn’t work.


I have another json script that I would like to get working, which does Google Sheets logging from a door sensor switch routine.

Hi All.

I’ve been trying to install Edgebridge on my raspberry pi but I’m struggling. Would anyone be able to do some step by step instructions?

Thanks

I used installation instructions in edgebridge/README.md at main · toddaustin07/edgebridge · GitHub

1 Like

I downloaded edgebridge4pi and then entered

chmod +x edgebridge4pi

And then

./edgebridge4pi

But I get this error message. Any ideas?

Do you need to use the executable version?
Many have installed it on Pi going the docker route.

It doesn’t look like you downloaded the file correctly. Maybe you tried doing it with wget?

Try using the download button on this page: edgebridge/edgebridge4pi at main · toddaustin07/edgebridge · GitHub

@Gavacac I ran wget on the path for the Download button that @TAustin posted and it worked for me on my Pi

Posted in older thread so posting here now:
Still fighting issue with registrations. Downloaded latest .exe
Registrations file wasn’t blank but edgebridge reporting no registrations on startup.
Deleted everything, rebooted hub, moved .exe to new location and now it doesn’t even seem to be creating the .registrations file anymore? I’m lost
Update Got past registration issue but now I’m getting hung with the POST issue it seems
Nothing has changed on blueIris side from what once worked.

GET request received from: (‘192.168.1.6’, 65480)
Tue Jan 17 22:41:24 2023 >>>>> Forwarding to SmartThings hub
Tue Jan 17 22:41:24 2023 Sending POST: http://192.168.1.59:38053/192.168.1.6/GET/Garage/motion/active to 192.168.1.59:38053
Tue Jan 17 22:41:26 2023 FAILED sending message to Edge hub [‘192.168.1.59’, 38053]

Force your LAN Motion Device to re-register with edgebridge. It looks like edgebridge doesn’t have a current registration…

Go into the device settings and change your LAN Device Address to something else (wrong/unused). Save, pause a few seconds, then go back in and change it back to the address of your application.

Watch your edgebridge console output and you should see a message indicating the new registration.

Now try again.

I see your device short name is “Garage”. Make sure that you used that capitalization in the LAN Motion device Settings. SmartThings always shows Settings values with the first letter capitalized. But when you edit the field you can see if it really is or not.

I saw another comment about changing address of LAN motion device and then changing it back.
I had already done that actually.
Capitalization is good in edit field.
Upon changing back to correct address I do see edgebridge console report the device registration.

Still get same POST error as I posted earlier.
I know communication is working in the other direction because I’m using your web requestor to send commands back through edgebridge to my blueiris server and that’s working fine.
It’s blueiris sending the GET motion commands back to the LAN motion devices through edgebridge that’s breaking down.

I appreciate your help and your work on this.

Can you screenshot the device settings for me, and also show me the contents of your .registrations file?

Something is going on with registrations file. I moved edgebridge.exe to new folder last night in effort to get it to create new registrations file. I could never get it to. So I just copied old one to the folder.
Now as I went to get contents of reg file for you it’s blank again…
What’s also odd is if I turn off “view hidden items” my registration file doesn’t disappear like I’d expect. How can I get it to recreate the hidden file?
I if i go back through changing IP of LAN motion devices I can see the log report the registration once I switch IP back to correct address but I still can’t get a command to come through.
Attached are settings of LAN motion device.

The registrations file will be scrubbed of any registrations from addresses it can’t reach after 3 attempts. So this is why the registrations file would be empty. You probably tried three times and then it got scrubbed. Because of this, you’re going to have to do the ‘change LAN Address trick’ in the SmartThings device Settings to make sure it is re-registered before you try again.

Is there anything running on your Blueiris server that might be blocking outgoing network traffic? A firewall, VPN, docker container, etc.? Anything unique about your network configuration? Is the server and hub on the same subnet? You could have a network config issue.

I’m honestly not sure about the BlueIris side
For that I’d just go back to the fact it has worked for many months and I didn’t change anything on BlueIris side.
I can also see the command from blueiris making it’s way to the edgebridge. It’s the forwarding to the LAN motion portion that seems to be breaking.

I see about the registrations file emptying if it can’t reach something 3x. I’m still perplexed as to why if I delete the file entirely it’s not being recreated. Should it not?
I feel like that’s part of the issue. I’m having to manually place a .registration file in the folder with .exe If I do not there is no file.
Could it be creating a file somewhere else somehow?

You should never have to create a .registrations file. It is created by the edgebridge app. In fact it might be causing problems if you try to. Ctrl-c out of edgebridge, then delete any .registrations file. Then restart edgebridge. It will give a warning message that no registrations exist, but that’s ok. Now force your LAN Motion device to re-register by changing the LAN Device Address Settings field. Closely watch the edgebridge output to make sure the registration happened. At this point you should be able to dump the contents of the .registrations file and see the new entry.

Ok. I tried that. Deleted file. Restarted bridge and changed IP of device back and forth and got the following.
Once I closed edgebridge and reopened the registrations file it was still empty though.