[EDGE] Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

I’ve been looking to get the ID Lock 150 a while now and finally I got a great deal on it, for half the price. I’ve installed it on my door but am waiting for batteries to charge before I add the Z-Wave module and pair it with Smartthings.

The chip is small (depending on your definition of “small” I guess), it’s 2x14mm. There are smaller ones at 2x12mm, but the one I’m likely to get is NExT which supports both frequencies - just in case I have a use for both, it’s only 2mm longer.

It’s from Dangerous Things (https://dangerousthings.com/chip-implants-101/).

A short video only showing unlocking with your hand can be found here: https://www.youtube.com/watch?v=diwNepi84O0

While waiting for the batteries to charge I bought access to your apps. I’m looking forward to pairing my lock. If nothing else, I’ll definitely report back when I’m chipped. :slight_smile:

First just wanted to say I bought access to the RBOY apps a few months back and they are great. I use this DTH for two Kwikset locks along with the universal lock manager. It works great to provide alerts and I have it in webcore with a lot of automations based on what’s going on with the keypad, command, or manual use of the lock. The one minor issue I have with it (well, major if you ask my wife, lol) is that in the new smartthings app, you can’t just click the lock to lock or unlock like you could with the stock lock DTH. It seems like a minor annoyance, but with the new ST app you have to open the app, wait for it to load, scroll to the lock, click the lock, then look down to find the button to unlock it. Using the new app to open the door actually turns into a process where it is easier to just use the keypad. In the classic app, it is right in my favorites and I just click the lock to unlock or lock, and this is the only thing at this point that has me still using the classic app. Well I just got the notification that “the new smartthings app is ready for you”, and at this point I feel the classic app’s days are numbered now. This is more of a problem with the new app in general and it just doesn’t replicate the “favorites” well of the old app. Long story short, I’ve seen some discussions on the UI and issues in the new app above in this thread. Is there a way to get a button right in the new app (similiar to the power button for switches) to lock/unlock without having to click the lock, wait for it to load, then click the button with the circle under lock state? I saw some mention of repairing the lock, but didn’t want to do that just yet as I think it would need some automations re-programmed and I’d have to take the lock off to move it to the hub. I did just updateto the latest code, and if repairing works I’ll give it a try though. Or, is this a UI update with the new smartthings app that is planned possibly for sometime in the future? Any other ideas for a workaround for single button clicking to open or unlock? I’ve thought about setting up a scene but am hesitant to give a scene access to unlocking the door.

1 Like

The item you’re asking about is a SmartThings platform decision (one I really don’t like either) Even if/when RBoy updates the Device Handler for newapp it likely won’t affect this particular idiosyncracy.

Create a Scene that locks the lock (call it whatever makes sense) and pin that scene as a ‘favorite’ to the top of her main page then do one that unlocks the lock as well…

Thanks Nathan, I know there are a lot of things about the new App that are not great, to say the least, which is why I think the old app still sticks around. But the workaround just seems sloppy, see the attached pics for a side by side comparison, and then imagine you are a person with no clue what you are doing trying to go from the old app to the new one. One is simple, intuitive tiles that you click and interact with and can see the instant status of the device, with “pretty colors”. The other has scenes and then the lock changes under them. It’s not intuitive for the user, doesn’t look as good, there’s more clicks to do the same thing, and for a “new app” it is definitely a step backwards. My garage door has the button to open and close it from the tile in the app, so I know the capability is there, and would think it’s just a matter of programming. So if one DTH for a different door can do it, you would think another one can too. That being said one is a “door” and another a “lock”, so this is not an apples to apples comparison and for all I know this is a security thing with locks that can’t be changed in the new app. Until then I’ll just keep using the old app until it stops working. Side note, anyone know how to get rid of the notification “the new smartthings app is ready for you”, lol.!

TOTALLY agree with you - there’s a LOT about the newapp that is well, sloppy. Fortunately - I’ve seen @RBoy & RBoy staff on the beta and developer threads actively trying to figure it out (Thanks guys)

Do what I do when you find somethin you dont like. Feedback (here for RBoy and the stuff they can control - I’m positive if its something they can fix in the DTH, they will - I see them leading most of the CLI customization discussions right now) but there’s something else we can do as users:

  1. go to this thread: https://community.smartthings.com/t/get-ready-to-make-the-switch/
    and talk about what’s not working (pollitely) the ST devs are there and they’re listening.
  2. send in feature requests to support@smartthings.com with constructive suggestions

They can’t fix what they don’t know about and if we all rely on the other guy to submit feedback you can bet that dev never gets the message because ‘the other guy’ never did.

I worked for a large software dev firm for ~12 years and I can’t tell you how many times I was told by a customer “I can’t believe you guys didnt know about” (Insert big issue here)

Part of my job was to chase these down, and very often, the problem was nobody ever reported it because they all figured it was such a big issue someone else HAD TO have reported it already.


Thanks just posted over there and emailed them. You’re right if Samsung doesn’t know it’s broken they won’t fix it.

1 Like

I agree with the previous poster. The only way to get things done is to do them yourself, basically. You can’t rely on others to report these things. That reminds me - I need to send a support email/ticket this exact thing.

It’s the same for my ID Lock 150, I need to press the lock, wait for it to load, and then press “Unlock”. The tablet I’m using on my wall isn’t especially fast, so that’s on me, but even with my phone and being ready (hearing someone going up the stairs to my door when I’m in the bathroom), that extra step takes time and is fully unnecessary.

I also have a couple of Xiaomi outlets with energy monitoring that I would want to switch from the default “on/off” on the “dashboard” (what is the default page called?) of SmartThings to showing current energy usage. This is very off-topic, but I use those only for energy measurement and always want them on, so I’d like a way to change that too.

Guess it’s time for that email to support.

That being said, I have another issue with my lock. At least once a day it starts to chime, I think it’s the same way it chimes when it registers whatever changes I do in LUM. I can’t remember the exact chimes at this moment - I’ll try to record it next time I hear it if possible.

My lock is an ID Lock 150 using the Z-Wave adapter which seems to be updated to v1.6. I have a Z-Wave outlet because it was recommended for Beam, but I haven’t gotten the lock to connect to it yet (Swedish: https://www.netonnet.se/art/smarta-hem/system-varumarke/z-wave/telldus-onoff-z-wave-range-extender/1009658.13999/)

Basically, it chimes a couple of times using one sound, then ending with another sound. I think it’s the same sound it does when “registering”, for example if I register a new PIN code in the app, or even at the door (I think they are the same sound).

The thing is, I’ve had all my codes set for weeks now but my lock keeps doing these chimes every day (might have been a day or two that I didn’t notice, but I could’ve been away, or not here just when it chimes).

That being said, I have other issues with the lock that is highly unlikely to be because any wireless activity.

The lock is alarming for Tamper Detection what feels once per day. It also doesn’t registers being closed, which might be why it alarms for Tampering. However, I’ve had the lock for maybe three weeks now (guessing). Tamper Detection has gone off since about one week ago, but the chiming from the lock has been going on during this whole period.

It’s likely that the issue is a hardware issue with my lock, but I thought I should mention all this in case @RBoy wants any logs of any kind.

That’s how the idlock z-wave firmware works, it chimes everytime the lock is accessed (SmartThings contacts the lock every few hours to check if it’s alive so you’ll hear the lock chime). While it’s a nice security measure but it can get quite cumbersome after a while as you’ve seen. We’ve reported it to ID Lock and they’ve put a partial fix in the 1.6 firmware.
Disable the audio notifications (using the Classic app or directly on your lock) and it should stop most of the chimes, however some operations (like changing codes) will still make the lock chime. If you want the lock to not chime at all when you disable audio in the settings, feel free to let ID Lock know.


Oh, okay, that’s good then. I haven’t been bothered by the chimes but have been wondering what they were.

I haven’t updated the Z-Wave adapter to 1.6 myself, but I’ve seen 1.6 when browsing the IDE, so I’ve been assuming it has 1.6. Do you know what that “partial fix” were supposed to “fix”?

I’ll try to disable to audio notifications and see what that does in practice, otherwise I’ll make sure ID Lock knows.

I’ve updated to the latest version 04.07.02 and now me and my wife get push notifications after every code unlock. I’m not seeing any setting to disable these. Is there a way to do so?

Its probably coming from SmartLocks Guest Access. It’s a ‘feature’ of the new lock manager smartapp.

1 Like

Yes sir you’re right… push notifications being mandatory on that smartapp seems like an oversight :/.

So I just did the delete the DTH, create a new one and update. i didn’t disconnect from ST, just chawed the device type when done. Now, every time I enter a user code, it beeps six times before locking/unlocking. Is something wrong? Do I need to do something else? I tried going into the app on both the classic and new version and edit/save. Still beeping and delaying the lock/unlock by about 6 seconds.

EDIT: After further testing, it is only happening on one of the two locks. Not sure why.

Universal Enhanced Z-Wave/Plus Lock Device Handler - Version 04.08.01

  • Patch for a firmware defect in some locks models (Schlage Connect/BE46x, IDLock 150, Yale keyless) which cause out of order event delivery leading to incomplete notification details
  • Fixed a bug in the stock SmartThings device handler which causes missing information for notification events caused by z-wave mesh delays

If you are using one of the identified lock models above and are experiencing missing user (name) notifications while unlocking/locking, then update to this version of the device handler.
NOTE: While the device handler cannot recover packets not delivered by the mesh/lock, however this update can recover information from packets delivered out of order which lead to incomplete/incorrect notifications.

Please make sure that your lock is within 20ft of a buffering device/repeater for best performance and reliability.


My backdoor lock (Kwikset 910 I believe) looses connection. It’s definitely something with the radio. Anyway, I have it hardwired on a wall wart going into a SmartPlug and I just turn the SmartPlug off then back on to reset it. This works for a week or so then it’s back offline.

I noticed that in webCoRE there is an “Unknown” state. This state is also seeable (if that’s even a word) in Classic App SmartLocks Home Page and in the New App it shows offline. However, webCoRE seems to not be able to detect when the status is “Unknown”…

I wanted to execute this simple Piston but so far a nogo. Any ideas?

Hi, I have the Schlage BE469ZP and just migrated to the new Smartthings app. The icon for the lock device always shows unlocked even though its locked ! Is there something I could do or it’s a known bug?

Instead of lock unknown, I would trigger the piston by the device going offline, like this

1 Like

I understand that the missing tiles are a limitation of the new app. Is there a means of getting the missing features to the settings page? I see settings for Yale, kwikset, Danalock and IDLock but not Schlage?
Looking for Vacation Mode specifically for the BE469.
If not, would activating via keypad mess anything? I know LUM doesn’t like manual code entry.

We’re working closely with SmartThings to bring the “advanced” UI custom controls (auto lock, vacation mode, alarms etc) to the new app UI. There a few issues in the new app UI which ST is working on sorting out.
The DTH itself is completely functional with the new app,it’s just the UI that is lacking “custom controls”. The DTH settings page is fully functional in the new app (relock time, volume level, motor control etc - these are lock brand specific, Schlage doesn’t any configurable options here, see the first post for a full list of features for each lock brand).
In the meanwhile you also change the “settings” directly on the lock or use the Classic app UI. Lock “settings” (vacation mode, audio, alarms, auto lock etc) changed directly on the lock will sync with the DTH (which can be viewed from the Classic app UI until the new app UI is ready).
Only user code programming should NOT be done directly on the lock to avoid conflict with SmartApps.