Edge Shelly drivers for Gen1 and Gen2 Devices

Can you do something for me? I need to find out what ID the Shelly S uses. Can you please do this from a browser, knowing the IP address of one of your devices?

http://<shelly IP address>/shelly

And post the response?

{“name”:null,“id”:“shellyplusplugs-b48a0a1cea40”,“mac”:“B48A0A1CEA40”,“model”:“SNPL-00112EU”,“gen”:2,“fw_id”:“20230510-081027/0.14.4-g4da93ee”,“ver”:“0.14.4”,“app”:“PlusPlugS”,“auth_en”:false,“auth_domain”:null}

Hope that was what you need. If not just ask :slight_smile:

1 Like

I’ve pushed out a GEN2 driver update (Version 2023-07-28T18:59:54.45113714) that contains support for the Shelly Plug S (as well as UK and IT; US was previously supported). Please wait until your driver has updated and then try an Add device / Scan for nearby devices to see if your devices are discovered and added. Let me know how it goes, as I don’t have this particular device so am dependent on you to verify everything is working as expected.

1 Like

Seems to work perfectly. I get the switch option and powerconsumtion :slight_smile: You are a hero \o/. Thanks alot.
Now i dont need to feel bad for buying 4 of them :slight_smile:

1 Like

Great to hear! :+1:t3:

I’m running into a weird issue with the Shelly Button 1.

I set a couple up and both were able to trigger the virtual SmartThings buttons and routines triggered by those buttons. But then I had a blackout which caused the hub to restart. After that, the buttons successfully connect to WiFi, but the URL they’re supposed to trigger no longer seems to be valid.

SmartThings never receives the event and routines are never triggered. I’m not really sure where to go from here for debugging. I tried doing a log dump from the advanced web UI but it never gives me the logs.

If I try to manually POST to the URL, I just get a connection refused error.

Edit:
I added a new button and set it to the same IP as an existing one, then changed the existing one’s IP to something random and back and that seems to have solved it. I’m not sure which part got things working again or if it’s permanent, so if there’s another blackout I’ll try more specific steps.

1 Like

Having issues with the I4 inputs not updating. Works fine for a day or two, then it does not update input status in SmartThings. Have to reboot ST hub to get it to update. No error message (device offline). No issues with UNI although I believe that is a different driver. Any suggestions?

Would it be possible to get some driver logs? You’ll need the SmartThings CLI running on a computer on your LAN (Windows is easiest). If you don’t already have it you can download the install file here, and I can give you more instructions on how to use it.

Yes, no problem. CLI is loaded on my PC from the Envisalink testing. Just give me detailed instructions how to proceed.

Okay, I think I have the log running. From the command prompt: smartthings edge:drivers:logcat
Then I selected: Shelly Gen2 Device Driver V1.4
So far Smartthings and the log are updating when an input changes state. I will keep this running until it doesn’t.

1 Like

You got it! Share the log via a direct message if/when you find something.

Hey there,
first of all: thanks for this great driver! Been using it quite some time and am really happy with it!

I‘m having problems with my Plus 2PM in cover mode. The commands „open“, „close“ and „pause“ are working well. But when I want to move it to a certain position via the percentage-bar, the relay only clicks, but nothing happens. Also seems that some of the values are not showing the right values.

Can I help identifying the problem?




Hi there. Thanks for reporting the issue. I’ll review the code and confirm the right commands are being sent for position.

Would it be possible for you to install the SmartThings CLI on a computer on your LAN so we could get some driver logs if needed? Any Windows computer will work. You just need to download the Windows installation file here and then I can give you instructions on how to use it.

If you have a Mac instead, there is a download file for that as well.

I used the CLI one time for another creator, but it‘s some time ago. Feel free to send instructions on what to do!

I think I may have found the issue. You may be the first to use the cover mode for this device, so it was untested. It was sending a relative position rather than an absolute position, which the curtain probably didn’t like!

I’ve pushed a driver update out: Version 2023-09-19T21:44:51.727631853

Let’s see if that fixes it, and if not, we’ll pursue the logs.

2 Likes

Wow, it works! Could only test it once, but seems to be solved! Thanks a lot!

1 Like

Good! I still have to figure out why you have no data in the other fields.

Hey,

Thank you for the great work! Any chance of supporting password-protected devices?

Hello and thanks!

Can you tell me a bit more about this? Are you talking Gen1 or Gen2 devices? I don’t recall seeing any reference to passwords in the API reference docs, so I’ll have to go back and look for it.

There’s a way to do it at the time the device is configured, but I think third-party integrations can’t change it after it’s set the first time.

Here’s a home assistant thread discussing how they implemented it. Note that something changed between GEN one and GEN two devices, but I don’t know exactly what.

Shelly Integration with Username and password - Feature Requests - Home Assistant Community

1 Like