Edge Shelly drivers for Gen1 and Gen2 Devices

Firstly, I’m sorry you’re having trouble with it. I know how frustrating that can be!

My hub restarted yesterday as well; most likely the same firmware update. However in theory that should not have broken anything and your driver should have been able to re-initialize when your hub restarted. I don’t have a Plus 1 switch, but I have another Gen2 Shelly device and it appears to be operating ok. So it doesn’t appear that the firmware update has broken the driver…

First, I’d want to be sure that the problem you are seeing is not just the glitchy app failing to update fields. Just be sure you’ve tried a couple times to restart the app to be sure you’ve ruled that out.

When you do a swipe-down gesture on a device details screen to refresh, do you get updated values that you would expect? Can you turn the device on or off from the device details screen using the switch?

Do you have the CLI? If not, do you have a computer on your LAN where you could install it? (Windows is pretty simple). This would help us get logging information from the driver to see what could be going on.

I know you said you already powered down your hub, but I would suggest trying that again. Unplug it and count off 10 seconds before you restore power. This will force all drivers to restart and maybe you’ll get lucky.

1 Like

Thank you so much for touching base.

Upon refreshing the cards, it is not updating the state of the switch nor the input state that I also use.

I’m away from the computer right now I will look at this more in depth when I get back.

Can you tell me the CLI command to run? I do have it installed on my computer can run it.

As I say, in the Shelly app, the switch toggles in the input state refreshes as expected.

To capture some logs, use this command:

smartthings edge:drivers:logcat

You’ll be prompted for your hub IP address, and which driver you want to monitor.

Let it run for more than 15 minutes, since if there is a connection problem, it should retry to connect within that period.

Then initiate a refresh from one of your device details screens.

Copy/paste that log here if it’s not too big, and be sure to surround the log text in here with triple back-ticks (```) to ensure good formatting.

1 Like

My shelly 1 plus with the temperature addon also stopped updating temperature values since yesterday evening. Im away from the PC but tomorrow I will run CLI.

A terça, 13/06/2023, 22:17, John Nadeau via SmartThings Community <notifications@smartthings.discoursemail.com> escreveu:

1 Like

Oh boy that’s not good either.

If either you or @JohnRichard get a driver log to share with me, please send it to me in a direct message rather than fill up this topic. Thanks.

1 Like

@TAustin just PM’d you a log. Let me know if it does a trick, or you need me to perform a do-over or anything else !!! Thanks!!!

1 Like

TO ALL GEN2 DRIVER USERS:

There appears to be a problem caused by the latest hub firmware release that is causing an error any time data is received by the driver. This is why you may be noticing your SmartThings devices not getting updates from your Gen2 Shelly device. It appears that you may still successfully control the Shelly device using the on/off switch, but any resulting data/state updates will not be received.

As far as I can tell this problem is limited to the Gen2 driver, and does not affect the Gen1 driver.

I’ve reported the issue and am trying to get assistant for resolving it. Will keep you posted.

2 Likes

Many thanks!

TAustin via SmartThings Community <notifications@smartthings.discoursemail.com> escreveu no dia quarta, 14/06/2023 à(s) 20:09:

@TAustin Hello,
Can you add more icons on Shelly Gen1 driver?

TO ALL GEN2 DRIVER USERS:

To follow up on my earlier post

The SmartThings team has found the issue and given me a work-around, so I have pushed out a driver update to the Gen2 driver which should fix the issue of not getting updates from your devices. Please let me know otherwise!

The updated driver is Version 2023-06-19T18:57:29.383933009

1 Like

Driver was updated but it looks that my Shelly Plus i4 do not work, both used statuses are “true” even without signal.

Is there need to uninstall driver and re-install it?

Awesome @TAustin !!!

All five of my switches are behaving correctly now !!! Toggling On/Off and reporting back the proper “Input State” !!!

Thank you so much !!!

For anyone wanting to force the driver update, this worked for me using the CLI (Command Line Interface) in Windows 10/PowerShell:

Task Command Notes
Show Current Driver Versions smartthings edge:drivers:installed Follow the prompts to VIEW the current Driver Versions.
Force a Driver Update smartthings edge:drivers:install Follow the prompts to select a Driver to Update
Select a channel to install the driver from TAustin Driver Tests
Select a driver to install Shelly Gen2 Device Driver V1.3
1 Like

You should not have to uninstall and reinstall the driver.

I’d say give it some more time to be sure that the driver did in fact get updated. I’ve seen cases where the driver version displayed by the app may show a new version before it actually gets installed to the hub.

If you are still having the same problem after 9 more hours or so, let me know.

That was the case… thank you for the support!

1 Like

Humidity and temperature values appeared in my 2 shelly PM devices (1st gen).
Not having any add-on, it shows me 0° temperature and 0% humidity.
This becomes a problem, because from the app, it uses this data to average the values of the house. Is it possible to delete them?

edit: I have only now discovered that from the app I can decide which devices to use to monitor temperature and humidity. I deactivated these shelly therefore my request becomes no longer indispensable for me.

I have just installed the Shelly UNI to measure temperature and have to say it works great with this driver. Nice work and thank you for this.
A suggestion for an enhancement for your consideration would be an “Offline Status” similar to what you did with the EnvisaLink driver. If the device is offline for whatever reason, there is no indication other than the temperature isn’t updating. Not a big issue if just being used for display purposes but could be an issue if used to control something like turning a heater on or off.

1 Like

Hi - thanks for the feedback; glad the UNI is working well for you.

Regarding the offline status indication, I have a couple questions:

  • Would setting the standard SmartThings device ‘offline’ state be sufficient, or are you looking for a field that would contain a value that you could trigger an automation from?
  • The offline status would only change if you have the device configured for auto-refresh. And therefore the offline status change wouldn’t occur until a refresh attempt fails. Or are you looking for a separate ‘fixed frequency’ polling of the device for quicker recognition?
  1. Being able to trigger an automation would be ideal.
  2. I think using the current auto-refresh makes sense. If checking the temperature every say 5 minutes is sufficient for the application, then knowing it’s offline at the same frequency should be okay.

Your questions made me think of something else. If an input changes state on the UNI (binary input, not temperature) when does SmartThings see that? Base on the refresh frequency (polling)? Not on the state change?

The device should be notifying the driver when the input state changes. In other words, NOT dependent on polling frequency.

So the polling is only for temperature/humidity?