Edge Shelly drivers for Gen1 and Gen2 Devices

It is possible to do, yes.

Please try to get a definitive answer from ActionTiles as to when they are going to fix their application to fully support SmartThings devices. There’s no sense going back and forth with them about one particular component or capability.

I’m still not enthusiastic about designing device profiles to account for ActionTile’s shortcomings.

1 Like

I write it here @TAustin To give feedback :I had to unplug 1 Shelly 1pm for a few days, to redo some wiring. The Shelly app obviously recognized it as offline, from SmartThings obviously not. I don’t know if he tried reconnecting all these days, but now that I reconnected it, it immediately didn’t work, but after 10 minutes it was back to work. Without having to restart the Hub. Great :+1:

1 Like

Hello @TAustin,

I already installed GEN2 Driver, and found some devices that I have at home.

The one that I really wanted still don’t, that is Shelly I4. Because this one don’t appear on Smartthings with Shelly integration.

When I try to add manually from “Shelly Gen2 Device Creator”, it stays loading and loading, but don’t add it.

I have already CLI ready to test it and help you. :slight_smile:

Do you know when it can be available?

Thank you.

I’ll try to get that done within a week. Thanks for volunteering to test!


Whenever I search the platform and find something cool, I always find that you’ve done it



I have added two more GEN2 devices to the Shelly Gen2 Device Driver:

I’m unable to test these myself, so as always, I rely on community members to report back their results. CLI logs are appreciated. THANK YOU!

Updated Driver Version: 2023-01-18T02:04:34.882529641


You are the men @TAustin :wink:

When I get home I will test it and give some feedback.

Thank you a lot.

after a long time I got a reply from actiontiles. the answer is: they have only migrated “main” so far, if there are any other components, they will not work. according to the statement, they don’t even know when or if it will be supported at all, the new platform is completely different and I have the feeling that more things don’t work there. when I read various discussions, there are a lot of problems after the migration, but it is uncertain whether they will be able to solve some of them.

that’s why I would like to ask you if you could convert the controller to UNI shells, at least so that there is a switch, sensor 1 and ADCS (relay1, temperature, humidity, volatge) in the main, otherwise it is not such a priority for me. other components can be used in automation, but it would be good to be able to display these things in one place.

and one more design change comes to my mind, so that it would be possible (since it is a universal device) in smarthings to choose how to display me (switch, temperature, humidity, volatage) and accordingly the device would be displayed in smarthings with the value of the selected sensor.

you have this functionality in one of your drivers - MQTT device creator

thank you very much for your willingness

OK you wore me down :slight_smile: . I’ve updated the Uni device to move those elements to the main component. Please test and let me know if everything is working ok.

I don’t know the status of ActionTile’s ability to support custom capabilities, so its possible it may not recognize the Input field. There’s not much I can do about that.

Also - a warning to anyone who might ask: The GEN2 devices will not work with ActionTiles since they are designed to use multiple components and I will not change this.

Updated Driver Version: 2023-01-18T17:54:06.061133365

1 Like

I know I’m pushy) so I tried it and the voltage is in main and is displayed in actiontiles fine. could the temperature and humidity of sensor 1 also be given there?

Temperature and humidity for the first sensor should already be showing in main in the device Controls screen.

You may need to create a new Uni device.

Hi @TAustin,

I tested Shelly Gen2 Device Driver - Shelly Plus I4, but is not working for now.

I sent you 3 messages for different tests:

  • Logs from Shelly Gen2 Device Driver, when I press physically the 4 buttons
  • Logs from Shelly Gen2 Device Driver, with one automation created on button 1
  • Logs from Shelly Gen2 Device Driver, removing shelly I4 and add again manually.

Graphically on Smartthings when I press a button of Shelly I4 nothing happen. But on Shelly app with this device is the same thing, so that is not a real problem.

But on logs you see that information is being recorded.

Using the device in automations also don’t do nothing.

Because I have 2 Shelly I4, and only one was automatically added, I added the other one manually, and I add also the IP address, but the device don’t update the network info.

Everytime I open the device on Smartthings, on both, this info message appears all the time:
This device is not yet updated with all status information. Please check again later.

Thank you! I’ll go through the logs… looks like some bugs to fix.



Thanks again for the Gen2 driver logs. I had a couple things to fix and have pushed out an updated driver, version 2023-01-19T02:11:42.535636275.

There was a bug that was preventing button events from getting processed correctly.

I also fixed some code that prevented you from initializing a device that you created manually, with a configured IP address. That should now work ok. Although I would like to address the reason WHY you had to manually create a device: you said one of your devices was not being discovered. Did you try more than once?

EDIT: One more thing: I had inadvertently included an ethernet component on the I4 device, so I removed it now. So please delete your I4 devices and rediscover or manually recreate them once you have this new driver.

thank you very much, it works perfectly. sorry for being so annoying))) I bought the device last year in December and since then I’ve been fighting to make it work somehow))

I’m in your debt, if you ever visit the Republic of Slovakia, specifically the city of Bratislava, let me know and I’ll invite you to local specialties and good beer :beer:

You may be surprised that I’ve actually been there! Ordered a “yard” of beer and barely made it back to the hotel :smirk:

1 Like

:joy: so maybe you’ll do it again sometime and we can also try the local drink “Borovička” but probably only right in the hotel bar so it’s not far from the room


Hi @TAustin,

I will try to write the steps from yesterday. :slight_smile:

  1. Installed Shelly Gen2 Device Driver

  2. Start automatic discovery.

  3. Found 10 Shelly Gen2 devices - but only 1 I4. I waited for some time, but didn’t try again automatically.

  4. Because I just wanted to test I4, I removed all the other 9 Shelly Gen2 devices.

  5. Started CLI log to test I4… What a mess… :slight_smile: Logs with “BUG” and “Warning” running non stop, because of the deleted devices. No way to test I4 like that.

  6. Removed all the devices. Uninstall the driver. Install the driver again. Checked CLI log, and now was all ok… CLI just waiting to record something.

  7. Start automatic discovery again.

  8. This time, just found 1 Shelly Gen2 devices. The I4 that was not found in the 1st place. All the other ones I think just ignored them. Ok for me at this time.

  9. So I tried to add manually the other I4, that was added automatically at the first time, but not now.

  10. And then I started the test, that I sent to you. I hope you understood… :slight_smile:

In my opinion, the automatic add of the devices is amazing, when the driver is ready and not on test phase, so you can add all at once. But when we are testing we want to check one by one, and we should add the devices manually only.

Now, I will start testing with the update you sent.

Thank you a lot.

Hello @TAustin,

Test results on Shelly Gen2 Device Driver - version 2023-01-19T02:11:42.535636275:

Because I had some time, I made tests with I4 and also 1 PM+.

I started the automatic search for 3 times, and all the times some devices were added. I didn’t try more even knowing that there were more Shelly GEN2 devices to add.
[Logs - https://we.tl/t-1aiv9CU4Mm - Not possible by message, too much caracters ]



  • Some devices were added automatically, some not.

  • The ones added automatically are working perfectly. With interactions and energy information. All good.

  • One that I add manually is not at 100%:
    – Interaction is ok. Can turn ON and OFF the light.
    – Don’t give any info of the device. Energy and the others.
    – Don’t appear in the bottom the network info, as the ones added automatically.
    [Logs - [Sent by message - Shelly Gen2 Device Driver - Shelly 1PM Plus (Add 1PM+ manually.) ]


Using CLI with this driver now, to check the logs, even without any interaction, there is logs all the time.

Is that normal, or there is something wrong?
[Logs - [Sent by message - Shelly Gen2 Device Driver - Logging without any changes]