Edge Shelly device support discussion

This is due to the recent Android updated; I’ve had to make a fix to the driver see below…

1 Like

ALL SHELLY EDGE DRIVER USERS/TESTERS:

I’ve just pushed out an update to the driver, version 2022-06-25T17:34:33.756482036

This update includes the following:

  1. Fix to ‘broken cloud’ issue in Creator device create button (affects Android users)

  2. Addition of new devices: Button1, I3 (Momentary & Toggle). Please note these have not yet been tested, so anyone that has these devices, I ask that you try them out and provide your feedback. @Chris_Gaddy

  3. Enhancements to device initialization error recovery/retry/validation

Thank you!

I’m actually still not using Edge but I’m preparing for the jump once it will be required.

I tried to follow this topic but I couldn’t fully understand if temperature add-on for Shelly 1 and 1PM is included in the driver, is it working fine?

Hi there. I haven’t added the temperature support, only because no one had asked for it yet. But adding it won’t be a problem, so just let me know when you will be needing it and I’ll take care of it. I can’t test it myself, since I don’t have it, so will be dependent on you to try it out.

1 Like

Thanks a lot!

Well I really don’t know when the transfer to Edge will be the only option, but I guess sometimes then :slight_smile:

Unfortunatelly I have quite some devices that don’t have Edge drivers yest so I’m really hasitant to transfer.

Biggest headache is Heatit Z-TRM3 thermostat, have 7 of those, and no one seems to make the driver yet … they’re wildly popular in Norway and many of us would like driver for it!

Interested? :smiley:

You’d have to find out what kind of interface they provide. Are they zwave, zigbee, or wifi devices? I do drivers for wifi devices, but they need to have some kind of published RESTful API.

1 Like

That specific model is zwave. Off topic for this thread, obviously: different brand, different protocol.

I’m not sure if there are edge drivers for any zwave thermostats yet. :thinking:

update

I just checked: as of yet there are no zwave thermostats in the production drivers. One for the Qubino thermostat was just added to the Beta channel last week. So it looks like that device class is still in development.

Thank to both of you guys!

Yes, definitely off-topic, I was just stating the reason why I’m so hesitant to switch to Edge!

I guess what you’re saying is that not even a generic driver for Z-wave thermostat exists yet and that it might take some time?

1 Like

Hello,

Using Shelly 3EM with the ST edge driver.
It worked perfectly and today I saw the “power meter” data is always “out of range”.

I tried deleting and syncing the device but it didn’t help.
The other data is syncing and I can control the 3EM switch.

Is it a known issue?

Thanks.

Thanks for reporting this. There have been some recent changes to the platform that is causing some problems. I seem to remember reading about a similar problem in another post somewhere recently. I’ll investigate.

1 Like

I found the discussion related to the “out of range” problem; it is here.

This looks to be a SmartThings issue and some people seem to have solved it by reverting back to an older version of the app (they are presumably on Andriod). Nevertheless, it seems the issue is a known one and has been reported.

EDIT: We should make @nayelyz aware that you are also seeing this issue.

1 Like

Thanks! However, this must be reported to Customer Support, they’re the ones that handle this kind of issue. They are already aware of it, but reporting it can help them gather more info.
To contact them, you can follow these steps:

  1. Enter this page
  2. Click on “Support” in the upper-right corner
  3. Check if the URL includes your region. For example, en-us here: https://support.smartthings.com/hc/en-us
  4. At the bottom, select “email” and describe your issue as detailed as possible.
  5. Click on “submit”

Or, these other methods depending on your location:
US: 1-866-813-2404
US: support@smartthings.com
UK support 0333 0000333
UK: support@smartthings.co.uk
CA: support@smartthings.ca

2 Likes

To all current users of the Shelly Edge driver:

I’ve just pushed out an update to the driver - version 2022-07-18T21:47:36.400845361

This corrects some cases where broken clouds may be seen on the signal strength field, or on certain fields of newly created devices.

No action is required; the driver will be automatically updated on your hub.

A reminder to willing testers:

There are still some device types that really have not been tested out yet, so if anyone has the following devices, please let me how they are working for you: i3 (switch or button), button, bulb

Of course I’m still taking requests for Gen 1 devices not yet supported.

Also, a reminder that if you run into a case where your SmartThings device seems not to be getting updates from your Shelly device when it should - even though the refresh button seems to temporarily work - the best course of action to force a re-initialization with your Shelly device is to go into device settings and temporarily change the IP address to something else (wrong), wait a few seconds, then change it back to the correct IP address.

1 Like

Hi,

First of all thank you very much for building this excellent Edge Driver, I was able to follow this thread and install them very easily, and I now have control over my Shelly 1 in Smartthings!

I have just installed a Shelly 1 on my garage door controller, it also has a reed switch wired in.

I am able to see and control the opening of the garage door in Smartthings, but I am seeing no indication of the Contact Sensor/External reed switch attached to the Shelly 1.

(I can see the switch change the colour of the power indicator in the Shelly App, so I know it’s wired correctly)

Any idea what I need to do to get this working correctly, I’d really like to be able to use the contact sensor to alert me if I leave it open etc…

Any help would be greatly appreciated.

Attached is a screenshot of my Smartthings Device and the Status output of the Shelly.

Thanks

"wifi_sta": {
"connected": true,
"ssid": "ThornfieldThunderbolt",
"ip": "192.168.1.164",
"rssi": -78
},
"cloud": {
"enabled": true,
"connected": true
},
"mqtt": {
"connected": false
},
"time": "22:14",
"unixtime": 1659734077,
"serial": 250,
"has_update": false,
"mac": "34945469CE6E",
"cfg_changed_cnt": 29,
"actions_stats": {
"skipped": 0
},
"ext_switch": {
"0": {
"input": 0
}
},
"relays": [
{
"ison": false,
"has_timer": false,
"timer_started": 0,
"timer_duration": 0,
"timer_remaining": 0,
"source": "timer"
}
],
"meters": [
{
"power": 0,
"is_valid": true
}
],
"inputs": [
{
"input": 0,
"event": "",
"event_cnt": 85
}
],
"ext_sensors": {},
"ext_temperature": {},
"ext_humidity": {},
"update": {
"status": "idle",
"has_update": false,
"new_version": "20220209-092750/v1.11.8-g8c7bb8d",
"old_version": "20220209-092750/v1.11.8-g8c7bb8d"
},
"ram_total": 50864,
"ram_free": 38232,
"fs_size": 233681,
"fs_free": 149847,
"uptime": 10713
}
type or paste code here

Hello and thanks for the kind words.

I don’t have the external sensor included for the Shelly 1, but it should be fairly easy to add.

For reference, create a R1L and you can see towards the bottom of the device controls screen there are 2 input states shown. I’ll do it in a similar way for the R1. Except I believe there’s only 1 input possible for the R1 - is that correct?

Follow up question regarding your external reed switch. In what cases would the reed switch input be ‘on’ but the relay switch would not also be on? Are they not tied together within the device anyway?

Thanks for the super swift response and apologies I should have been clearer.

Yes, it’s only possible to have a single external switch on the Shelly 1.

I have the reed switch set up as a contact sensor on the garage door. When the door is in the closed position the reed switch is activated/on, and when it opens contact is broken and it’s off. The main output of the Shelly acts like a momentary switch to raise and lower the garage door. I have the Shelly in ‘detached’ mode so the output of the external switch does not automatically trigger the relay.

As there are multiple ways for me to open and close the door (manual button, RF controller, Shelly) the sensor and the relay need to operate independently.

The Shelly is definitely getting the signal correctly as I can see the coloured indicator changing in the Shelly App.

I assume the Shelly will need to make calls to SmartThings hub based on the ‘External Switch’ or ‘Sensor’ outputs within the I/O settings?

Thanks again for any help.

Thanks that was very helpful. It made me realize that I was mistakenly looking at the ‘inputs’ status element instead of the ‘ext_switch’ element. Although the documentation doesn’t explicitly say it, I will assume the value of ext_switch.0.input is 0 if off and 1 if on.

Yes, the switch is wired and recognised as the exterior switch.

Your logic on the ON/OFF sounds logical to me.

Thank you

Wish I had seen this before just buying the newer Shelly Plus 1 devices , which I now understand to be Gen 2?

If you want I’m willing to help debug with my Gen 2 switches ?