[Edge] Heatit Controls Official Edge Driver [v2.3.0]

The solution to get the room temperature to show correctly is to

  1. create a virtual temp/humidity device for the room temperature (use vEdge creator [ST Edge] vEdge Creator: a virtual device generator for end users)
  2. Make a rule to mirror the required temperature from heatit into the vEdge device (Information here Mirror temperature sensor to virtual device - #9 by Paul_Oliver but substitute “roomTemperature” for “main” ). You will also need the API Browser+ here SmartThings API Browser+ ... Now Available to All to add the rule, then enable it.
  3. Make sure your vEdge device is in the same room as the thermostat
  4. Click on the room temperature and use the overflow menu to select the virtual device instead of the heatit thermostat

1 Like