[Edge] Heatit Controls Official Edge Driver [v2.2.0]

sorry, I don’t understand what functions you are talking about. I have all the features. the only small problem in the user interface there is no units after the number

Please send us an email at post@heatit.com and we’ll take it further there.

allt är bra .

tack för ett bra jobb


Good news!
I’ve a number of thermostats for a long time running smoothly on soon to be deprecated DTHs from RBoy and AdamV:
Their identifiers as displayed in the IDE are:

zw:Ls2a type:0806 mfr:019B prod:0003 model:0203 ver:4.00 zwv:6.07 lib:03 cc:5E,55,6C,98,9F sec:86,85,8E,59,60,72,5A,73,70,7A,43,40,42,32 epc:4

zw:L type:0806 mfr:019B prod:0001 model:0001 ver:1.08 zwv:3.83 lib:06 cc:5E,43,31,86,40,59,85,73,72,5A,32,70 role:05 ff:9200 ui:9200

zw:L type:0806 mfr:019B prod:0001 model:0001 ver:1.07 zwv:3.83 lib:06 cc:5E,43,31,86,40,59,85,73,72,5A,70 role:05 ff:9200 ui:9200

Q @HeatitControlsAB : Are all these “versions” covered by the official Edge driver?

The invitation link does not work. Probably the wrong link is added


Z-TRM3 is supported, as is the Z-Wave with v.1.08. We are yet to look into 07. I will let you know when I have tested that version.

1 Like


I tried the link now, it works for me.
Are you able to try to log in again or change which browser you are using?

The problem is that not the invate link is stored, but the page link. The invate link looks a bit different, and allows the first access with confirmation of the license condition.


When I click on the link to enroll, I just get a page with spinning wheel.

I have tried different web browsers, but the result is the same.

What to to?

Can you try this link?

Are you also able to try using this link?

Please give me a feedback ASAP so I can update the link in the post.

That link works. No more spinning wheel.

This link also work.

Great! Thank you for the feedback, I’ll update the post now.


I have enrolled and install the drivers, but when I connect the Z-TRM3:to my hub it comes up as a Z-Wave Device Mutichannel an not as a thermostat.What am I doing wrong?

After using “Scan for nearby devices” and starting inclusion on the TRM3 it will show in the list as a multichannel device. On my system, when I exit and wait for a bit it shows up as TRM3.

If this is not the same for you, are you able to screenshot the “Driver” tab in the device’s settings?

I included th TRM3 yesterday and it still shows up as a multichannel device.Looks like I don’t have a driver tab in the device settings.

Seems like it has not taken the driver in use.
I suggest trying to un-enroll the driver and re-enroll.

Driver updated to version 2.0.0.

Added support for Z-Push Button 2-4-8, Z-Push Wall Controller, Z-Dim, Z-Dim2 and Z-Water.
Reformatted the post.

1 Like

Hello, any updates on the 1.07 version?

Also, do I need to remove it and then add it again to pick up the new driver? How do I do that? Or can someone point me to a dummy’s guide to updating to Edge drivers? Not sure I understand the basic concept of enrolling, etc…


1 Like