[Edge] Heatit Controls Official Edge Driver [v2.1.0]

It’s better to use either manuals.heatit.com or document.heatit.com.
Since you are using the Heatit Z-Wave, on probably 1.7 or 1.8, the calibration for the other sensors has not been implemented, this came in 1.9.

Regarding the OTA, this is up to SmartThings to implement, not us.

1 Like

Hi! I just bought a Z-Water and a few Z-Temp2 thermostats, the Z-Water uses the Edge driver, but the Z-Temp2 does not. Seems to use a generic Thermostat DH (not Edge) and it does not work very well (i.e. not at all). Are you planning an update to the Edge drivers with support for the Z-Temp2?

Thanks,
Anders

Hi,

we are working on the Temp2 drivers and will release them ASAP.

1 Like

Sounds good. need to test it also. Hyvä Olli Pekka.

Any concrete plans for when the next release will be made? I 'm kind of stuck until that happens with only a half-working setup.

No concrete plans unfortunately.
It’s quite busy here, so not a lot of time to test the Beta drivers.

I would be happy to provide some testing feedback if you have any kind of beta testing programme.

Beta drivers are added to the post, see the bottom of the original message for the beta drivers link.

1 Like

Thank-you very much for that. I will test the Temp2 in the next few days.

I noted that the driver (beta 1.1) for ztrm2fx is not yet providing the temperatureMeasurement capability from “main” . Sorry to bang on about it but this is important for me, among other things the current temperature does not display on google home.

I am using “ST Device Info Viewer” [RELEASE] Simple Device Info Viewer to check capabilities.

1 Like

I understand, we are still looking into the best way to solve it.
Since the thermostat does not report to the gateway which sensor mode is selected if it has been changed locally, we need to decide which sensor to use.

It’s in “Preferences”. Can you use that?

The issue is that when the sensor mode has been changed locally (not via parameter). It will not be reported to the gateway.
Our thought is to always use the internal sensor for the main device temperature.

how about if the room sensor reports 0C , and floor sensor reports 20C.

main.temperarure = max (floor sensor, room sensor)

Hasn’t that always been the issue, even with the groovy drivers? Will it not “correct” itself next time you use the ST app to access the device? Maybe note it as a known issue? In general it is not going to happen more than once or twice after installation?

Edit: just to add… using just a single internal sensor as fallback will not work in my case. I have some devices using floor sensor only, some using room + floor limitation, and some using room sensor only (including internal or with external thermistor). Its just the way it has to be in an older house where the original thermostats were installed inside or outside of the bathroom, or the floor sensor “trekkrør” was missed out.

1 Like

There is a problem in the link to accept the invitation to install the Edge Driver, it just throws me a:
There was an internal server error.

Common issue or something else that went wrong?

Common issue today. :disappointed_relieved:

Unable to join channels (25 Jan 2023)

1 Like

Links works now:
Driver Install (z-TRM3)

  • Successfully added to Hub, one with full secure, two where it fails, but still got added…
  • See that it reports set temperatur, power usages etc
  • However when clicking on the theromstad in ST, nothing happens, its unable to connect…

So for me this didn’t work at all :frowning:

Any idea whats wrong (this is fresh install)…?

I will check what kind of functions can be made regarding this issue.

This might be true, but for our thermostats, we have previously chosen not to report back the configuration parameter values if they’ve been changed or updated locally. Well, not as much chosen, as just not thought about.
We will see what we can do to get the correct sensor value to show on the device.

What’s the distance to the gateway when you are including? Sounds like a problem where the interview might fail.