Edge Drivers Z-Wave+ for Homeseer WD/WS100+?

Thanks @philh30 ! If you have any other suggestions, I’d welcome them.

@Sylvain I made the change that philh30 suggested and packaged the updated driver

@anghinoni I also attempted to add hold events

Let me know if it works for you!

4 Likes

wow that was fast , now it is working Thank you

Thanks a lot @ryanjmulder it is working now!

@ryanjmulder

I have been waiting to try your integration when I return from my work assignment. I can see from the follow-ups that things look very promising. Thanks for the work and for sharing your efforts. I will try your drivers as soon as I am back.

@ryanjmulder
Works great! Thank you :pray:

Hi. Can someone point me in the right direction to install this Edge driver?

Thank you!

  1. Click the link above to go to the GitHub page for the driver.
  2. Scroll down a little and click the invite link found there
  3. Log in to ST, authorize for your hub
  4. Click “Available Drivers” and then install the Edge driver

FWIW, your switches will not pick up this driver until ST moves your switches to Edge.

You can check if ST has already switched you over by clicking one of your HS switches, then click the three dots top-right, and see if “Driver” is in the menu between “Edit” and “Information.”

If not, your options - once the driver is installed - are to wait, or to remove each switch individually, then re-add as “Generic Z-Wave Device” and the new Edge driver should get assigned automatically based on fingerprint (if not, go back to the three-dot menu, select “Driver”, and choose the driver).

1 Like

Hi @ryanjmulder , any chance of adding the fingerprint for the FS100+ Water & Light Sensor?

@SameGuy I’d be happy to, but I don’t know what the fingerprint is.
Otherwise, feel free to edit fingerprints.yml and add a profile.

1 Like

Thank you. Must not be converted to Edge yet. I’m not able to install the driver. Is there anything I need to do to get my account updated to Edge? …Somethign changed months ago. I was blocked from installing/editing smart apps. My switches stopped working. Isn’t that because of the Edge update?

Thanks for the quick response! This is what API Browser+ brings up (sorry, I can’t get it to display the left column on my phone):

What version hub do you have?

EDIT: Has the firmware been updated? (latest versions)

Sorry, @SameGuy, after looking at this closer I see that you’re asking about a sensor, not a switch.
I don’t have any experience with the sensors, and I’m sure that this switch driver won’t work.
However, I did see this thread which includes a driver for a Homeseer sensor, they might be able to help you there: [ST EDGE] Z-Wave Sensor Driver Channel - including specific Ecolink, FortrezZ, HomeSeer and Zooz models

1 Like

Awesome, thanks, sorry to confuse things from my end. Some of us (procrastinators) have been waiting til things broke before searching for fixes, so of course there’s a bit of flailing as we (I) try to come up with solutions. I hadn’t seen that thread in my searches yet. :+1:t3:

Ok. Thank you for your help!

@ryanjmulder

Just as an FYI, I just opened a pull request to incorporate some additional work. Your posting was a good chance for me to jump into these Edge Drivers with both feet.

Please let me know if you want to go this contribution route, or if I should generate a new channel invite. The initial commit burst was meant to help build out the fingerprints/profiles/preferences/configurations, and to emulate the Community structure. Now that is in-place, I was looking to properly add additional functionality for dimmer rates etc.

PS – I have largely ignored the fan capabilities, but at first blush, it looks like both 3-speed and 4-speed capabilities exist in the default zwave-fan driver.

2 Likes

@jshessen WOW! I was dreaming of building out this driver someday when I had time, and I’m so glad that you did. I can handle the PRs and packaging if you want, but it probably makes more sense for you to take over this driver, if you’ve got the time and the passion for it.

If you want to post an invite link here, I’ll edit my posts and readme to point to yours.

2 Likes

11 posts were split to a new topic: [BETA] Edge Drivers for Homeseer Devices

I moved the conversation about the new version to its own thread so that’s the one that will show up in the community-created wiki quick browse lists now and it will be easier to find. :sunglasses:

Here’s the new thread:

[BETA] Edge Drivers for Homeseer Devices

4 Likes

Can you add mfg 0184 for hs/hd100 switch. Official driver doesn’t support ws100 switch. Your driver installed on one ws100 switch and not the others.

zw:L type:1001 mfr:0184 prod:4447 model:3033 ver:5.15 zwv:4.24 lib:03 cc:5E,86,72,5A,85,59,73,25,27,70,2C,2B,5B,7A ccOut:5B