EDGE Drivers. Devices with Multiple Tile capabilities are not shown in Android App

Hi @nayelyz

Devices that have a multi-tile VID, created according to the EDGE documentation have stopped working and cause android 1.7.93.26 APP to crash when trying to display them.

This makes these devices unusable.

Has anything changed in the way of creating these VID device presentations that is not documented?

Thanks

3 Likes

@nayelyz I’d just like to add a couple of points.

  • If you do display a page with one of these tiles on it and the app crashes you may find that the app will attempt to open up on the same page and so instantly crash again, and you need to reinstall or wipe data to break the cycle.
  • Although on one of my phones the app only crashed when attempting to display one of these tiles, on another one the very existence of the tile was enough to crash the app after a short period. So you can’t even hide the file in separate room that you never open. The app seems to have reverted to a slightly sluggish start up behaviour and it was like it crashed as soon as it got around to updating the device with the problem tile, but that is speculative of course. Once it crashed in that fashion it pretty much crashed on start up from then on.

I’ll check with the team. Just to confirm, you don’t have more than 5 groups in those custom VIDs, right?
This means “main” and other four groups.

Thank you both for the info.

No, All vids works fine in previous Android App
Thanks

Ok, I wasn’t able to replicate the issue, I had the device I used to test the issue in the favorites section that you reported, I updated the app to test but it is not crashing, so, I need more details about this, please.

First, what do you mean by “Edge documentation”? Dashboard groups can be used in different integrations, so, they belong to the device configuration and presentation docs.

I tested on two Android devices and none is crashing. So, please help us to create the report by providing the following info:

  1. support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
  1. The logs of the mobile app. Please check if these steps work:

It seems to only happen with tiles with all 5 groups.
If tile has 2, 3 and 4 it works fine

@nayelyz I have had this crashing problem with multi-tiles from several developers including @Mariano_Colmenarejo, @philh30 and @krlaframboise

My tile has five groups too.

I refer to this documentation, that you put in a post, to make presentations of devices, which includes multiple tiles.

I had the same issue as all above

I had a large tile on the home page, as soon as i scrolled down to it, the instant the tile appeared on screen even by 1 pixel the app crashed out back to android desktop.

If i chose a room with cameras but standard tiles the app crashed back to android desktop

If i chose a room with large tile the app crashed

I sent an error report with log file but support suggested i clear cache and send an error report… which i had already completed and done

I uninstalled the ST app, re installed, followed set up pages when first using the app ,the app crashed and refused to ever open

Re installed previous version of app, changed all large tiles to single smaller version tiles

Updated app again to latest version, no crashes

If needed i could pm the bin file to you @nayelyz

Thanks, @fido. I was able to reproduce the error, so, they are no longer necessary so far, I’ll let you know in case we need something else.

3 Likes

I can confirm it used to work with this presentation and stopped working with the latest app version.

I am not a developer, but am using one of @philh30 's drivers and can confirm my app crashes since a few days every time I press the devices button, and same happens to everyone in my family.

If the driver is using a multi-tile it has been a problem since ST broke something in the last app update.

1 Like

It does use multi-tile, yes, so I deduced the app update caused this. Thanks.

You can uninstall the app on 1 device and re install the previous version, use that to change the mosaic tile to a basic tile and then upgrade again to the latent version all should be well

Or use a device not affected by the latest update, change the tile and all should be well

If you are using a driver from @Mariano_Colmenarejo that now shows (old) at the end, check the driver thread for the latest update, Mariano has updated many drivers

1 Like

Thank you - that is a good idea and I will do it on one device so at least someone can control the devices without needing to resort to a laptop. That said, not sure I will change the tiles for all multi-tile devices - I have almost 50 of these devices and it’s a pain… then I would have to revert back when they finally fix the app (hopefully in the next update).

Though I do use @Mariano_Colmenarejo’s drivers, this particular one was created by @philh30 and it’s been ticking along nicely for a few months now.

Co-incidentally, since we are on the matter - I have a few multi-endpoint devices such as Qubino Flush 2 Relay (using the Edge driver from the Smartthings Beta channel) and Aeotec Nano Duo (using the Aeotec driver for that switch switches. These show in the app as a single tile. Is there any way to convert these to multiple tiles?

I dont think Smartthings stock drivers provide multi tile (Mosaic) capability in any driver

No one knows if they ever will but i doubt it

Again Aeotec are responsible for there integration, i doubt they will provide a multi tile either

1 Like

Thank you, no worries. Hopefully, developers here will take up the challenge once the dust settles a little.

1 Like