[Edge drivers] Creation of new devices in the wrong room

Hi. Just setting up to use this driver. When I first installed it, my SmartThings hub location in SmartThings was in my “Bedroom” room, and therefore the Creator device was installed in Bedroom also. After reading other posts, I created a new room called “Smarts” and moved the ST Hub and Creator there. Unfortunately when I create a new virtual device, it still creates it in Bedroom. I have deleted the Creator and completely removed the driver, re-booted ST Hub, cleared ST app cache and reinstalled everything. Although when adding the creator device, it says it has added it to the Smarts room, it still shows up in Bedroom and subsequent virtual devices are still created in Bedroom. I can always move them back to Smarts, but is there any way I can get new virtual devices to create in my Smarts room?

Hi this sounds like a SmartThings platform issue and not something the driver has control over.

@nayelyz , is this something you can comment on please?

Hi, @mmcmillan
It’s possible the “old” room where the Hub was is still present somewhere, so, I’ll open a report, can you provide the following, please?

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM
  2. Enable support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
  1. Create a new device take note of the time when you perform this action and share it with me. Eg. 17:17 CST
  2. Share the name of the new device created to get its ID and add it to the report.