[Edge drivers] Connection error Tasmota driver

This happened a few times now, where the tasmota edge driver is not able to communicate with the tasmota devices using the Gateway IP address.
Clicking on the gateway IP/port# from the ST app, it times out. I have to manually reset the HUB for it to come back online with a different gateway IP and port.

Is this a ST hub issue or the edge driver?

below is a log from one of the devices.

17:12:39.589 RUL: EVENT#SW performs “WebQuery POST [Content-Type:application/json] {“Mac”:“E8DB84DD079A”,“cb”: “Status 0”}”
17:12:44.799 RSL: RESULT = {“WebQuery”:“Connect failed”}
17:12:53.484 RUL: SWITCH1#STATE performs “backlog event sw=SW1_1”
17:12:53.490 RSL: RESULT = {“Switch1”:{“Action”:“ON”}}
17:12:53.509 RSL: RESULT = {“Event”:“Done”}
17:12:53.550 RUL: EVENT#SW performs “WebQuery POST [Content-Type:application/json] {“Mac”:“E8DB84DD079A”,“cb”: “Status 0”}”
17:12:58.770 RSL: RESULT = {“WebQuery”:“Connect failed”}
17:12:58.797 RUL: SWITCH1#STATE performs “backlog event sw=SW1_0”
17:12:58.804 RSL: RESULT = {“Switch1”:{“Action”:“OFF”}}
17:12:58.822 RSL: RESULT = {“Event”:“Done”}
17:12:58.861 RUL: EVENT#SW performs “WebQuery POST [Content-Type:application/json] {“Mac”:“E8DB84DD079A”,“cb”: “Status 0”}”
17:13:04.050 RSL: RESULT = {“WebQuery”:“Connect failed”}
17:16:08.105 RSL: STATE = {“Time”:“2023-04-04T17:16:08”,“Uptime”:“15T09:50:05”,“UptimeSec”:1331405,“Heap”:24,“SleepMode”:“Dynamic”,“Sleep”:50,“LoadAvg”:19,“MqttCount”:0,“POWER”:“OFF”,“Wifi”:{“AP”:1,“SSId”:“Indigo-IOT”,“BSSId”:“E8:1D:A8:EC:A5:D8”,“Channel”:11,“Mode”:“11n”,“RSSI”:96,“Signal”:-52,“LinkCount”:6,“Downtime”:“0T00:00:20”}}
17:16:08.118 RSL: SENSOR = {“Time”:“2023-04-04T17:16:08”,“Switch1”:“OFF”,“AM2301”:{“Temperature”:null,“Humidity”:null,“DewPoint”:null},“TempUnit”:“F”}

Unfortunately, it is the ST hub issue.

Is there any solution to this, or do you know why this happening?
I had several sensors running until a week ago they were offline and I found that there was no connection through the gateway where before I could see the devices on the Web page. Several hub reboots and the IP gateway changes but still no connection.

This site can’t be reached is unreachable.


Don’t know what to do as I was preparing to setting up some more devices, but now on hold.

Are all your devices and ST hub on the same 192.168.4.n ? If they are not, then it’s probably your network/subnet issue.

Yes the hub is on and the 3 ESP8266 I have are 67,68 and 69.

This morning found the hub has updated firmware to 47.10 and the gateway connected!
No idea why after 2 months running perfectly I have had a week offline, but now online again.

Thanks anyway.

Hi, can you and @hongtat provide more information about the issue, please?

  1. What’s the behavior expected
  2. How is it working that causes a problem for you

    These two first points should be shared with the edge driver logs that show the behavior to see how are the commands/events being handled

I’m not able to pull any logs right now as I am away.
But here is the post I did back in Apr describing the issue. And @hongtat replied it is an ST issue.


Yes, but it is not clear why it is an ST issue, it says that the connection failed but I don’t know if there was any troubleshooting. Or, how does this driver create the connection, @hongtat, it would be useful to get more details from you, it would be useful for the team to see the code of your driver implementation to have a better idea of what could be the problem, please

Hi @nayelyz

It implements the same server.lua as SampleDrivers/server.lua at main · SmartThingsDevelopers/SampleDrivers · GitHub

The IP:Port stops listening intermittently for some users and have to reboot the ST hub to get it working again (new port). It happened intermittently for me in the past in some ST firmware and haven’t encountered it for pretty long time.

Hi, @hongtat
In the description of your driver, it says it can manage different Tasmota devices, @KennyG how many devices are connected to the driver?


I am having this issue almot every day where the hub stop listening. I have 20 devices trying to connect.

Hi, @ragoss
Thank you for the information. I’ll ask the engineering team about this and let you know their feedback.

What hub are you using?

I was using ST hub v2 when I encountered this issue. The number of devices doesn’t matter, the IP:Port will still stopped listening, and it went away after certain firmware upgrade last year.

I have hub v2, US customer Rev E. I also noticed that a process for listening for MQTT request also stops when this process stops.

Hi, @hongtat
The team mentioned that it could be useful if you used something more reliable than register_channel_handler which is:

    while true do

It also may be helpful to pass log.error or print to server:tick to get any error information that could be helpful to see what’s going on.

Hi @nayelyz

Yes. Already have this since last year.

    while true do

We are in big trouble, we need to reboot hub 2-3 times in a day…