[Edge drivers] Aqara TVOC

Hi all.
I have the same problem: I only see the TVOC and not the temperature and humidity.
So there is no solution?

I didn’t find one for now. I also had another sensor (HUE motion sensor outdoor) showing all measures (temperature, luminosity) but not movement! It looks sometime ST is not receiving specific measures from devices even if they’re supported.

Hi guys, the only solution for this is refactoring the driver. I’ve tried contact this driver developer but he not answered yet.


I guess there is still nothing new. I was thinking, that maybe it was added to official SmartThings Edge Drivers Beta, because there is the Humadity and Temperature sensor handler, but seems like not for this device, I tried to re-add the device, check available handlers, but still only Zigbee Thing from the official Edge Drivers and Zach’s not showing the temperature and humadity unfortunately. Is there any other solution for this, which I did not try/find yet?

Hi, @Krosta. For a device fingerprint (support) to be added to an official SmartThings Driver, the company that manufactures the device must go through a certification process for his device to be recognized as Works With SmartThings.

You can take Zach’s driver code, which he shared here: EdgeDrivers/xiaomi-sensor at master · varzac/EdgeDrivers · GitHub
And, make the corresponding modification needed to support those capabilities again, since there was a firmware update that broke this integration as mentioned in this post: [Edge drivers] Aqara TVOC - #7 by Simon_Townsend

There is a way to downgrade firmware using Conbee2, but with 0022 firmware the device is not updating the status, but edge driver is working… Do You know if there is a possibility to listen what messages the device is sending?

edit: Do You know if there is a way to port this: zha-device-handlers/zhaquirks/xiaomi/aqara/tvoc.py at dev · zigpy/zha-device-handlers · GitHub to edge driver?

Hi, @koxok
There’s no tool to port that code directly to an Edge driver, it would depend on the developer or someone who knows the behavior of that handler to “translate” it into the code expected by SmartThings Edge. You can find documentation about Edge development here: Get Started with SmartThings Edge | SmartThings Developers

Is there anyone actively working on this driver? I have one of these Aqara VOC monitors (model AAQS-S01) and would love to integrate it. I use it to monitor my 3D printer room. Resin printing puts out VOCs and I would like it to control a vent fan if the numbers rise too high.

There is a driver working:

Do you have a link? I have been searching here for hours.

Try this:


Got it installed, but it still isn’t updating. I’ll let it see for a few hours and see what happens.

Unfortunately, after two days there are still no updates.

I discovered the same driver by accident yesterday. I installed it today and my aqara tvoc is now working correctly…


This link doesn’t work.
It must be the invitation link.

Did you just install the VOC driver or did you install others from the list too? I have the TVOC driver installed and that is not working.

I deleted the device and readded it. All is better. Temp is even in Fahrenheit. I am still awaiting humidity, but don’t really need it.

Awesome. Yes I’ve found sometimes just juggling with the drivers makes a difference… Glad there is finally a solution for this one…

Did you do a single press in reset button?

If not, try do it in 2 or 3 secs for interval. Here this works.

It is reporting now, but the update interval is atrocious. TVOC updates every couple of days, even when there are huge swings. I have tried using the advanced tab of my.smartthings.com and SharpTools to issue refreshes to it, but the device does not send refreshed data. This makes it a bit useless as a triggering device.