Edge Driver - Third Reality Smart Button

Hi Brad,

I submitted a request on the ST Community for to developer Yakov Gerlovin See: https://community.smartthings.com/t/st-edge-beta-buttons-and-remotes-edge-driver-aqara-ikea-tuya/241708/22

You may want to bookmark this thread for receipt of a potential driver solution.

1 Like

Released an Edge driver which supports the Third Reality Smart Button. Check details here:

3 Likes

@csstup @Buds_Smart_Home i just added the third reality motion sensor and it worked with the Zigbee Motion Sensor Driver. Just an FYI


This thread is regarding the Third Reality Smart Button, which didn’t have an Edge driver until Corey released his today.

It isn’t that Third Reality devices aren’t supported in stock Edge drivers, it is that the button in particular hasn’t been added to the ZigBee Button driver yet. We can reasonably expect it to be as it is fingerprinted in the Ikea Button DTH, but now users have the option not to wait.

@BlackRose67 @orangebucket my mistake guys… I added the wrong pics. I was reading different thread and got them mixed up

My button is working with the “CStup Edge Drivers”


2 Likes

Surprised it was missed if it was already in the DTH.

I wasn’t able to add my ThirdReality button initially until I created my own DTH in the IDE, based on the Ikea Button.

There are a few devices like that one across various drivers. It is like the ‘to do’ list was taken from a snapshot of the drivers as they were in July last year and they haven’t all been revisited yet. I think the button was added to the DTH in August last year.

1 Like

Very possible. I thought another reason because the framework does not yet have cluster 0x0012 (Multi state basic) handling classes generated out and this device uses those to handle all 3 states. The two pressed states you can use existing clusters, and the hold state you might be able to cheat with another. Its on my list to request 0x0012 support be added.

2 Likes

Just set up my Third Reality button with your driver and it works perfectly. Thank you so much!

2 Likes

Thank you SO much for this! My ThirdReality smart button (model 3RSB22BZ) stopped working entirely today, and only a generic Zigbee driver was getting installed. That generic driver offered no control options, but yours worked perfectly!!!

2 Likes

Thanks for creating this driver! My two buttons finally migrated to a stock driver and went dead. Everything with the stock driver looked fine, but nothing would respond. Switched drivers and all fine now. I had to rebuild my few automations, but I assume that’s because I used the built in UI ones for the button vs an independent automation.

1 Like

Hi Todd,

@csstup is the developer that I contacted to add the Third Reality Smart Button to the edge driver. I’m glad you were able to discover the driver and get it working. I use the same button to control me studio lights. It works great!

Bud

1 Like

The 3RSB22BZ must have more of a story to tell as it was fingerprinted in the Ikea Button DTH but not ported to Edge and it seems to be going through certification at the moment. This seems rather unfortunate as end users might reasonably expect it met the criteria for migration. That was certainly what I presumed in my earlier comments in this thread.

I don’t use the device myself but it certainly isn’t the only device that was explicitly supported in stock handlers but not ported. One wonders how users are supposed to follow the guidance they are given in these cases.

My switches wound up crapping out 2 days ago too. All the sudden there were about 50 button press options and none of them worked. Reinstalled and ended up as a generic ZigBee thing. This driver got me back in business. Many thanks!

I had same issue and installed the Zigbee Button CS CStup Edge DRiver 2022-09-22T07:54:35…
The primary button works but the Held and Double pressed actions do not. Not reported here, hard to believe I’m the first to report so long after update.

Smartthings Hub on 48.00005

I’ve mentioned this before. Neither the driver nor the hub have anything to do with the timings of “held” or “double pressed” on this device. The device itself sends either a “I was pressed”, “I was double pressed” or “I was held” type event.

I just tested the device with the 2022;09-22T version of the driver on a hub. All 3 actions work fine and register.

thanks for checking. i found the problem was thedevice was set in the wrong mode. Holding the front and inside buttons put the device back to the correct mode. all good.

What was the alternate mode you were in? Wondering what benefits that might have. Or is just reduced to a single press event?


Somehow the device got into Echo mode. Resetting via the instructions here took care of the issue I was having. The clue is the flashing LED was alternating red/blue rather than only blue flashing.

1 Like