(EDGE Driver-Mc): Zigbee Temp Sensor and Child Thermostat Mc, Zigbee Temp Sensor with Thermostat Mc

Mariano will need the need the fingerprints to be able to identify it.

1 Like

Hi @Cesar_Novo

Indeed device was added to the driver
I have seen in another post that it does not actually use the EF00 cluster and if it does not work I do not know what can happen.

I would need you to send me the logs with the CLI when the device is paired with the driver and see that the device responds to the configuration

1 Like

@Mariano_Colmenarejo Truly, you’re the best! A real Master!
Unfortunately, I’m a newbie… I’m always learning, and i just recently installed the smartthings CLI and started using it (install drivers and not much else)…
Could you help me by describing which command to use?
Sincerely, thank you very much for your patience!!!

Uninstall the device form app

Enter the command in CLI window

smartthings edge:drivers:logcat

It will ask you for the IP of the Hub
Then the number of the driver that you want to see.

Once the logcat is running
Install the device with app, after a few seconds the log of the pairing messages between the driver and the device will appear

1 Like

Hi @Mariano_Colmenarejo can you please add the following temperature and humidify sensor:

β€œdeviceManufacturerCode”: β€œ_TZ3000_itnrsufe”,
β€œdeviceModel”: β€œTS0201”,

@dotan_shai
Thanks

Hi @Ori_Shafir
Added to this driver version

─────────────────────────────────────────────────────────     
 Name         Zigbee Temp Sensor and Child Thermostat Mc 
 Version      2023-01-21T11:05:03.967776771
─────────────────────────────────────────────────────────
- id: "_TZ3000_itnrsufe/TS0201"
    deviceLabel: Tuya TS0201
    manufacturer: _TZ3000_itnrsufe
    model: TS0201
    deviceProfileName: temp-humid-battery
1 Like

Thank you @Mariano_Colmenarejo

2 Likes

Hi @Mariano_Colmenarejo!
I share with you a link with the Tuya TS0601 logcat, because it as to many caracters, and i couldn’t insert the tex in this message:
https://justpaste.it/cuwjs
Hope everything is OK and, again, thank you very much for your time, pacience and hard work in favor of us all!!!

PS - I took a while sending the logcat because yesterday my QNAP system HDD died, but that’s another story :frowning:

Hi @Cesar_Novo

This device sends values 0 for all the capabilities, temperature, humidity and battery.
It answers that it is configured well, but then it does not send the values well.

all the TS0601 I know use the EF00 cluster, this is a rare case, but it doesn’t work

1 Like

@Mariano_Colmenarejo I understand, no problem!
Thank you for your time and troubles!
The only strange thing is that, accordingly to this forum: https://community.home-assistant.io/t/temperature-and-humidity-sensor-with-lcd-display-tze200-znbl8dj5-sending-only-zeros/476547/9, it works with Home Assistant using ZHA…

Anyway, again, thank you very much!

HA writers have the same problem, it sends 0 values for everything.

Others answer that in zigbee2mqtt it worked for them and for another in HA it started to work from one day to the next without knowing why.

I don’t see any solution

You can try heating or cooling it to see if it sends a new value or reboot the Hub

1 Like

Try to use the , configureMagicPacket method that you mentioned before in order to get NOT zeroes. Also, according to Z2M the following DP are in use. I don’t think you aware to that:

                [1, 'temperature', tuya.valueConverter.divideBy10],
                [2, 'humidity', tuya.valueConverter.raw],
                [4, 'battery', tuya.valueConverter.raw],
                [9, 'temperature_unit', tuya.valueConverter.temperatureUnit],
                [23, 'temperature_calibration', tuya.valueConverter.divideBy10],
                [24, 'humidity_calibration', tuya.valueConverter.raw]

I hope this can help.

1 Like

@Cesar_Novo

Try with this driver version with tuyaBlackMagic()

─────────────────────────────────────────────────────────    
 Name         Zigbee Temp Sensor and Child Thermostat Mc 
 Version      2023-01-21T20:58:21.833584758
─────────────────────────────────────────────────────────
1 Like

@Mariano_Colmenarejo I tried to update the driver, even in smartthings CLI, but until now, i only get the driver version 2023-01-21T11:05:03.967776779… As soon as the new version becames available (with tuyaBlackMagic :laughing:) i promise i’ll send a feedback!

Thank you (and all the friends in the forum) for your time and dedication!

@Cesar_Novo

Sorry I published now. I forgot publish in shared channel :man_facepalming:

1 Like

Sorry… updated the driver… waited several minutes (the β€œsignal metrics” even updated to new time), but everything stays the same…

Anyway, thanks… Maybe, not enough tuya β€œmagic” :wink:


1 Like

@Cesar_Novo

Are You tried unistall and reinstall device?

1 Like

Hi @Mariano_Colmenarejo !

Yes, of course… Every time i update the drivers, first of all i remove the device and do a new search.
Even when it doesn’t work, i repeat (remove and do new search) just in case…

1 Like

Hi @Cesar_Novo

If you want, you can send me a pairing log to see that it responds to yoursBlackMagic

1 Like

Here’s the link for the log cat (with the updated driver - BlackMagic: https://justpaste.it/9omie

A big thanks!