(EDGE Driver-Mc): Zigbee Temp Sensor and Child Thermostat Mc, Zigbee Temp Sensor with Thermostat Mc

32⁰F is 0⁰C

Hi,

All zigbee devices sent temperature in °C, the app convert to °F for locations.
0°C = 32°F.

When I solve it, if you want you could use the child thermostat to control your heater

I do not know if this at all is related to other problems concerning sudden temperature drops? It happens randomly with a number of sensors at different locations.

(Aqara temp/hum/press and Zigbee Temp Sensor and Child MC driver)

The drivers are simple transmitters of the temperature values they receive from the devices.

The only thing they do is divide the received value by 100 to convert it into °C with 2 decimal places.

If it is a repetitive value and from one model and manufacturer, it may be a malfunction.

If you want you can check with the cli logs what value the device is sending

Ha!! Yes…I wasn’t thinking! Thanks!! I’ll await the update!!

I was thinking that maybe this driver change/“correction” - which I think you contemplate - may be extended to - 100°C and not 0°C only?

1 Like

Hi Mariano!
I’m an italian user and in Italy we use Vimar as Thermostat.
there are a lot of pepole that can’t find a way to use their thermostats, because nobody use Vimar out of Italy.
We ask for your help, please.

A thermostat is a more complex device than a switch or a temperature sensor.

It is not enough to add your fingerprints to an existing driver.

Need to know all its characteristics, modes used, if it is used for heat, cold or both…, it is necessary to know the manual and the cluster and attributes it uses to see if it is possible to add it or have to write a specific subdriver and the most It is important to do debugging tests, viewing logs with the CLI

If you are willing to provide the manual and send logs with the CLI to debug the driver, then I could try doing that

Dear Mariano, thank you.
i don’t know how it works, because i’ve never used it: for use vimar devices in classic way you need a gateway. in my home i haven’t install it, because i work only with smartthings and zigbee protocol.
I don’t know if this can help, anyway this is the link of the product: Termostato rotella connesso IoT2M grigio - 02973

of course i’m willing to share with you the logs, but i have to know how :smile:

really thanks Mariano

Hi @S.F.B @jrichardw

I need the fingerprints of yours devices to make the driver modification

Hi @Sgamo

2 months ago the Vimar 02973 thermostat model was added to the Zigbee Thermostat stock driver.

The fingerprints that were added are model = “WheelThermostat_v1.0” different from yours, which are model = “Thermostat_v1.0”, although your Vimar 02973 model in the manual you published is the same.

I have added your fingerprint to my Zigbee Thermostat Mc controller and try to see if it works

───────────────────────────────────────────────────
 Name         Zigbee Thermostat Mc
 Version      2023-10-23T11:40:42.842927385        
───────────────────────────────────────────────────
- id: "Vimar/02973-smart-wheel-thermostat"
    deviceLabel: Vimar Smart Thermostat
    manufacturer: Vimar
    model: WheelThermostat_v1.0
    deviceProfileName: thermostat-fanless-heating-no-fw
  - id: "Vimar/02973-smart-wheel-thermostat-2"
    deviceLabel: Vimar Smart Thermostat
    manufacturer: Vimar
    model: Thermostat_v1.0
    deviceProfileName: thermostat-fanless-heating-no-fw

How do I find that? I looked in the ST app and on the advanced web portal and I cannot find the fingerprint.

In the advance web app the Fingerprints are listed as the Mfg. Code and Model. He needs both.

2 Likes

Ah!!! Thank you!!!

@Mariano_Colmenarejo here’s the info:

Manufacturer Code: LUMI
Model: lumi.weather

1 Like

Hi @Karsten_Nygard

Merged to Zigbee Thermostat Mc driver the TEST version for NAMROM thermostat tested by you .

This is the new driver version.
You can perform an App driver change to this new driver version.
I will delete the TEST driver version from my channel, but you can use this driver version until you delete this TEST driver version from your Hub.

───────────────────────────────────────────────────
 Name         Zigbee Thermostat Mc
 Version      2023-10-23T16:50:50.897846628        
───────────────────────────────────────────────────
- id: "NAMRON AS/4512737"
    deviceLabel: NAMRON Thermostat
    manufacturer: NAMRON AS
    model: 4512737
    deviceProfileName: namrom-thermostat

Please, could you delete the posts with logs published in this thread, they are no longer necessary and the thread would be cleaner, Thank you

Thank you for bringing this thermostat to the community, it seems very complete and good underfloor heating thermostat

1 Like

Dear Mariano.
Thank you, but after the reconnection of the device in my hub, i can’t see from the app the possibility to switch driver.
i try in the IDE and the error is: Error changing device driver to “Zigbee Thermostat Mc”. Ensure that the driver you are trying to change to has a valid fingerprint match with this device.

Am i doing something wrong?
Thank you

Hi @Sgamo

Delete the zigbee thermostat Mc driver from your hub and reinstall it from my channel.

You have to delete the device with the app and add it again with the search nearby option.

It is not worth changing the driver, the device is not configured correctly

1 Like

Mariano, IT WORKSSSSSSS!!! :grin: :grin:

Last problem and i swear, i’ve done, and i will not forget to repay you in the correct way for your patience and work.

I’ve got 3 thermostats, i’m asking myself why the first one work and the other 2 no.
i have to give you the fingerprint of the others? aren’t they the same?

It could be different

can i post it?