(EDGE Driver-Mc): Zigbee Switch Mc, Zigbee Switch Power Mc, Zigbee Multi Switch and Child Mc

Sorry, this devices do not work with my drivers.
Ask if they can add it to any driver of @erickv or @ygerlovin

So I don’t know if the problems are related, but I deleted the “All Switch On-Off” tile–and the routines on both the Main sw1 and Child sw2 worked for a few days, then stopped working.

They didn’t come on or off according to schedule at all this week, and when we test the routine for times 5 mins in the future, they seem to work on/off. But then we look at phone again 5 mins later, and the Main sw1 tile shows “powered on” again–even tho nothing is actually running.

Put “All Switch On-Off” back in play, and still nothing seems to change whether we turn “All Switch On-Off” off or on. Not sure what purpose it serves. It does not change the state of either power switch running my pumps.

I don’t see that the intermittent execution of the routines is related to the driver.
Rather, it seems to me a possible problem related to your zigbee network, the smartthings platform or the routine itself.

Last week I myself was seeing problems where the android app shows different states in the tile and in the details view for the same device and it was driving me crazy, but this is how it is with smartthings with constant changes.
Then it fixes itself without knowing why.

If you are changing devices from DTH to edge drivers, this causes the zigbee or zwave networks to be affected with each change and have to be constantly rebuilt, which can cause performance with significant delays in routines, which then disappear or random disconnections of devices…

Is your device far from the hub or other zigbee repeaters in your network?
How is the routine that fails?

The operation of the All switch On-Off has a small delay of about 2 seconds with respect to the physical switches, because when a state change is made in any of the physical switches, the driver has to interrogate the device to determine the real state value of each one of the switches and wait for its response to update the status in the app.

The driver works the same whether you have created the child switch or not.

@Mariano_Colmenarejo–Ok. I’m trying a few other things, and I’ll let you know what happens as I try them. I know that the Groovy DTH worked flawlessly for years, but also there was a different presentation–the tile was just one static panel, with 2 switches and a power meter display on that panel/tile. There never was an operable “All On-Off” switch that I ever saw–certainly no routines for such a switch. We were able to define routines for both pump switches separately–but they were not parent/child–more like siblings. When I turn on/off the “All On-Off” switch now, about half the time nothing happens–so I’m sure that this new switch and it’s state (even after it’s been “deleted”) has something to with whether my routines kick off. Just have to isolate that behavior.

Yesterday we added the “All On-Off” switch back into the clutter on my phone, and the routine started working again. The day before we had to start and stop both pumps manually, with the switch deleted–no changes to the routines or Zigbee network. Trying a few more permutations and options.

Hi @wtmayes

In this driver the child devices that are created are simply mirrors of their parent switches in the multi-component device.

the parent switches continue to exist and function just the same.

It is not mandatory to create them, they are created for the user’s convenience to facilitate voice routines or location in different rooms.

The All switch On-Off button works as its name suggests:

  • If switch-1 and switch-2 are off and you press it, then switch 1 and 2 turn On
  • If all switch-1 and switch-2 are On and you press it, then switch 1 and 2 turn Off
  • If switch-1 or switch-2 is on and you press it, then switch 1 and 2 turn Off.

If you don’t use it manually or with routines, it doesn’t do anything, it just monitors the state of switch-1 and switch-2

I don’t know what routines you want to do, if you post them, tomorrow I could give you my opinion.

Now I’m going to sleep, it’s very late here