(EDGE Driver-Mc): Zigbee Light Multifunction Mc

hello again, today i had my main UPS go out, which brought down the hub. Once i got power restored, my new Sengled e11 n13a will not reconnect to the hub. it installed with the Zigbee Switch driver. will this device work with one of your drivers?
details:

|Name| on-off-level |
|Mfg Name| SmartThingsCommunity |
|Mfg Code| sengled |
|Model| E11-N13A |

thanks

Hi,

This bulb is in the stock driver, it should pair with it.

It does not exist in my driver, but it should be able to match by generic clusters.

When I have some time I will add the fingerprints

- id: "sengled/E11-N13A"
    deviceLabel: Sengled Light
    manufacturer: sengled
    model: E11-N13A
    deviceProfileName: on-off-level
1 Like

gracias parcero. this is my first experience with a zigbee bulb device losing connection and turning on and not reconnecting. i did some reading, and saw that others changed their bulbs, for a bulb that had a driver that would reconnect properly after a hub power outage. i was just wondering if this was possible. thanks, i performed Sengled re-pair procedure, and the bulb reconnected after performing a Scan for Nearby Devices during the bulb reset procedure, it paired and remained the same device in my list. not the most inconvenient issue… but… still an issue. thanks for looking in to this.

No bulb should lose its zigbee network id when the hub is disconnected.

It is not something that the driver controls.

you can disable secure zigbee rejoint mode on the hub, which makes it easier to rejoin devices automatically.

hmm, well, i dont understand how the hub lost the device then. and id rather not disable the security feature.

Hello Roy_R,
Yes, Mariano is great ;o)

Short question:
I bought the GL-C-006P, too.
I’m curious what light you’re running it with?

I use it with a 24V CCT LED.
https://amzn.eu/d/dmp8LdK

Unfortunatley it won’t change the tempertature of the LEDs all the way were the cold lights are off.
Means if I idle the temperature all the way down to 2700K, it appears more like a 4000K light.

I had the same issue already with 2 different controller, were I asked Mariano to add them with 2000K to 6500K range instead of 2700K-6500K

MiBoxer Dualwhite Zigbee Controller

  • manufacturer: _TZ3210_jtifm80b
  • model: TS0502B
    and

Iderwel RGBCCT Zigbee Led Controller 2000K - 6500K

  • manufacturer: _TZ3210_ijczzg9h
  • model: TS0505B

I really wonder if the LED Strip might be my problem and not the controller?

Best regards,
Stephan

I think I’m using the same light strip. But at the moment mine is powered down, it wouldn’t turn off in the middle of the night. But that could be due to the button I have connected to it.

With you saying β€žpowered it downβ€œ you mean its not in use at the moment?

I guess you can not tell then at the moment, if your cold LEDs are still on a little, changing the temperature to 2700K.
With 6500K, all warm light LEDs supposed to be off and the cold light LEDs supposed to be on. Changing the temperature to 2700K the warm LEDs supposed to be on and the cold should be completely off.

I just wondering if anybody else has this problem.

@Mariano_Colmenarejo do you think it would be a big deal changing the driver for this controller GL-C-006P from 2700K-6500K to 2000K-6500K.

Thank you very much everybody for this discussion and the help.

Best

Correct. Busy busy, and been active with the smarthome for a while now.
But I don’t think mine go up to 6500k. I’ll save this notification and when I’m back at it I will check in again.

1 Like

Hi

I was looking up features of this device and it looks like the range is 2200k to 6500k.

It is possible that when the value 2700 is sent, the controller does not completely turn off the cold LEDs.

I could give the profile 2000k-6500k and you can limit it to 2200k in preferences

Tomorrow modify driver and try it

Hello Mariano
You are the best!

Thank you very much.

Try with this driver version with 2000k-6500k profile

───────────────────────────────────────────────────
 Name         Zigbee Light Multifunction Mc
 Version      2023-10-06T09:40:56.702549737
───────────────────────────────────────────────────

Hello Mariano
What should I say… you made my day - again! (already the third time this year.)
Thank you very much!

Maybe for everybody who is curious about this topic. (Sorry Mariano if I make you feel to trash your thread, but I think the values of the voltage are super interesting)

I bought a 24V CCT LED light strip 2800K-6500K mentioned above.
I tested it with three different zigbee controllers.

  1. MiBoxer Dualwhite Zigbee Controller, model: TS0502B
  2. Iderwel RGBCCT Zigbee Led Controller, model: TS0505B

both footprints got added by Mariano this year with the profile 2000K-6500K and are working great.
And now the latest family member:

  1. Gledopto, model: GL-C-006P

The footprint got already added by Mariano several months ago but with the 2700K-6500K profile.

I noticed (again), that the strip had a way to bright/cold light (arround 4000K) when I adjusted it in the ST App to 2700K.
Mariano changed the profile to 2000K-6500K and now it does exactly what it should. It shuts the cold light LEDs off adjusting it to 2000K.

This time I also took some measurements of the voltage and pictures.
Measured at the + and th CW -
at dimmer 1% - 2000K - 4,35V
at dimmer 1% - 2055K - 7,65V (cold lights off)
at dimmer 1% - 2056K - 13.32V (cold lights turn on)
at dimmer 1% - 2200K - 13,52V (cold lights turn brighter)

Thank you again Mariano for your great support!



1 Like

Hi,

It is important to know the correct range of the hardware controller when adding it to a driver profile, this will ensure that the voltages for the cold and warm LEDs are correctly adjusted.

Of course, if we connect an LED strip that does not comply with that hardware range, then the temperatures will not be real either.

In your case if the strip is 2800k-6500k then when you send a 2000k command the strip will have 2800k

Hi @Mariano_Colmenarejo ,
I have two gl-s-006p (gu10 rgbw) using yor latest version (2023-10-06) .
Tried the 2000-6500 profile limitting to 2200 in settings, but something is not right, I must been doing something wrong?
As you can see in te pictures:




Hi @marcos.scheffler

This bulb has a range of 2000k-6500k.

The driver sends the temperature value and the bulb hardware makes the conversion to voltage for the LEDs.

If the app shows the value 2200k, it means that the light bulb has sent the response to the 2200k command received with that value as accepted and is the current measured value

With the 2700k-6500k profile did it work well?

Thank for your help @Mariano_Colmenarejo !

According to gledopto, they are supposed to be 2200-6500 (https://www.gledopto.com/h-col-402.html), but indeed, using the 2000-6500 profile it works well for the white light. With temperature set to 2000k only warm leds are on, and only the cold leds are on with 6500.
Now, just for the rgb part it seems that the color is not right when using low values for saturation. Ex.: This is supposed to be a light green:



:man_shrugging:

Edit: nevermind, the bulb I was using in-fact had no color tuning abilities.

Thank you for all your work by the way. My house has several lights enabled by this

Hi @dangitbobby

Added to this driver version as rgbw profile with 2200k to 4000k as all ikea
In preference settings you can change to other profiles with others color temperature ranges

───────────────────────────────────────────────────
 Name         Zigbee Light Multifunction Mc            
 Version      2023-10-26T19:45:21.018171898        
───────────────────────────────────────────────────
 - id: "TRADFRI bulb E26 CWS 806lm"
    deviceLabel: IKEA E26 Bulb
    manufacturer: IKEA of Sweden
    model: TRADFRI bulb E26 CWS 806lm
    deviceProfileName: rgbw-level-colortemp-2200-4000

I am trying to figure out how to set the power on defaults for a lightify recessed light. Searching this thread shows it should be possible, but I can’t find the setting.

It’s a lightify 73741 recessed light.

Device Label
OSRAM RT RGBW

Device Name
rgbw-level-colortemp-2700-6500

Device ID
ac8e2d69-d16c-4f33-a439-f6f85c9cad59