(EDGE Driver-Mc): Zigbee Drivers for Motion, Open/Close, Moisture, Smoke-Co Sensors and others Devices

Hi @xavip

These data are correct, bit 3 is tamper and bit 1 is Alarm1.

If when it does not detect anything Alarm1 is set to 1 then it is possible that your device is bad or has been blocked.

Try to reset the device and pair it again or remove the battery to see if it is restored.

This device was added quite some time ago and I have no reports of it malfunctioning

Hi @Mariano_Colmenarejo

I have a frient pro sensor , I need to use it to switch on a light if there is movement and the luminosity is less then 6/7 LUX .
I installed your drivers and Frient drivers but both behave the same: if I insert the batteries the sensor work very well for the first seconds, after that it just freeze then LUX value there after a lot of time it’s still the same, I still haven’t tested on after multiple hours but the behavior seems always the same. Do you have any idea of the reason of this? I have other sensors and it seems that everyone behave the same. I’ve tested this with AEOTEC multi sensor 6 and Fiber FGMS-001 . I’ve searched here and I saw another user with my same issue but I haven0t found an answer with the solution.

Hi @simoc

Sorry, I have no idea what causes these problems, I see several posts with problems on zigbee or zwave devices, maybe it has to do with the hub firmware update, but I don’t know.

You can try rebooting the Hub.

If you do this, let the hub stabilize, without using the devices and the app, for about 20 or 30 minutes, especially if you have many drivers and devices installed, the hub’s memory may be at its limit and it may be difficult to initialize all drivers and devices and hub do a sequencial driver init to get a free memory

Hi @Mariano_Colmenarejo

i connect this device
AVATTO Tuya Zigbee Smart Touch Switch 110-240V 1/2/3/4 Gang Light Switches Zigbee3.0 Signal Repeater work with Alexa Google Home
https://he.aliexpress.com/item/1005006170527294.html?spm=a2g0o.order_list.order_list_main.5.59b3586aMeA5UB&gatewayAdapt=glo2isr

but it is not supported @dotan_shai advice to contact you with the device info:

Model TS0003
Manufacturer _TZ3000_avky2mvc
NetworkId 0xA283
Zigbee EUI A4C138EFD6964AFB
ZCL Version 3
APP Version 82
Server Clusters 01={ 0003,0004,0005,
0006,E000,E001,0000 },
02={ 0004,0005,0006,
E001 },
03={ 0004,0005,0006,
E001 }
Client Clusters 01={ 0019,000A },
F2={ 0021 }
Test bar

can you add it to your Zigbee Multi Switch and Child Mc driver?

Ok, Thx.
I’ve tested with another unit and it’s working as the standard.

Regards,

1 Like

Can you tell me the solution to turn on/off switch2 without going into the details

@Mariano_Colmenarejo, I’m using this driver on the old (original) SmartThings multipurpose sensors since the native SmartThings Edge driver does not work with them. Everytime these contacts are opened using this driver, I’m getting multiple entries which causes the associated Alexa Routines to make multiple voice announcements about the contract being opened. Any ideas?

Update: Sorry, it isn’t your driver, it was the magnet. I replaced the associated magnet with another one and that fixed it. When I put the original magnet on another sensor, it too had same multi-notification issue. Very strange.

@Mariano_Colmenarejo, can you add the fingerprint for a Papaiz SL205 Lock to your Zigbee Lock MC driver?
Fechadura Digital SL205 (papaiz.com.br)

Papaiz is part of Assa Abloy like Yale and use by default the same Yale Connect Hub. The SL205 seems to have the same functionality of Yale YMC 420D or YMC 420W

Aded to this driver version.
Try if it works and use it under your own responsibility

Uninstall device with App
Re-install device with App and this driver version

You Do not perform a driver change from zigbee thing

───────────────────────────────────────────────────
 Name         Zigbee Lock Mc
 Version      2024-04-11T10:57:51.333570584        
───────────────────────────────────────────────────
- id: Papaiz/SL205
    deviceLabel: Papaiz SL205
    manufacturer: Papaiz # same Yale
    model: PSL200
    deviceProfileName: base-lock
1 Like

@Mariano_Colmenarejo , thank you very much.
I’ve deleted the device and added it again and the device was correctly found with your driver.
Now i can lock/unlock through the app and receive status changes when locking/unlocking through the door lock, but…

  1. i’m receiving a message that “all status for the device wasn’t loaded yet”;
  2. cannot find the"Smart Lock Guest Access" in the app, to manage the codes.

Do you have any advices how to tackle these issues?

I’ve managed to handle the “status not loaded” message. Removed the device, rebooted the hub and factory reset the door lock before readding the device. Battery status is correct now in the app and don’t get the message anymore.

Now, still not get how to manage lock codes. :thinking:

Any hint from anyone??

This should help as long as you’re able to access it from your location. It’s limited to the US and Canada.

Smart Lock Guest Access (SLGA)

After searching a lot i found that “Smart Lock Guest Access” is not available to me because i´m located in Brazil (it´s a US and Canada service only).
So, i´m trying to find an alternative to this.

@Mariano_Colmenarejo
I successfully added a code through the AWA interface using the “setCode” command and the new code worked to unlock the door, but i see that “scanCodes” attribute still show “Scanning” and “lockCodes” is empty. Do you have any clue why scanCodes is not in “complete” state and the code added is not shownd in the lockCodes attribute?



Unfortunately i cannot use Smart Lock Access because i´m located in Brazil.
Wondering if i can create a US region Samsung account and start over my configuration in this account to use this service, even with the HUB installed in Brazil?

That seems like more trouble than it’s worth.

Maybe one of RBoy’s drivers could solve the problem? Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

Rboy driver is for z-wave locks. Mine is zigbee

1 Like

I have no idea how the lock codes work.

It may also have to do with the chache nabejo error and the values appearing after a while, but I don’t know

@Mariano_Colmenarejo ,
I started to read the developer documentations about Edge drivers and getting used on “how things work” (want to start adventure myself in the world of writing Custom Device Drivers and SmartApps/Services in a near future, if i could find some spare time).

You have said that your “Zigbee Lock MC” driver is just a pure copy of the default SmartThings “Zigbee Lock” driver, right?

Also, i can assume that you have only added the fingerprint for my lock to the fingerprints.yml file, right?

So, i was looking in the default driver source code (zigbee-lock/src/init.lua) and noted that they are using Yale specific sub driver to handle codes reload and other things. This sub driver is not loaded for my lock because the manufacturer doesn’t match with the conditions in his src/yale/init.lua:

can_handle = function(opts, driver, device, …)
return device:get_manufacturer() == “ASSA ABLOY iRevo” or device:get_manufacturer() == “Yale”
end

Can you change your device driver or create a new copy (if you think it’s better) modifying the can_handle function of the yale sub driver to this code:

can_handle = function(opts, driver, device, …)
return device:get_manufacturer() == “ASSA ABLOY iRevo” or device:get_manufacturer() == “Yale” or (device:get_manufacturer() == “Papaiz” and device:get_model() == “PSL200”)
end

Thanks in advance

also, could you check if you have the most recent changes made by Samsung in your drive?

No, they are added to the fingerprint.yml with base-lock profile and to the yale subdriver, normally that is enough, but your lock may not be exactly the same as the yale ones

You can add them yourself to the stock smartthings driver Code and create your own driver

1 Like