(EDGE Driver-Mc): Z-Wave Sensor and Child Thermostat Mc

What device, fingerprints is it?
Do you have installed the Zigbee Temp Sensor with Thermostat Mc driver in your Hub?


I’ve got these installed on my hub (assume done correctly)?


At the very least it should show you the Zigbee Thing Mc as compatible driver to change.

I would try to reboot the Hub or turn it off and on, without battery if is a hub v2.

I understood that you were going to use a smartthings multipurpose sensor, not a motion sensor

Alas nothing,I will try a reboot
I’ve found the multi purpose sensor too now so will try that too


Got it working with the multi sensor - how do I assign it to a smart socket to drive the heater?



Sorted… Added routines to check the β€œFan Current State” and switch the heater on/off


You can use also:

  • Thermostat operatingState = β€œPending Heat” or Thermostat Mode = β€œOff” then Turn Off the switch heater
  • Thermostat operatingState = β€œHeating” then Turn On the switch heater

Excellent, working on ActionTiles now too :smiley:

1 Like

Hello everybody.
I am very new to everything related to Smartthings, and I came accross this conversation while trying to do the exact same thing that is described in here. However, I am having some trouble trying to find information on how I could exactly make use of this edge driver.
I am trying to control a switch that turns on and off my boiler with an external SwitchBot temperature sensor. I see this works for Z-Wave devices, but I was wondering if it would be possible to make it work with mine.
Also, I would like to ask if anybody has a guide on how to install and make use of an edge driver like this one, as I am getting a bit lost with everything.
Please let me know as well if I am not using the proper forum for this!
Thank you very much.

Hi @DaniDieMa

For those devices I don’t know of any driver that has the Virtual Thermostat function.

With this sensor you can create routines in the App that activate and deactivate a switch depending on whether the temperature is <= or >= a value and bounded by periods of time.
They are more complicated to perform reliably than with a virtual thermostat.

There are 3 drivers that have the Virtual Thermostat function:

  • For zigbee devices (temp and humidity, open/close, motion) that have temperature capability:
    Zigbee Temp Sensor with Thermostat Mc
    Device fingerprint link

  • For zigbee devices Temperature and humidity sensors:
    Zigbee Temp Sensor and Child Thermostat Mc
    Device fingerprint link

  • For zwave devices ( temp and humidity, open/close, motion) that have temperature capability:
    Z-Wave Sensor and Child Thermostat Mc
    Device fingerprint link

Drivers named β€œChild Thermostat” create a virtual thermostat independent of the device temperature sensor.

  • To use them you must have a device compatible with one of these drivers fingerprints. .

  • Install the driver of your choice from the shared channel on your hub

  • Add the device with the App to pair it with the edge driver.

  • Carry out the thermostat adjustments and the routines to execute the actions in the heating.

New version for Z-Wave Sensor and Child Thermostat Mc:

To improve performance, reducing use of hub resources and executing any changes faster:

  • The fixed timer of 20 sec for the calculations of the thermostat functions and the one of 300 sec to obtain the temperature of the parent sensor has been eliminated.

  • A subdriver has been created to manually manage the c.c. sensorMultilevel- sensor_type=TEMPERATURE of all the sensors of the driver and to be able to update the temperature of the child sensor every time the parent sensor sends a new temperature value.
    Thanks to @nayelyz and the smartthing team, for helping me find out how to create a can_handle function to execute the subdriver for all sensors in the driver and only when it receives a sensorMultilevel-sensor_type=TEMPERATURE command.

  • This allows the thermostat calculation routine to only be executed when there is a change or a refresh, saving hub resources and with an immediate response to any change in temperature or settings.

  • It has been tested on an Aeotec Trisensor by @nayelyz and Aeotec6 from another user, thanks too

  • For zigbee virtual thermostats, Zigbee Temp Sensor and Child Thermostat Mc and Zigbee Temp Sensor with Thermostat Mc it has been updated and working for more than a week without any problem since in zigbee it is much easier to control the temperature reports of all devices in a single function handler.

  • The update to new version will be done automatically within a maximum period of 12 hours or manually with the CLI

 Name         Z-Wave Sensor and Child Thermostat Mc 
 Version      2022-12-23T16:30:30.720700514

Merry Christmas to all :christmas_tree: :fireworks: :confetti_ball: :gift:


@Mariano_Colmenarejo, this update does seem to make any thermostat changes take effect almost immediately.

@Mariano_Colmenarejo, i have a minor suggestion.

I think it would be clearer if the label Thermostat Locked were to read Thermostat Lock.

What it should show is the label that I defined in the presentation of the capability.

"detailView": [
            "label": "Thermostat Lock State",

In an App update they broke this and what shows now is the capability name.
On some it was fixed in another App update and on other identically defined capabilities it bafflingly doesn’t work.
I refuse to redo all the presentations and vid that don’t work.

If one day I’m bored I’ll do it, but to add the Spanish translation.

1 Like

I’m glad! That was one of the objectives.
The other and just as important is to consume less resources from the hub and the network.
Thanks for your comments about this in previous posts, which made me think of another way to execute the code.

1 Like

Hi everyone. @Mariano_Colmenarejo thanks again for the useful driver. I’ve been using it with my Aeotec multisensor 6 for several weeks now. The only issue I have is that the temperature of the sensor, and thus of the thermostat, is updated once every 50-60 minutes. Tried changing the value of the β€œreport interval” setting, which seems to have no effect at all on the actual interval of updating the temperature. Note, the motion sensor responds immediately. Is this a known issue and is there a solution for that?

P.S. Merry Christmas! Hope you’re having a great Christmas weekend.

Hi @Armen_Saghatelian

Thanks, I wish You Merry Christmas too

Could you send me a screenshot of the last hour temperature history of the sensor and a snapshot of the temperature graph of the app?
like this

Sure + settings page just in case

Hi @Armen_Saghatelian

According to the aeotec6 manual, the reporting interval only takes effect when it is connected to the external power supply.
When it is running on battery the minimum interval is 60 minutes.

The minimum interval could be set to 4 minutes if the wake Up value is set to 240 sec.
This setting is not available in the profile, this would cause the batteries to run out sooner

You can try to see if connecting it to the external power supply reports what you have set, by default it is 480 sec (8 min)

Parameter: 111 (0x6F) The interval time of sending reports in Report group 1 (Valid values 0x05-

  1. The unit of interval time is second if USB power.
  2. If battery power, the minimum interval time is 60 minutes by default, for
    example, if the value is set to be more than 5 and less than 3600, the interval
    time is 60 minutes, if the value is set to be more than 3600 and less than 7200,
    the interval time is 120 minutes. You can also change the minimum interval time
    to 4 minutes via setting the interval value(3 bytes) to 240 in Wake Up Interval Set
    default value : 3600 (seconds), byte 4
1 Like

Thank you @Mariano_Colmenarejo for the useful info. I plugged it to the power supply and it immediately started reporting every minute. Interesting limitation of the device. I didn’t think of that, as there are other devices on battery, e.g. the Smartthins original multi sensor, that reports every ~10 minutes and doesn’t drain the batteries too quickly.
Anyways, thank you again for your help.