(EDGE Driver-Mc): Z-Wave Sensor and Child Thermostat Mc

@Mariano_Colmenarejo, I don’t see where your routine turns off the heater when the thermostat state is idle.

@Mariano_Colmenarejo, I have a different problem which has been happening since the beginning. Humidity is not being displayed from my multisensor. Should it be?

@Mariano_Colmenarejo, I have another request.

I own 2 Oomi Multisensors from fantem.com, which are basically Aeotec Multisensor 6’s. When I try to delete one and readd it to SmartThings – so that it picks up the Aeotec edge driver – it gets readded with the DTH. I suppose that’s because it’s reporting with a different mfgr code.

Here’s its string:

zw:L type:2101 mfr:016A prod:0102 model:0064 ver:1.06 zwv:4.05 lib:03 cc:5E,86,72,59,85,73,71,84,80,30,31,70,7A,5A`

Here’s a real Aeotec’s string:

zw:L type:2101 mfr:0086 prod:0102 model:0064 ver:1.10 zwv:4.54 lib:03 cc:5E,86,72,59,85,73,71,84,80,30,31,70,7A,5A

I’d like to use your driver for this device. Is this something that you can add to your driver so that it’ll be discovered?


The humidity is not shown, it is an error of the first version. If you clear the app cache it should go away.

In the future, if everything works well, I may implement the profile with humidity for the devices that support it.

Added as Aeotec multisensor 6 in this driver version. Try it

 Name         Z-Wave Sensor and Child Thermostat Mc 
 Version      2022-11-14T09:29:29.053444128
  - id: "016A/0102/0064"
    deviceLabel: Oomi Multipurpose Sensor
    manufacturerId: 0x016A
    productType: 0x0102
    productId: 0x0064
    deviceProfileName: aeotec-multisensor-6
1 Like

That caused it to be discovered.

If I’m having trouble with functionality of one or more of the sensor’s capabilities, would I ask on the z-wave sensor thread and get them to fix it there? For instance, motion detection is not working probably because one of the sensor’s many settings is not exposed for me to set in the device in the app.

Update: Never mind. I found another of your excellent edge drivers that allows me to set z-wave settings not exposed by the usual drivers.

It did not.

Hi @BartschLabs

Then I will modify the driver.
sorry, I forgot to add the fingerprints to send the initial configuration and the two preferences parameters of profile. :man_facepalming:
That may have caused it to not work well, although it should have kept the configuration it had with the DTH.

Update: Initial Configuration and preferences fixed in this version

 Name         Z-Wave Sensor and Child Thermostat Mc 
 Version      2022-11-15T09:47:25.441726399
1 Like

I have a Nortek/GoControl contact sensor that seems to work with your Z-Wave Sensor MC, but when it changes to Open state, it never changes back to Closed. I can see in the app a momentary blip when it’s closed, but it remains open. Any thoughts?

zw:S type:2001 mfr:014F prod:2001 model:0102 ver:4.84 zwv:3.67 lib:06 cc:71,85,80,72,30,86,84

Hi @Expose

This device is in smartthings stock beta driver Z-Wave Sensor
My driver for this device is the same as stock driver.
Please try if works fine with Smartthing stock Beta driver Z-Wave Sensor
If not works fine then need to report to @nayelyz to fix prior of the final migration

  - id: 014F/2001/0102
    deviceLabel: Nortek Open/Closed Sensor
    manufacturerId: 0x014F
    productType: 0x2001
    productId: 0x0102
    deviceProfileName: contact-battery-tamperalert

@Mariano_Colmenarejo, I see that there are now 37 thermostat modes that I can choose from, instead of a handful of modes.

Recently, if I ask Alexa to set the thermostat to heat, Alexa asks, “What do you mean by heat?” I try different responses, and eventually Alexa asks, “Can you tell me the exact value?”

If I ask Alexa to set the thermostat to auto, cool, or off, the thermostat mode gets set correctly.

Do you think all the new thermostat modes has anything to do with this?

Hi @BartschLabs

Of all the modes available in the capability thermostatMode, the driver has these 9 supported modes configured.
This is what you have to see in view of details, automations conditions and actions.(in englihs)

The modes that smartthings exposes to alexa I don’t know.

In fact the modes you see on my.smartthings.com are only the modes of the stock presentation.

The good news is that I figured out the “Alexa, set ___ thermostat to heat” problem. “Heating” is now the word to use. Alexa still responds, “It’s set to heat,” even though “heating” is the new verbal command.

The not so good news is that this is what I see in the thermostat child device for modes.

Hi @BartschLabs

 Name         Z-Wave Sensor and Child Thermostat Mc
 Version      2022-11-22T18:10:13.772097618

It seems that the supported modes have not been configured correctly, I have modified the version to force the configuration of modes in the initialization.

You should see this in the logs when the driver is installed.

2022-11-22T18:08:06.420411251+00:00 PRINT Zigbee Temp Sensor and Child Thermostat Mc  << thermostat_Modes_Supported >>
2022-11-22T18:08:06.427285251+00:00 INFO Zigbee Temp Sensor and Child Thermostat Mc  <Device: 032e488a-9694-435f-a9f8-e101d3e2b90c (Thermostat-Environment Sensor)> emitting event: {"attribute_id":"supportedThermostatModes","capability_id":"thermostatMode","component_id":"main","state":{"value":["off","auto","eco","asleep","heat","cool","rush hour","away","manual"]}}

Prior to forcing an update of the driver, I solved the problem by deleting and recreating the thermostat device.

I’m still on this version of the driver:

1 Like

@Mariano_Colmenarejo, what do you think about making the default thermostat name be “sensor name Thermostat” instead of “Thermostat-sensor name”?

This is the initial label for device create.
You can change the name as you want in app edit device

In CLI logs the new name assigned to device will appears some time after

Yes, I do realize that. I was hoping you could change the default to save me some time every time I have to recreate the device. :slight_smile:

I think that anybody using this driver with voice control of the thermostat device would prefer the name to be more natural (at least in English), with “thermostat” at the end.

@Mariano_Colmenarejo, I have two problems with the sensor device that I haven’t yet mentioned because I first wanted to get the thermostat functioning correctly.

  1. The motion timeout is 60 minutes, not matter what I set the Delay Time to be in Settings. I’ve tried changing to the Aeotec Multisensor 6 driver and to your Z-Wave Config driver to change the setting and then changing back to this driver, but I can never make the setting stick.

  2. The Power Source pane is always blank. It should say USB.

This part of the code is exactly the same as the stock driver.
If the stock doesn’t work, this one won’t work either.
I see capability powerSource is not declared in driver template.
I can put some debug log and see some log that you send by removing and turning on the power to see what the device is sending.

I assume you mean 60 seconds instead of 60 minutes.

This part is also identical to the stock driver and will not work on the stock driver either.

  • I have seen that the initial configuration that it sends to the device is 20 sec, which is the default value in preferences.
  • I have also seen that the code has an error, both the stock and mine, which is a copy. Incorrectly sends values of the initial configuration.
  • The changes in preferences send them well, but the device may be asleep and you have to wake up device when you send the preference change.

I have made a version correcting the error in sending the configuration and I am going to force it to be configured when installing the new version, which by default only does it when the device driver is paired

Please, Install this driver version ans attempt to capture the logs.
I will see tomorrow, i am going to sleep :zzz:

 Driver Id    b88307ad-ed36-42fb-81b0-c9875e1bd25f  
 Name         Z-Wave Sensor and Child Thermostat Mc 
 Version      2022-11-22T22:34:07.813809801