(EDGE Driver-Mc): Z-wave Remotec ZRC-90 Scene Master and Namron Button Remote Mc

Great! Here is the link to Z-wave database: https://products.z-wavealliance.org/products/3911

Hi @Magnus1 @teo78

Added to this driver version, 2Kanal an 1Kanal buttons. The 4Kanal already existed in driver
I hope the fingerprints are correct as there is a discrepancy between the manual and zwave alliance

───────────────────────────────────────────────────
 Name         Z-Wave Button Mc
 Version      2023-01-30T15:56:18.094875445
───────────────────────────────────────────────────
- id: Namron/4kanal
    deviceLabel: Namron 4kanal
    manufacturerId: 0x0438
    productType: 0x0300
    productId: 0xA305
    deviceProfileName: multi-button-8
- id: Namron/2kanal
    deviceLabel: Namron 2kanal
    manufacturerId: 0x0438
    productType: 0x0300
    productId: 0xA306
    deviceProfileName: multi-button-4
- id: Namron/1kanal
    deviceLabel: Namron 1kanal
    manufacturerId: 0x0438
    productType: 0x0300
    productId: 0xA30F
    deviceProfileName: multi-button-2
2 Likes

UK, yet another variant?

zw:S type:0106 mfr:5254 prod:0001 model:8510 ver:1.01 zwv:4.05 lib:02 cc:5E,85,72,21,84,86,80,73,59,5A,5B ccOut:84,5B

Currently pairing as a default “Z-wave remote”

EDIT: It’s help if I’d added the right Edge driver. Added successfully after spotting my mistake. Thanks

1 Like

Hello Marty,

I have the same problem you had. My device shows the exact same data than yours (zw:S type:0106 mfr:0000 model:0000 ver:3.03 zwv:6.09 lib:02). I also tried @Mariano_Colmenarejo recommendation of using the Zwave Thing Mc, reseting the zrc-90 and pairing closer to the hub and no luck, still getting 0000 on model, mfr, and prod.

Did you ever find a solution for this issue?

Thanks

I’m having the same problem. When I include the ZRC-90 device, it comes up as Z-WAVE REMOTE. SmartThings doesn’t add the Z-Wave Button MC edge driver to it. Not sure how you can force the edge driver to a device. I just get Edit and Information when I click on the three dots in the upper right corner.

2 posts were split to a new topic: Edge drivers for Namron Zigbee remotes?

Hi @Magnus1 ! Did you get your device (Namron 4 kanal) to work with Mariano’s updated driver?

Hello @Mariano_Colmenarejo I have a brand new ZRC-90 but its defaulting to SmartThings drivers Zwave Switch and Zwave Extender. Then I tried your Thing driver but didn’t work. Zwave Device Config TEST only works and attached is the screenshot. Yours - Zwave Button Mc I have installed but doesn’t even appear as an option to select.

I believe the fingerprint is: 79d41cb6-c45d-4b9b-b98f-75df54379980

Also I see the following at: Link to fingerprints:

  • id: Ramotec/zrc-90 ### I think the spelling is wrong?
    deviceLabel: Remotec ZRC-90
    manufacturerId: 0x5254
    productId: 0x8510
    deviceProfileName: multi-button-8

Hi @baivab

The device is not well paired, it shows 0000 on the fingerprints.

Excludes and re-includes it near the hub.

sometimes it’s a bit complicated

Yeah. I guess so.

Can you correct the typo I suggested above? BTW: thank you for the great work.

However if you scroll above you will see another user faced the same problem. So you had suggested the same (as you did above, to me). Already.

I tried to reset the device (+10 sec R and then 3 rapid clicks) and again pair to hub. For pairing L button clicked once does it. The other combination L+R does not pair. Documentation suggests the same too.

Obviously I was in Z wave exclude mode at hub.

This is totally transparent and superfluous for the user. the important thing is the fingerprints.

I didn’t change it at the time in case it affected devices already paired with the old id.

Thank you.

It finally worked. Here’s what I did.

Paired remote as your Thing Mc driver.
Hub - in Zwave exclude mode.
Hub could not delete it. Force delete also went on and on.
However, when I logged from the web portal showed removed.

This reset everything to default as per documentation.

Then I reset the device, 3 times by long pressing the R button +10 seconds and 3 rapid clicks each time. .
I removed the batteries for +30 seconds.
Put everything back together.

This moved the device into “service mode” and effectively hoped it would have deployed any firm wire missing which is in there but not deployed? Bad quality checks, perhaps?

Moved the slider in the device to PC position.
Removed batteries again. For +30 seconds.
Put it back and let it sit for +30 seconds and moved the slider back to default.

Reverted to original state.

Removed batteries again. For +30 seconds.
Put it back and let it sit for +30 seconds

Tried now to pair by pressing the L button once and having the hub in Pair mode by scanning for nearby…
Boom: Worked. :grinning: :smiley: :yum: :stuck_out_tongue:

QQ: What’s the “Main” button in your app? I think I can ignore that. Basically buttons [1…8] is what can be used.

1 Like

The main button of the buttons, is something that has included smartthings by default in all the multibuttons.

it is activated with the same action that is executed in any other button

can be ignored or used to detect if any button is activated

Thank you Mariano this worked great for me, after my remote stopped working with ST hub this week.

2 Likes

Hi @Mariano_Colmenarejo,
My Namron 1kanal show up as Z-wave switch when adding it to Smartthings. I have enrolled your channel and installed the z-wave button mc driver, but I’m not able to assign your driver to it. Any ideas?

Below device information from the advanced web app:

I noticed the manufacturer Id is different; 0x0330 compared to 0x0438 in your driver. Could this be an issue?

Hi @Hans_Matthiasen

I take note to add it in August

1 Like

Awesome! Thanks a lot!

Hi @Hans_Matthiasen

Added to this driver version

───────────────────────────────────────────────────
 Name         Z-Wave Button Mc
 Version      2023-07-31T21:03:53.004349953        
───────────────────────────────────────────────────
- id: Namron/1kanal/0330
    deviceLabel: Namron 1kanal
    manufacturerId: 0x0330
    productType: 0x0300
    productId: 0xA30F
    deviceProfileName: multi-button-2
2 Likes

Hi, @Mariano_Colmenarejo

I tried the updated driver for my Namron 1Kanal button, but it will not be accepted. I noticed that in ST, my device shows up with this manufacturer code: 0330-0300-A310.

Looks like it has a different productId than the one you just added. Any chance to add this?