(EDGE Driver-Mc): Z-wave Remotec ZRC-90 Scene Master and Namron Button Remote Mc

I do have it installed and subscribed to your site. I have it in before I try to pair

It appears that it is picking up the generic driver and not “Z-Wave Button Mc” driver. That is why I thought it was a Fingerprint issue.

Oops I see you want me to use Z-Wave Thing Mc. I will remove Z Wave Button Mc and replace

Nope still uses the generic Z Wave driver. It will not pair with either Z-Wave Button Mc or Z-Wave Thing Mc. I reset the Hub as well as factory settings on the ZRC 90. Grrrgh

Sorry, I do no konow wath is happen with your device

Where can I find the list of fingerprints this driver supports? Have a few GoControl WA00Z-1 switches I haven’t got covered for the end of Groovy.

1 Like

This is the link to Zwave Button Mc fingerprints


6 posts were split to a new topic: GoControl WA00Z-1 Edge Driver?

I just added this device with the Edge device handler. The ZRC-90 shows in my app and all the buttons are listed and I have manage to program a button. However, I get a message that reads “This device hasn’t updated all of its status information yet. Check again later”. The device shows in Standby mode and the buttons do not seem to do anything. Any help?

The ZRC-90 is working great, it just a very long time (a few hours) to update the status. Sorry for jumping the gun.


I got my 4-channel (8 button) Namron switch to work with Z-Wave Button MC Thanks @Mariano_Colmenarejo!

However the 2-channel (4 button) did not work. They are being added as “Z-Wave devices”. Any clue why @Mariano_Colmenarejo?

Hi @Magnus1

Because I only added the 8-button device to driver for two users who requested it, but they have not said anything if they have tried it or not.


Make sense. Any chance to add the 4-button device to to driver as well @Mariano_Colmenarejo?

Hi @Magnus1

If you provide me with a link to the documentation and fingerprints, I’ll look at it.

1 Like

Great, works fine, many thanks :slight_smile:

Regarding the 4 button device, I don’t have that myself yet, but this is the manual: https://www.elektroimportoren.no/docs/lib/4512720-Brukerveiledning-5.pdf
Appears to be exactly the same, just with fewer buttons.
However I suspect the “Product Type ID” in the manual is wrong (or they have multiple). Since for the 8 button device I have, the manual lists it as 0x0003, but it actually is 0x0300.

1 Like

Great! Here is the link to Z-wave database: https://products.z-wavealliance.org/products/3911

Hi @Magnus1 @teo78

Added to this driver version, 2Kanal an 1Kanal buttons. The 4Kanal already existed in driver
I hope the fingerprints are correct as there is a discrepancy between the manual and zwave alliance

 Name         Z-Wave Button Mc
 Version      2023-01-30T15:56:18.094875445
- id: Namron/4kanal
    deviceLabel: Namron 4kanal
    manufacturerId: 0x0438
    productType: 0x0300
    productId: 0xA305
    deviceProfileName: multi-button-8
- id: Namron/2kanal
    deviceLabel: Namron 2kanal
    manufacturerId: 0x0438
    productType: 0x0300
    productId: 0xA306
    deviceProfileName: multi-button-4
- id: Namron/1kanal
    deviceLabel: Namron 1kanal
    manufacturerId: 0x0438
    productType: 0x0300
    productId: 0xA30F
    deviceProfileName: multi-button-2

UK, yet another variant?

zw:S type:0106 mfr:5254 prod:0001 model:8510 ver:1.01 zwv:4.05 lib:02 cc:5E,85,72,21,84,86,80,73,59,5A,5B ccOut:84,5B

Currently pairing as a default “Z-wave remote”

EDIT: It’s help if I’d added the right Edge driver. Added successfully after spotting my mistake. Thanks

1 Like

Hello Marty,

I have the same problem you had. My device shows the exact same data than yours (zw:S type:0106 mfr:0000 model:0000 ver:3.03 zwv:6.09 lib:02). I also tried @Mariano_Colmenarejo recommendation of using the Zwave Thing Mc, reseting the zrc-90 and pairing closer to the hub and no luck, still getting 0000 on model, mfr, and prod.

Did you ever find a solution for this issue?


I’m having the same problem. When I include the ZRC-90 device, it comes up as Z-WAVE REMOTE. SmartThings doesn’t add the Z-Wave Button MC edge driver to it. Not sure how you can force the edge driver to a device. I just get Edit and Information when I click on the three dots in the upper right corner.

2 posts were split to a new topic: Edge drivers for Namron Zigbee remotes?

Hi @Magnus1 ! Did you get your device (Namron 4 kanal) to work with Mariano’s updated driver?