(EDGE Driver-Mc): Z-Wave Edge Drivers and others with FIBARO devices:

Hi @GiacomoF,
This one is among the half-done in the stock beta Z-Wave Sensor.

They’ll post it soon I think!

1 Like

The Fibaro Single Dimmer seems to be working much better now. S2 is working perfectly and being able to distinguish between on/off with pressed/held for a physical toggle switch means I can very easily set up a local automation to control other non-load devices from this toggle switch. This is really, really good.

I have noticed for S1 that there is no setting to synchronise with the physical switch. The Fibaro’s have parameter 22 to control this. This would mean, for a single physical switch installation that down is always on and up is always off, instead of acting like a 2-way switch with the Fibaro being the ‘hidden’ 2nd one. (Of course, this means if the physical switch is down and the lights are off, then toggling it up would mean they’d stay off and then would only come on if toggled down).

Would it be possible for you to expose this in your driver, rather than having to use a Z-Wave tweaker?

Otherwise, I don’t know what’s changed since the last time I tried this a few weeks ago with the same dimmer, but it’s so much better now. Reliable, working correctly from what I can tell and the S2 is great!

Oh, and whether this is a driver thing or a ST thing, it seems this works properly when both buttons are toggled together or very similar times. This didn’t work very well with the DTH + scene control + WebCore (it was quite unreliable anyway, but especially if both buttons were pushed together).


Yes, I added 2 buttons to be able to execute with automations and scenes the actions sent by S1 (Button1) and S2 (Button2) when activating parameter 28, sending scenes, according to the table in the manual.

the only thing that didn’t work well is that S2, by default also controls the load connected to S1 and it shouldn’t. I already reported it to @nayelyz

I have added parameter 22 for the option to synchronize the device state with the mechanical switch.

The changes are in this version

│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-03-06T10:45:23.484229           │

Hmm, I’m no longer seeing the issue of S2 controlling the attached load.

Mine is working correctly with:

Switch type: Toggle
Double click: activated
Function of 3-way: disabled for S2
Scene Activation: Activated
On-Off mode disabled

I’ve just updated the driver to the 2022-03-06 version and set parameter 22 to sync. This works.

The only thing I’ve noticed is occasionally the device in app shows the dimmer as 1% when off but rises to 100% when on. This is on-screen only, not what is physically observed. It’s not consistent.

Otherwise, this driver is now working very well for my Fibaro Dimmer 2 (‎FGD-212) with a double physical toggle switch, S1 controlling the local load (only) and S2 controlling the scene activation via ST (only).


1 Like

Fibaro dimmer2, Fixed a bug in buttons actions assignments for scenes S1 and S2 being swapped.

  • button1 for scene values (S1) 10 and 11
  • button 2 for scene values (S2) 20 and 21

values 10 and 20 (OFF to ON), correct action now: Pressed
values 11 and 21 (ON to OFF), correct action now: Held (Relesed)

│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-03-08T16:21:50.425239           │
1 Like

Thanks, I hadn’t noticed this but I will check my rules.

I have been asked privately by another person about my settings for my Fibaro devices. I’ve copied the reply here in case it helps others and it is relevant to this thread.

I am seeing different behaviour between the Fibaro Dimmer and the Fibaro Single Switch. This is the same with both the stock Edge Z-Wave Switch (2022-02-23) and @Mariano_Colmenarejo’s version (2022-03-06T18:26:15). I generally use Mariano’s drivers because they are more complete and better.

The Dimmer is ‎FGD-212. The Single Switch is ‎FGS-213.

The IDE does not show the details of software versions for these as I’m using Edge drivers. It just shows a placeholder. I do have the Smartthings CLI but I can’t see a way of grabbing the device model/software version info in this way. It’s not exposed in the live logs either.

The dimmer is on a standard double toggle switch. My whole house was re-wired 3 years ago and I have 3-wire with the live presented at the wall switch. This means the modules are all behind the switches, not in the ceiling (there’s no permanent live in the ceiling, only switched).

I connected the toggle switch COM to Sx on the module. I’ve bridged COM between switch 1 and 2 on the rear of the physical switch. From the left switch, L1 goes to S1, and on the right switch, L1 goes to S2.

With the Dimmer, S1 controls the local load. S2 does not control the local load at all. There is scene activation set. However, with @Mariano_Colmenarejo’s driver, it shows as a button state. This means I can use a routine to control other devices (Ikea Zigbee bulbs in my case (using Edge drivers FWIW)) via the hub. Pushed = off, Held = on.

With the Single switch (non dimming), it’s pretty much the same, but I have noticed that while S1 and S2 controlled physically, operate as expected. S1 controls the local load and S2 controls the scene. However, in both the stock and @Mariano_Colmenarejo’s drivers I have noticed a ‘bug’ (not reported) which shows the device in the app itself is switched on/off when S2 is toggled, although the actual local load is not turned on/off. So it’s a visual bug. For me, it’s not a big problem as my specific usage for this switch is quite basic and this doesn’t cause me an issue - but the bug will annoy me if it’s not fixed. I think this is a ST thing, not Mariano.

Finally, I also have a Fibaro Double Switch. This is more of a problem because ST have decided that child switches are not presented as separate devices in the app. There’s separate comments about this, here: [ST Edge] Issues with multi-component devices and third-party integrations - #9 by lewisburgess

Some screenshots from both the Fibaro Dimmer:

Screenshots from the Fibaro Single switch:


I’ve updated to this version in the CLI and checked my routines on my Fibaro Dimmer (see my previous post above) and I haven’t noticed any difference in behaviour.

Down = on = Held
Up = off = Pressed

I didn’t have to change anything for some reason.

The driver version with changes is this.

In the screenshots the version is 2022-03-06

You can see what the dimmer sends by viewing the button in the app and pressing s2

May also have to see parameter 22 value.
The dimmer is supposed, send the value 20 when it goes from Off to On and 21 when S2 goes from On to Off.

Now for the value 20 it sends Pressed and for 21 it sends Held

In the fibaro single and double switches I do not modify any. The code Is same of stock driver

The screenshots were taken before the update and testing.

I’ll test some more, but it seems to be ok.

1 Like

@Mariano_Colmenarejo you were right. I did have to swap pressed and held around on my routines. :+1::blush:

1 Like


I made some changes in the dimmer2 subdriver to solve the problem that some users still have with S2, which controls the load of S1 in addition to send the scenes.

It seems that it works well now, I hope it continues to work well for you too

driver version

│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-03-09T19:03:00.486914           │
1 Like

Hi @Mariano_Colmenarejo first of all thank you very much for your great job!!
could you please added the Fibaro Flood Sensor?
This is the fingerprint zw:S type:0000 mfr:0000 prod:0000 model:0000 ver:0.00 zwv:0.00 lib:00
Thanks again

1 Like

One Smartthings Italian user modified the DH inserting more number of % check during the shutter movement, because in the original DH there is only one check after 10 seconds and the % will remain stuck or not accurately updated. Second fix he made is a percentage check when the shutter has been opened with the phisical button, often the percentage was not accurate.

this device Will be in stock driver, i think, in smartthings Next update

# - id: "fibaro/flood/zw5"
  #   deviceLabel: Fibaro Flood Sensor ZW5
  #   manufacturerId: 0x010F
  #   productType: 0x0B01
  #   deviceProfileName: water-battery-tamper-temperature

Thanks @Mariano_Colmenarejo could you please link the official repository? because I didn’t found it or maybe I’m searching something wrong. Thanks

I had to change the routine to use (the new) “Button 2” instead of “Button 1” (which was previously the only button present and only applied to S2 for me).

Otherwise, it seems to be OK on my dimmer.

I’ve not tried my Fibaro Single Switch yet - have been getting odd behaviour on this with both your driver and the stock one. I described this earlier, but not tried your driver from yesterday on it this morning.

Thanks :slight_smile:

Channel link

smartthings edge driver github link

1 Like

@Mariano_Colmenarejo - not sure if you could have a look at the behaviour for the Fibaro Single Switch 2 ‎FGS-213.

For S2, I’m seeing the following behaviour:

Toggle switch state changed
“Button pushed” shows on device in app, in either direction (requires modification to pushed/held)
Power On / Off toggled in app (incorrect)
DOES NOT control the local load (correct)
Routine for “Button pushed” works. (correct)

If the S1 load is physically on
Physical S2 toggle does not change state of load (correct)
Does change power state in app (incorrect)

This is in-line with the “Toggle switch synced with switch status”, so if S1 is on & S2 is off, then S2 toggle switch is changed to on the power indicator stays on. If S1 is on & S2 is on & the toggle switch is changed to off, the power indicator will go off. (The actual load output does not change).

If the power button is pushed for the device in-app, this controls the local load (correct) and changes the power state (correct). It does not activate the S2 scene/button (correct).

In the app’s device history, the Button press & Power state is logged as per the above. The power meter will only log if the actual output load changes (due to the S1 toggle switch or in-app power change).

Hope that all makes sense.

I don’t know if this a SmartThings thing or not, because I’ve seen the same behaviour in the stock Z-Wave Switch as well as your versions.

Let me know if you want some CLI logs.

Thanks. :slight_smile:

I think you should open a report or post on edge beta known issues, since it’s a stock driver issue and they should fix it.

I have not modified anything in the driver for the fibaro single switch

I get the impression that this is something from the default libraries, which affects more devices, in fact the Aeotec nano doesn’t work well for you either, right?

OK, I will do that.

The Aeotec Nano is terrible for me.

But the Fibaro is much more stable.