(EDGE Driver-Mc): Fibaro Smart Implant Mc

Hi,

This driver version has new VID’s for child thermostat with temperature range -100 to 250

───────────────────────────────────────────────────
 Name         Fibaro Smart Implant Mc
 Version      2023-10-18T16:22:44.113403768        
───────────────────────────────────────────────────
1 Like

Yupp, it works for the (Child) thermostats as well, now! Thank you very much!

1 Like

@S.F.B @TapioX

When making these modifications I realized that I had not updated the thermostat subdriver with the same adjustment functions that the Zigbee Temp Sensor and Child Thermostat Mc and Z-Wave Sensor and Child Thermostat Mc drivers have.

This version already has the virtual thermostat subdriver updated.
Review the preferences to adjust their operation in the best way.

This is the link to the thermostat Manual Thermostat.pdf

───────────────────────────────────────────────────
 Name         Fibaro Smart Implant Mc
 Version      2023-10-19T09:44:34.999292835        
───────────────────────────────────────────────────
1 Like

Your drivers are better than the stock ones. Thank you Mariano.

I am using a smart implant to monitor the temperature of my freezers, to know if they are off for any reason. I’ve got the DS18B20 temp probe, works great.

Now, I am testing this using a 9vDC wall supply, but I’d like to make this into a portable package that uses 3x 18650s.

Doing this, I can run them in serial to get about 12-14 volts, but I cant read in the voltage to INPUT 1…

UNLESS, I have the 12-14V from the 18650s run through a voltage regulator chip down to 9v, then I can power the device, AND read out the voltage on the smart things app. (To alert me if the battery is getting low)

Thoughts on this idea?

I think that you don`t need external regulator

12V supply is needed to use voltage inputs.

Yes, but I can’t feed 12v to the 0-10v analog input (I assume, or I will damage it?)

Chris

You are right.
An alternative implementation is to use a voltage divider.
Two resistors in series and the middle point is connected to analog input.

1 Like

If you are going to use this voltage divider to monitor the battery then I have to make a new profile that has analog inputs and an external temperature probe.

If you make a @TapioX voltage divider, the resistors have to be about 33 Kohm (standard value) each, at least, so that the battery is not discharged excessively. (12 vdc / 66 Kohm = 0.00018 A)

1 Like

Hi Mariano, I use your drivers with satisfaction, I have recently added a temperature sensor to my fibaro smart implant
I use the 2 inputs on two wired motion sensors and the two outputs to control functions on the alarm system
I didn’t find this feature on the settings, 1 temperature sensor, 2 outputs and 2 motion sensors
I alternatively used the function 1 sensor, 2 outputs and 2 aperture sensors but the latter never update the status and give me an error
thanks

Hi @EnrCol

I’ll add this profile, but give me some time, it’s been a while since I modified the driver, I’ve forgotten it a little. I’ll have to look carefully at what code I have to add, I don’t want to mess it up.

I’ll let you know when it’s done

Hi,
While I add the new profile, that profile of temperature sensor, 2 inputs, contact sensor and 2 switch out should work. This user tried them.

1 Like

No, it doesn’t work for me, it doesn’t update the status of the 2 contact sensors and neither does the setting for the update intervals of the temperature sensor
Thank you for your time

And with the previous profile you used, did the contact advisor entries work for you?

If you were already using it before, you should have parameters 20 and 21 at values 0 (“Normally closed alarm”) or 1 (“Normally open alarm”)
I do not have this device, but I understand that the procedure to follow is to connect the temperature sensors and input sensors to inputs-1 and 2 and then pair it

Parameter “Interval of Temp Reports- 68” configures the reporting intervals, by default it is disabled, value 0
description: “This parameter 68 defines reporting period of External Sensors value. 0= disabled. 60-32400 (60s-9h). Deafault = 0”

Parameter 67 defines the reportable temperature changes, by default it is at value 5 (0.5ºC)

I don’t know if any user who is using it can help you better.

I use these settings for inputs

Settings for temperature

1 Like

Hi @EnrCol

Added new profile “Ext Temp + 2 Motion + 2 Switch”

This driver version updated automatically in 12 hours max.

Note: I have observed that the Android app does not update the profiles automatically when using personalized presentations, it may take longer for the new profile to be presented, but I don’t know.

───────────────────────────────────────────────────
 Name         Fibaro Smart Implant Mc
 Version      2024-01-27T11:38:41.027520028        
───────────────────────────────────────────────────

thanks Mariano, I have now seen the updated driver but as you say on Android it has not yet updated the customizations
In the meantime I found out that my problems with your driver have been fixed with this new update and now it works with contact sensors updates status.

@EnrCol

Try close and delete app cache or select multitile option

Have you changed to new profile?

Clear app storage cache and then change the profile

Thanks for this @Mariano_Colmenarejo

I have restarted my sensor project (measuring water pressure) and use the implant to measure voltage, so it is really great to be able to access this through smartthings. So far it is working well. I would only ask if it is possible in the future to make the choice of profiles more flexible with, for example, check boxes rather than radio buttons. I am currently only using one analog input, and may add a temperature probe later so there is some “noise” in the display. I don’t know if it’s possible, so just an idea for the future if you needed feedback.

Hi @jeremycook61

Profile changes on edge drivers are made the same way they are selected from preferences or with a list in the details view.

When you add the temperature probe, I think, you will have to uninstall the device, install the probe and reinstall the device, this is a requirement of the device for the probe to work, not the driver.
then changing the profile in the app would work correctly with the probe