(EDGE Driver-Mc): Aplicaciones Virtuales Mc (virtual Switch Mirror, Virtual Calendar and virtual Switch Board...)

Having typed all that out… I just edited my rules to send the refresh after the offset change.

I just let mine sit for a few minutes and once the next value in the driver changed everything updated including SR/SS. No manual/forced refresh needed.

Ouch, that hurt.

I had not tried to adjust the time setting, I typically don’t try adjusting the Automations for a couple of days just to see if it fixes itself or it’s a regression.

But I’ve set mine to 1:59 now. It’s probably a good thing to do before the you know what hits the fan at 2 o’clock

Hi All,

To limit the number of events emitted to the platform, there are events that are updated with each calculation, every 1 minute and others every 30 minutes and others every hour.

The sunrise and sunset time events are updated every hour, from minute 0 to minute 2, that is, 3 times, but the data for the calculations are updated every 1 minute just like the sunrise and sunset offsets and the time.

sunrise, sunset time and duration of the day, in the app history you will only see them once a day, with the change of day, since they do not change during the rest of the day and the history does not show repeated events.

Every time you do a refresh in the detail view, swiping down recalculates and updates everything.

To avoid misunderstandings, I have added that when the local time offset is changed, all data is recalculated and updated 2 seconds later.

───────────────────────────────────────────────────
 Name         Aplicaciones Virtuales Mc
 Version      2023-03-13T11:57:05.979077951
───────────────────────────────────────────────────
4 Likes

@Mariano_Colmenarejo is it possible to use your “Timer Number of Days” device to control my Easter lights using the following scenario?

I would have IFTTT start the “Timer Number of Days” on Palm Sunday pulling the data from my Google Calendar. I know that works.

Then after 10 days I would like the “Timer Number of Days” to automatically turn off and stay off until next spring. Is this part possible? And if it is possible how would I do that?

Hi @Paul_Oliver

I don’t know exactly how you want to use it once it’s activated for the first time and for next 10 days.

How does it work if you put a timer of 2 days for example.

  • The switch will remain "Off " state until 00:00 of second day of set timer

  • The switch will remain in the “On” state for 24 hours to be able to execute the routines as precondition throughout the day

  • The switch will go to the “Off” state the following day at 00:00 hours or if it is turned off voluntarily by the user.

  • The switch will change to “On” state at 00:00 of second day of set timer and every 2 days.

So when you enable it on Palm Sunday, what number of days are you going to put in the timer, 1 day or 10 days?

@Paul_Oliver

If you want to activate the 10 days Timer on Palm Sunday and activate it again after 10 days to deactivate everything routines until next year:

  • With IFTTT activate the timer with 10 days just on Easter day.
  • With this activation you can start the light routines with a virtual device.
  • After 10 days the Timer device will go to the On state and you can make a routine that deactivates the Timer setting to 0 days and deactivates all the light routines.

The following year when you activate with IFTTT it will return to the same activation and deactivation mechanism 10 days later.

Ok, I think I understand.

The virtual timer lives in the off state and you can turn it on for 24 Hrs. Then it will turn off again. Then the 10 days I enter in the driver will turn it back on 10 days later for 24 Hrs.

So, I would also need a virtual switch to turn on for the duration of my 10 day automation.

Thanks for explaining how it works.

1 Like

I hope this hasn’t been answered already, but there are a lot of messages in this thread. Anyway, whenever I try to create a SmartThings routine in the app using the virtual calendar device, and I pick Sunrise Time, a field pops up asking for a time (or something). I thought the VC would calculate sunrise for me? If I leave the files blank, SmartThings won’t save the routine. If I create a routine and use sunrise offset with a 1 minute offset, the routine saves and it works. What am I doing wrong with the sunrise time? By the way, I have set all the time/location options in the VC. Thanks.

Do you have the UTC offset (local hour offset) in the settings? If not use google to determine it for your time zone.

Or use sunrise time with Zero offset.

I have everything set, including UTC. If I look at settings for the Virtual Calendar, everything is correct, including sunrise. It’s just weird that if I select “Sunrise Time”, a dialog pops up asking for something, but I’m not sure what. It’s like it’s asking me to pick a Sunrise Time, which doesn’t make sense because I want the VC to pick the time for me. However, I didn’t know I could use 0 in Sunrise Offset Time. That’ll work just fine because the Sunrise Offset Time has been working (I’ve been testing it at 20 minutes before Sunrise). Thanks!

P.S. I’m also testing SmartThings Sunrise as well as SharpTools. SmartThings send me a text a minute or so after alleged Sunrise at 717 am and so did SharpTools.

Hi @rcbjr2

Sunrise or sunset time are text fields since there is no time or date capability.

to run routines for sunrise or sunset matches, use sunset offset=0 or sunrise offset =0

1 Like

Thanks for clarification! And as I said, I didn’t know I could use 0 as offset. Duh. :smirk:

1 Like

@Paul_Oliver @NickA

Yesterday we had the change to daylight saving time and with the routine that changes the local time offset at 3:01 a.m. It works well.

To change the time to winter, I will have to do the same, but adding the sumer Local Hour Offset as precondition, so that it does not change it every time it is 3:01 a.m. again.

4 Likes

Thanks for confirming that it worked, I had changed mine after your suggestion, so now I’ll wait until November.

Why the precondition??
You specified the day of october, so it will only run once, right??

In my case I added with the year. And when it fires up it shows me a notification saying : Change date to next year :grinning:

I don’t know what happened with this chance, but it didn’t work. And in the morning I just changed the time to 10am and it worked as expected. So I don’t know why it didn’t work at 2am…

It is not executed Because when the time is changed by adding one hour, at 2 a.m. automatically goes to 3 a.m. and therefore 2 a.m. that day does not exist.

When the adjustment is made to winter time, subtracting one hour from 3 a.m. you have to put something that guarantees that it will only be executed once.

If not done so, at 3 a.m. it will be 2 a.m. and when it’s 3 a.m. again of the new schedule, it would run again.

Although it is possible that the first time it will be 3 a.m. does not exist and it is again 2 a.m. and if the routine is set to 3:01 a.m. then it run only one time

2 Likes

Ok. I see what you mean. But here in Portugal the change was from 1am to 2am, so in my point of view it should have worked…
But just in case, now I set it to 3:05 :laughing:, in both changes. And added the precondition to the winter time.
Thanks!

2 Likes

Hi @Mariano_Colmenarejo , as usual your drivers are very helpful.
I am trying now to integrate the irrigation system with your switchboard.
I was wondering if it would be possible to insert in the settings shutdown timers for each generated Switch so as to create a kind of X minute pulstime, and if possible to insert an additional Switch that starts in sequesnce all the others (turn on switch1, when turning off swicth1 turn on swich2 etc…). So that you can manage the whole impainto without having to create an infinity of automatons