[EDGE DEVICE] Simple Harmony Bridge **Alpha Testing**

Are you using an Elite? If so you could use the HA buttons at the bottom of the handheld. It won’t be a single button solution as it would require you to press one of the HA buttons when you pause but it should work. That is how I do it as I don’t always want the lighting to change when I pause. I use virtual switches because you can’t directly invoke ST routines/automations with the Elite HA buttons. Let me know if you want details.

I have the ultimate so I don’t have the buttons but could add a custom one to the screen. It’s just hard to break the muscle memory of hitting the pause button.

AFAIK the Elite is the only Harmony remote that can link directly to HA devices. But full disclosure I use all Elites so am not 100% certain. Check the Harmony website.

Hi,

Thank you @lmullineux for this great driver.

I’m doing the opposite of most people and coming from home assistant back to Smartthings and was very happy to discover this driver.

I have a couple questions and issues which are more of an inconvenience.

Firstly, I have an issue that the history is not being populated either in the Smartthings app or on the my Smartthings website. I have verbose logging enabled. I’m using v2 of the driver. The Harmony Bridge is connected to my Harmony Hub as the device and activities list populated and these commands can be sent from Smartthings. I even have the activities as ‘devices’ in Smartthings which has been very useful. The history in the activities is being populated with the status, eg, on, off, starting and stopping. Whilst the history in the Bridge is not. I guess it’s not necessary, it is just good to have for debugging.

Another issue I’ve noticed is that if I use the PowerOff device that is generated by the bridge the command is communicated to the Harmony Hub but the Activity devices then go offline including the PowerOff device. The bridge remains connected and manually sending the activity turn on commands works and the individual activity devices come back online. If I use the PowerOff command through the bridge the command works as expected and the activity devices all stay online. So not a concern but just an inconvenience that I can’t use the PowerOff device activity. All the other activity devices work as expected and don’t show this behaviour.

Finally I’ve noticed that harmony bridge commands can act as routine triggers in Smartthings. How does this work? I created 2 test routines that send Smartthings app notifications when an activity starts and the play command on a specific device. So far these routines have not triggered.

I was hoping for the device play/pause status within Smartthings, is this possible with this Bridge?

Thanks,
Sam

That sounds like a bug, it’s probably just setting the offline status incorrectly if everything works as it should. I will look into this next time I’m working on the driver

That should work, can you send me your routine screenshot to take a look?

This is usually a Samsung issue when this happens, not sure what causes it.

Ok if you need anything from me I’m happy to help.



If I can provide anything else please let me know.

Damn ok. Nothing I can do about this then.

The first screen shot is not possible, as you cannot use device commands as triggers. ( Sorry, just no way that this driver can detect a single device command)

If you are triggering the device command from smart things then it’s possible to chain the automation to the event that triggers the pause.

The second screenshot is possible, but you should use the activity devices in the automation. The below screenshot will trigger when the activity completes it’s on routine

Or you can make it like this, where the routine will trigger when it is starting rather than completed it’s on routine. Basically the same but faster trigger (but if the activity fails to start on the harmony side, the routine will have still ran)

Ok thanks. I will rethink the play state then and reconfigure the routine to the activity device. Thanks for your help.

Is there some way to send specific channel or favourite commands? e.g. I want a routine to trigger the Watch TV activity and set to BBC or send 101? Usually with the remote you can just send the favourite and it will automatically start the activity.

There’s 2 ways your can do this…

  1. Add that as a step to your watch TV activity on the harmony side ( I think that still works)

  2. Send the individual remote codes to change the channel using a routine through this driver. However timing could become an issue

Number one should be more reliable

Sorry for being dim but are there instructions for doing 2?

Hmmm, it doesn’t work currently the way I was expecting because of the Samsung limit of not adding the same device to a routine twice, so you could set channel 1, but not 101 using the device command automations you can see above.

I could work around this in a future release of the driver, I’ll add it to my list of todo items

Is there a reason you don’t want to do the first option I mentioned above? Or would be more reliable that way

1 Like

First option is not really suitable as I don’t always want to watch the same channel when starting the activity. With so many different channels I’d end up with loads of specific activities which I think would be more confusing and cumbersome.

I believe one advantage of using Harmony activities would be that all the activities could include turning everything on and that portion of the activity wouldn’t run if the equipment was already on. So you could initiate “watch ESPN” or “watch ABC” etc without first having to turn on all the equipment with a different activity/command. (Less talking with Alexa :slightly_smiling_face:) But it definitely could be tedious to set those up for more than a handful of channels.

is this still available, when I try to enable the driver it says I don’t have access.

Yes it’s still available

I’ve never heard of that error, at what stage is it appearing? Can you send a screenshot?

I get this message when I click the link

image

Seems to be some sort of system glitch going on at the moment. Their is another thread discussing the issue. It is apparently effecting some edge drivers but not others.

1 Like

I have been running this driver for a while with no issues - thank you!

I have now added a new activity to my Harmony Remote and can not figure out how to made this edge device see it - Is there a way to refresh the driver once you add a new activity to the Harmony Remote without having to reinstall?

@scover

Turn on ‘config on connect’

Turn off activity devices, then turn it back on

That should do it

You can then turn off ‘config on connect’

1 Like