[EDGE DEVICE] Simple Harmony Bridge **Alpha Testing**

Weird - I can execute manually run routines from inside another routine

You can still run scenes (manually triggered Routines) from a normal routine I just created the following one with no problem. The only thing that changed was the name.

1 Like

All right thanks guys! I guess I need to do more investigation of my ST setup since it wasn’t working for me.

Were you able to figure this out? I am seeing the error now when I look at ST CLI.

Nevermind, I rebooted the Harmony Hub and it connected.

Good morning. Has something changed or is maybe the smartthings teams messing something up again?
The harmony hub stopped working, a restart did not work. I see the ip address setting is still correct and its connected with that ip in the router devices section. When i manually try to execute a command it shows a loading icon for too long and then fails with a network error.

@goosetapo

Nothing has changed in the driver… And i have not had a deluge of similar reports from others.

Turn on verbose logging - then check the history tab to see what is going on. This should tell you if it is a connectivity problem or not.

If it’s still not clear - connect on the CLI to logcat and see what the error is.

Make sure know additional security features have turned on, on your network - particularly if you use a mesh network.

Double check your ip address is correct and hasn’t changed on the harmony, ensure that you have rebooted the harmony and that the harmony app is working (and can connect locally). I have seen some cases that have required a reset of the harmony - then reload settings from your account - but this is usually when you cannot connect with the harmony app, or the harmony app is always behaving like you are outside your home. (even when you are at home)

Drop me a PM if you need any more help.

Do you prefer a pm? Here maybe others can be helped who face the same problem?
If you prefer pm i will continue there.
For now i have this from history after enabling verbose. This time the command to turn the tv on worked without a timeout or network error…but nothing happened. Still have to try the logitech app when im back home.
The ip settings are all good. Its weird this issue started after many months of no issue whatsoever.

I don’t mind if you post in public, just conscious of boring people :smiley:

Ok, the good news is, it definitely appears that you do not have a connectivity issue - so you can disregard the last message - everything here is connected fine and I can see messages being sent and received. So something else must be wrong.

What command is it that you are issuing? How are you issuing it? is it a device command, or activity command? How are you sending it? [routine, virtual device, activity device]

Manually executing it didnt work, and i usually have it work through routines. If presense sensor detects presense, turn on tv and virtual tv switch.

can you send me the history output when you send the command? (with verbose logging turned on)

Is ‘turn on the tv’ a device command or harmony activity?

Here you go. the text above in the log contains all commands known, and requires like 7 seconds of fast scrolling to ignore, haha.

I have tried the harmony app on my phone, and it connects fine and works to turn on the tv.

I can only see sent messages there, no recd messages.

Were there no received messages?

Have you rebooted your harmony hub?

Are you using v2 of the driver? What version are you on?

Next step would be to capture logs using logcat while you perform your actions. For those you should use a pm, or go through them and remove anything sensitive first e.g your harmony account email address

I rebooted it a second time and that seemed to do the trick. Works now again, thats weird. Maybe i cut it away from power a bit longer.
Thanks for the assistance!

1 Like

Hi there, I must confess you did a great job on the integration and I am very thankful… For the others, let me share my experience of what I use the integration for.

I used to have Logitech Harmony Hubs +Yonomi + Alexa Echos to control by voice my many appliances throughout the house. The number of LHHs is 6, number of Alexa devices is approx 9 (some are in the garden and do not need to control anything else). The configuration used Alexa to ask Yonomi (where scenes were defined too) to control the appliances through Logitech Harmony Hub. If you wonder why Yonomi - it was the only way to control multimple LHHs for Alexa.

Now yesterday, Yonomi finished the service after many years of good work, and I was left in the dark! But because of your excellent integration I could easily setup my appliances/Alexa network again, just in few hours! I really am sooo greatful!

Furthermore, what I found out - as I have SmartThings connected to Alexa - once you add a new Logitech Harmony Hub through your integration into ST, the activities (defined by LHH) are automatically found by Alexa and can be imported to routines without hassle. So no need to pickup coding and stuff - AND THIS IS ABSOLUTELY FANTASTIC!

I love you, guys.

3 Likes

@gourmet77

I’m glad it is working well for you, especially as you have what sounds like quite a complicated setup. Good luck migrating all of the routines