[EDGE DEVICE] Simple Harmony Bridge **Alpha Testing**

As I said this is not a driver issue, more of a Samsung app / phone issue. Something on your phone is stopping it from downloading the custom presentation from the Samsung server. Nothing I can do to help that. You could speak to Samsung support. Or try and resolve yourself.

I suspect you would have the same issue with any driver that uses custom presentations. Lucky for you not many drivers use custom presentations

If it’s network that is causing you could try clearing cache / reinstalling the app when connected to different WiFi or when on data.

@jbjohnson77 Try removing/deleting the app from your phone. On an iphone it should delete all associated settings/files. Then reinstall the app from the App Store. Hopefully that will get you a fresh install of the app.

1 Like

Tried that already.

Could it be a problem with latest SmartThings update? I didn’t have problem with iPad that’s not running the latest update. Just a thought…

@jbjohnson77 At this point, I would open a ticket with SmartThings Support. There is something funky between your phone and the cloud. It is obviously working properly from your iPad, so the cloud and device are likely fine.

As far as the latest update. I am having no problems with it.

I’ve tried 3 different iPhones, two different SmartThings log-ins (mine and the wife’s), and an iPad. Only one that works is the iPad. Only notable difference is the iPad is on different version of the ST app.

Are they all connecting via the same network? Do you use any kind of VPN or adguard?

You need to speak to Samsung support

Just switched over to this from the smartapp, working great so far. One question…when setting up my second hub, it skipped over the “PowerOff” activity device it set up for the first one. Is there a way to add that back in? I assume it saw the activity for the first hub and decided I already had it? Not a big deal, since I can turn everything off individually, but would be a bit more convenient.

Logger: Skipping - Activity Device already exists for - PowerOff

It’s a bug, I will fix it next time I work on the driver

1 Like

Cool. Thanks for all the effort!

Thank you so much for taking the time to create this for us! I am stuck on ‘Adding a Device’. I have installed the V2 driver, but when I scan for nearby devices, it is not finding anything. Not sure what I’m doing wrong?

It’s probably added already, check in all your rooms

Nowhere to be found darnit. I have re-enrolled and reinstalled - still no luck. I have tried hitting nothing on the Harmony Hub and hitting the pair button as well.

Thoughts on what I’m doing wrong?

It should find instantly, because it doesn’t actually find your hub at this point - you enter an IP later to actually find it.

Connect too your hub with logcat and see if it presents an error. Make your app is connected to the same location as your hub

They are definitely the same location. Can you explain logcat (sorry)?

I do have 3 Harmony hubs online - could that be messing it up?

No, at this stage it has nothing to do with harmony.

Have you added the channel and the driver?

Search for smartthings logcat, it lets you connect using the cli to smartthings edge drivers and view the logs

It was user error on my part - I was not adding the device to a specific room. Once I did, it worked perfect. I am now up and running with my activities. This is very impressive and appreciated work - thank you so much!!


Lovely post. tried setting up just over 24 hours ago. two questions

  1. for some reason see no device commands at Step 4. Stuck in logger bridge device (xxxxxxx) initialising. thoughts?
  2. looking at the post, the device command doesn’t seem intuitive. ie: in harmony, set up a routine “movie” running say lights, then pc through ir then receiver, etc, how would one know which device command pertains to say that harmony hub “movie” action? Thank you

You don’t need device commands for activities, only for sending individual device commands.

Turn on ‘movie activity’ - that’s an activity - activity devices will create automatically.

‘mute the bedroom TV’ that’s a device command

Anyway, it looks like the error you have is with connectivity. Have you configured your IP address correctly? Are you sure you’ve used the right ip? It should be the local one not the public one for your network.

Thank you for your fast response and clarification on device command.
Have two hubs, selected the correct one for home, reverified ip address/local in smartthings device list webpage. screenshot below