[EDGE DEVICE] Simple Harmony Bridge **Alpha Testing**

This is good news indeed! Great find

1 Like

So, if you’ve already setup your hubs and didn’t grab the history from your hub. Do you know if you can get the commands to show again to grab them?

Would it require deleting everything and setting it up again?

@lmullineux , any ideas?

@TN_Oldman
Switch on ‘config on connect’ in settings, it will force a config pull from harmony.

If it’s already on, switch it off and back on.

Don’t forget to switch it off when your finished, it won’t do any harm if you leave it on its just wasteful

2 Likes

Hi… Thank you for all the work! Works great.
Quick question… It seems the driver does not reconnect automatically when the harmony hub reboots. Seems to work fine if the smartthings hub reboots. Using v2 of the driver. Any suggestions?

Is your harmony hub on a static IP?

yes, it does have a static ip

That is an odd one. I have had no problems with reconnects after hub reboots.

Thanks @john915 for the feedback

I will try and re-create this issue on my side.

Can I ask how long the harmony hub was offline for? The reason I ask I have retry on connection timeout, which will eventually exhaust itself (it wont keep trying forever), but I also have logic to detect disconnection at the point you perform an action, then re-establish the connection.

So the reason for my question is to help me try and re-create the scenario you experienced.

EDIT: I don’t need these answers anymore, I was able to re-create the problem. Basically a bit of bad code in the reconnection loop was causing the driver to crash and restart, but if the driver restarts when the Harmony Hub is offline it gets stuck where it will not try to reconnect by itself. Working on a fix now

1 Like

V2 Driver Update

Based on feedback from users, and details on how to recreate from @john915 I have found an issue.

To summarize the issue in 2 parts

  • If the driver restarts for any reason while the harmony hub is unavailable (network, or turned off etc etc) it will get stuck in a state where it will not try to reconnect by itself. A few users of V2 have come to me with this problem and It was rectified by forcing a reconnection by re-setting the IP address
  • A separate bug in the reconnection code, that in some circumstances could cause the driver the crash and restart - this bug is also present in V1 but causes a lesser impact I will not be fixing V1 - sorry

Compounded together this results in the driver becoming stuck if the harmony device goes offline un-expectedly.

Thankfully, both issues were easy fixes and a new driver has just been published to the channel. It will auto update to your hub in the next 24 hours, of you can force an install in the APP or via the CLI.

2 Likes

It was a quick reboot of the harmony hub, under 1 minute. Forcing
connect with IP address update fixed it immediately.
Thank you again for creating this driver. It is very helpful to me.

@john915
Then the new version I just published should help in that scenario - thanks for reporting

1 Like

Same here. Have to remove and re-enter IP address to get it working again. I have static IP for it.

Problem should be fixed now, I would be grateful if you test with the V2 version with todays date

1 Like

Simulated the condition and tested. Problem has apparently been resolved after driver update.
Will report back after further testing.
Thanks a lot for your work.

1 Like

I’m trying to force update to get this change. I have seen three methods mentioned. Wait 12 hours, try to delete the driver in the hub, or use CLI. I know the CLI works but the other methods don’t seem to work. I’m on 1-14-23 date driver. I have routines and don’t want to redo them. Has anyone figured a better way to force update?

Are you already on V2 of the driver? (you should be with that date)

If you go to the your st hub in the app, then drivers, then choose my channel, then click available drivers

You should then have the option to install?

Have you already tried that?

Problem is fixed (repeated the test).
:+1::+1:

1 Like

Deleted the V1 driver and associated devices and Routines. Followed the post 1 process to add the V2 driver and devices and recreated the associated Routines. Everything is working fine. @lmullineux Thanks again for your work on this!

1 Like

I have already moved to V2, I have 1/14 but it doesn’t seem to update by itself to your newest V2. I tried to force it by deleting the driver (cannot delete driver is in use). I read that it should force the upgrade but doesn’t?
Is there a better way to force the update?

Use the CLI, or just wait for the auto update

1 Like